Long logon time when you use the AddPrinterConnection VBScript command to map printers for users during logon process in Windows Server 2012 R2 or Windows Server 2008 R2 SP1

Article translations Article translations
Article ID: 2896881 - View products that this article applies to.
Expand all | Collapse all

On This Page

Symptoms

Consider the following scenario:
  • You have a Windows Server 2012 R2 or Windows Server 2008 R2 Service Pack 1 (SP1)-based terminal server.
  • The terminal server is configured to use the AddPrinterConnection VBScript command to map printers for users during the logon process.
  • You try to log on to the terminal server.
In this scenario, it takes longer than expected to log on to the terminal server. Additionally, the terminal server experiences high CPU usage.

Notes
  • When this issue occurs, the terminal server is unresponsive until the printers are mapped.
  • The expected logon time is within one minute.

Cause

This issue occurs because the following operations are performed redundantly after the AddPrinterConnection VBScript command is called to create network printer mappings during the logon process:
  • Redundant registry keys are populated.
  • A printer driver is downloaded and reinstalled every time that a printer connection is added. This occurs even though the driver exists on the terminal server.

Resolution

To resolve this issue in Windows Server 2012 R2, install update 2955164. For more information about update 2955164, click the following article number to view the article in the Microsoft Knowledge Base:
2955164 Windows RT 8.1, Windows 8.1, and Windows Server 2012 R2 update rollup: May 2014
To resolve this issue in Windows Server 2008 R2, install the hotfix that is described in this article.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2008 R2 SP1.

For more information about how to obtain a Windows 7 or Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To apply this hotfix, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

Collapse this imageExpand this image
assets folding start collapsed
The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies to" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:
    Collapse this tableExpand this table
    VersionProductMilestoneService branch
    6.1.760 1.17xxxWindows Server 2008 R2SP1GDR
    6.1.760 1.22xxxWindows Server 2008 R2SP1LDR
  • GDR service branches contain only those fixes that are widely released to address widespread, critical issues. LDR service branches contain hotfixes in addition to widely released fixes.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintaining the state of the updated component. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows Server 2008 R2
Collapse this imageExpand this image
assets folding start collapsed
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Localspl.dll6.1.7601.22502965,63205-Nov-201310:48x64
Winprint.dll6.1.7601.1751439,42420-Nov-201013:27x64
Win32spl.dll6.1.7601.22502756,22405-Nov-201310:49x64
Win32spl.dll6.1.7601.22502756,22405-Nov-201310:49x64
Win32spl.dll6.1.7601.22502497,15205-Nov-201309:56x86
Win32spl.dll6.1.7601.22502497,15205-Nov-201309:56x86
Localspl.dll6.1.7601.22502776,70405-Nov-201309:54x86
Winprint.dll6.1.7601.1751430,20820-Nov-201012:21x86
Collapse this imageExpand this image
assets folding end collapsed
For all supported IA-64–based versions of Windows Server 2008 R2
Collapse this imageExpand this image
assets folding start collapsed
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Localspl.dll6.1.7601.225022,079,23205-Nov-201309:47IA-64
Winprint.dll6.1.7601.1751490,62420-Nov-201010:28IA-64
Win32spl.dll6.1.7601.225021,527,80805-Nov-201309:49IA-64
Win32spl.dll6.1.7601.22502497,15205-Nov-201309:56x86
Collapse this imageExpand this image
assets folding end collapsed
Collapse this imageExpand this image
assets folding end collapsed

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Collapse this imageExpand this image
assets folding start collapsed

Additional file information for Windows Server 2008 R2

Additional files for all supported x64-based versions of Windows Server 2008 R2
Collapse this imageExpand this image
assets folding start collapsed
Collapse this tableExpand this table
File propertyValue
File nameAmd64_541004444788cae44ca1182575f71090_31bf3856ad364e35_6.1.7601.22502_none_10f12962507b274b.manifest
File versionNot applicable
File size722
Date (UTC)05-Nov-2013
Time (UTC)14:42
File nameAmd64_a37afca7131fd37a7bcd6ac1dbb3a57c_31bf3856ad364e35_7.1.7601.22502_none_4216a0669766fbff.manifest
File versionNot applicable
File size1,086
Date (UTC)05-Nov-2013
Time (UTC)14:42
File nameAmd64_ab558592de6b9e805d35a8e10046b36e_31bf3856ad364e35_6.1.7601.22502_none_85bb5f25976e9a9d.manifest
File versionNot applicable
File size720
Date (UTC)05-Nov-2013
Time (UTC)14:42
File nameAmd64_ac00991b52acc3b71061711509c5c069_31bf3856ad364e35_6.1.7601.22502_none_06dcfd978501edb7.manifest
File versionNot applicable
File size722
Date (UTC)05-Nov-2013
Time (UTC)14:42
File nameAmd64_ddf061c2565bcb8890cfe596cab13e47_31bf3856ad364e35_6.1.7601.22502_none_a3976213d291bbad.manifest
File versionNot applicable
File size722
Date (UTC)05-Nov-2013
Time (UTC)14:42
File nameAmd64_microsoft-windows-p..ooler-core-localspl_31bf3856ad364e35_6.1.7601.22502_none_8ed3b6dfc26510c1.manifest
File versionNot applicable
File size4,845
Date (UTC)05-Nov-2013
Time (UTC)14:48
File nameAmd64_microsoft-windows-p..ooler-networkclient_31bf3856ad364e35_6.1.7601.22502_none_982b939da0a0fbd8.manifest
File versionNot applicable
File size10,428
Date (UTC)05-Nov-2013
Time (UTC)11:18
File nameAmd64_microsoft-windows-p..ooler-networkclient_31bf3856ad364e35_7.1.7601.22502_none_899c0fe32b87a4a7.manifest
File versionNot applicable
File size6,373
Date (UTC)05-Nov-2013
Time (UTC)11:16
File nameWow64_microsoft-windows-p..ooler-networkclient_31bf3856ad364e35_6.1.7601.22502_none_a2803defd501bdd3.manifest
File versionNot applicable
File size10,426
Date (UTC)05-Nov-2013
Time (UTC)10:08
File nameWow64_microsoft-windows-p..ooler-networkclient_31bf3856ad364e35_7.1.7601.22502_none_93f0ba355fe866a2.manifest
File versionNot applicable
File size6,371
Date (UTC)05-Nov-2013
Time (UTC)10:09
File nameX86_microsoft-windows-p..ooler-core-localspl_31bf3856ad364e35_6.1.7601.22502_none_32b51b5c0a079f8b.manifest
File versionNot applicable
File size4,844
Date (UTC)05-Nov-2013
Time (UTC)14:48
Collapse this imageExpand this image
assets folding end collapsed
Additional files for all supported IA-64–based versions of Windows Server 2008 R2
Collapse this imageExpand this image
assets folding start collapsed
Collapse this tableExpand this table
File propertyValue
File nameIa64_cae9194819158f3202802d15e7007074_31bf3856ad364e35_6.1.7601.22502_none_05cb7eda36e5d4e2.manifest
File versionNot applicable
File size1,084
Date (UTC)05-Nov-2013
Time (UTC)14:42
File nameIa64_e5da294de1b3bfb9270e8f6cfdc7a006_31bf3856ad364e35_6.1.7601.22502_none_0f040e0b29f82613.manifest
File versionNot applicable
File size720
Date (UTC)05-Nov-2013
Time (UTC)14:42
File nameIa64_microsoft-windows-p..ooler-core-localspl_31bf3856ad364e35_6.1.7601.22502_none_32b6bf520a05a887.manifest
File versionNot applicable
File size4,844
Date (UTC)05-Nov-2013
Time (UTC)14:42
File nameIa64_microsoft-windows-p..ooler-networkclient_31bf3856ad364e35_6.1.7601.22502_none_3c0e9c0fe841939e.manifest
File versionNot applicable
File size10,426
Date (UTC)05-Nov-2013
Time (UTC)10:23
File nameWow64_microsoft-windows-p..ooler-networkclient_31bf3856ad364e35_6.1.7601.22502_none_a2803defd501bdd3.manifest
File versionNot applicable
File size10,426
Date (UTC)05-Nov-2013
Time (UTC)10:08
Collapse this imageExpand this image
assets folding end collapsed
Collapse this imageExpand this image
assets folding end collapsed

Properties

Article ID: 2896881 - Last Review: May 13, 2014 - Revision: 3.0
Applies to
  • Windows Server 2012 R2 Datacenter
  • Windows Server 2012 R2 Essentials
  • Windows Server 2012 R2 Foundation
  • Windows Server 2012 R2 Standard
  • Windows Server 2008 R2 Service Pack 1, when used with:
    • Windows Server 2008 R2 Enterprise
    • Windows Server 2008 R2 Datacenter
    • Windows Server 2008 R2 for Itanium-Based Systems
    • Windows Server 2008 R2 Foundation
    • Windows Server 2008 R2 Standard
Keywords: 
kbautohotfix kbqfe kbhotfixserver kbfix kbsurveynew kbexpertiseadvanced KB2896881

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com