Symptoms
Assume that you have a Windows Server 2012 R2-based Active Directory Federation Services (AD FS) server that is running in a network environment. Transient network connectivity interruptions frequently occur. In this situation, the AD FS proxy is no longer trusted by the AD FS server and the AD FS proxy goes offline. Therefore, authentication requests cannot be processed by the AD FS proxy.
Note After this issue occurs, you have to run the following Windows PowerShell cmdlet to recover the trust between the AD FS proxy and the AD FS server:install-webapplicationproxy
Cause
This issue occurs because an incorrect error code is returned to the AD FS proxy. Therefore, the retry mechanism is not invoked.
Resolution
Hotfix information
A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.
If the hotfix is available for download, there is a "Hotfix Download Available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix. Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website:http://support.microsoft.com/contactus/?ws=supportNote The "Hotfix Download Available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
Prerequisites
To apply this hotfix, you must be running Windows Server 2012 R2.
Registry information
To use the hotfix in this package, you do not have to make any changes to the registry.
Restart requirement
You must restart the computer after you apply this hotfix.
Hotfix replacement information
This hotfix does not replace a previously released hotfix.
The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2012 R2 file information notesImportant Windows 8.1 hotfixes and Windows Server 2012 R2 hotfixes are included in the same packages. However, only "Windows 8.1" is listed on the Hotfix Request page. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 8.1" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
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The files that apply to a specific product, milestone (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:
Version
Product
Milestone
Service branch
6.3.960 0.16 xxx
Windows Server 2012 R2
RTM
GDR
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The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2012 R2" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows Server 2012 R2
File name |
File version |
File size |
Date |
Time |
Platform |
---|---|---|---|---|---|
Microsoft.identityserver.web.dll |
6.3.9600.16473 |
806,912 |
21-Nov-2013 |
11:05 |
x86 |
Status
Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.
More Information
For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
Additional file information for Windows Server 2012 R2
Additional files for all supported x64-based versions of Windows Server 2012 R2
File property |
Value |
---|---|
File name |
Amd64_72aa339fc912c1178a01399833a3528d_31bf3856ad364e35_6.3.9600.16473_none_2b2a9d39257e6cb7.manifest |
File version |
Not applicable |
File size |
701 |
Date (UTC) |
21-Nov-2013 |
Time (UTC) |
20:18 |
Platform |
Not applicable |
File name |
Msil_microsoft.identityserver.web_31bf3856ad364e35_6.3.9600.16473_none_0cf7a84afc1797bc.manifest |
File version |
Not applicable |
File size |
3,315 |
Date (UTC) |
21-Nov-2013 |
Time (UTC) |
12:48 |
Platform |
Not applicable |
File name |
Package_1_for_kb2912221~31bf3856ad364e35~amd64~~6.3.1.0.mum |
File version |
Not applicable |
File size |
2,031 |
Date (UTC) |
21-Nov-2013 |
Time (UTC) |
20:18 |
Platform |
Not applicable |
File name |
Package_for_kb2912221_rtm~31bf3856ad364e35~amd64~~6.3.1.0.mum |
File version |
Not applicable |
File size |
1,668 |
Date (UTC) |
21-Nov-2013 |
Time (UTC) |
20:18 |
Platform |
Not applicable |