Article ID: 2916846 - View products that this article applies to.
Expand all | Collapse all

On This Page

Symptoms


Assume that you install the Remote Desktop Session Host (RDSH) role service on a computer that is running Windows Server 2012, and then configure the computer to obtain licenses from a Remote Desktop Services Licensing Server. When you try to connect to the computer by using Remote Desktop or Remote App, you may receive an error message that indicates there is no Remote Desktop Services Client Access License.

Cause

This issue occurs because the RDSH server is missing certificates when a connection arrives and it cannot request a license for that connection to the Licensing server.

Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix Download Available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix Download Available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2012.

Registry information

To apply this hotfix, you do not have to make any changes to the registry.

Restart requirement

You have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

Collapse this imageExpand this image
assets folding start collapsed
The global version of this hotfix installs files that have the attributes listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2012 file information notes
Important Windows Server 2012 hotfixes are included in the same Windows 8 hotfix packages. However, only Windows 8 is listed on the Hotfix Request page. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 8". Always refer to the "Applies To" section in an article to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, milestone (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:
    Collapse this tableExpand this table
    VersionProductMilestoneService branch
    6.2.920 0.20 xxxWindows Server 2012RTMLDR
  • GDR service branches contain only those fixes that are widely released to address widespread, critical issues. LDR service branches contain hotfixes in addition to widely released fixes.
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2012" section. MUM, MANIFEST, and the associated security catalog (.cat) files, are very important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows Server 2012
Collapse this imageExpand this image
assets folding start collapsed
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Rdpcorets.dll6.2.9200.209273,246,08027-Jan-201405:22x64
Rdpudd.dll6.2.9200.20927235,52027-Jan-201404:36x64
Rdpvideominiport.sys6.2.9200.1638427,88826-Jul-201203:17x64
Rfxvmt.dll6.2.9200.1638436,35226-Jul-201203:07x64
Tlscsp.dll6.2.9200.2092748,64027-Jan-201405:22x64
Tlscsp.dll6.2.9200.2092647,61627-Jan-201401:15x86
Collapse this imageExpand this image
assets folding end collapsed
Collapse this imageExpand this image
assets folding end collapsed

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.

More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Collapse this imageExpand this image
assets folding start collapsed

Additional file information for Windows Server 2012

Collapse this imageExpand this image
assets folding start collapsed

Additional files for all supported x64-based versions of Windows Server 2012

Collapse this tableExpand this table
File propertyValue
File nameAmd64_0936a8ad60dbe0504829e3ba45833116_31bf3856ad364e35_6.2.9200.20927_none_ec56ecb9d062b883.manifest
File versionNot applicable
File size724
Date (UTC)27-Jan-2014
Time (UTC)13:23
File nameAmd64_5fc95f082cdaebc0d63135afd3515ce7_31bf3856ad364e35_6.2.9200.20927_none_a52ea64a52a64020.manifest
File versionNot applicable
File size1,088
Date (UTC)27-Jan-2014
Time (UTC)13:23
File nameAmd64_dc5906673252656ed82c1206c16a2d9b_31bf3856ad364e35_6.2.9200.20927_none_11b7e15c961ea9c8.manifest
File versionNot applicable
File size722
Date (UTC)27-Jan-2014
Time (UTC)13:23
File nameAmd64_e24dfc0a7c261d0be516be3c18f1b5ed_31bf3856ad364e35_6.2.9200.20927_none_21009b209bce7022.manifest
File versionNot applicable
File size729
Date (UTC)27-Jan-2014
Time (UTC)13:23
File nameAmd64_microsoft-windows-r..s-regkeys-component_31bf3856ad364e35_6.2.9200.20927_none_892558b7aa7d9874.manifest
File versionNot applicable
File size13,555
Date (UTC)27-Jan-2014
Time (UTC)13:23
File nameAmd64_microsoft-windows-t..ces-serverlicensing_31bf3856ad364e35_6.2.9200.20927_none_4b60a4f1d826da21.manifest
File versionNot applicable
File size2,361
Date (UTC)27-Jan-2014
Time (UTC)05:54
File nameX86_microsoft-windows-t..ces-serverlicensing_31bf3856ad364e35_6.2.9200.20927_none_ef42096e1fc968eb.manifest
File versionNot applicable
File size2,359
Date (UTC)27-Jan-2014
Time (UTC)01:47

Collapse this imageExpand this image
assets folding end collapsed

Collapse this imageExpand this image
assets folding end collapsed

Properties

Article ID: 2916846 - Last Review: March 11, 2014 - Revision: 1.0
Applies to
  • Windows Server 2012 Datacenter
  • Windows Server 2012 Essentials
  • Windows Server 2012 Foundation
  • Windows Server 2012 Standard
Keywords: 
kbautohotfix kbqfe kbhotfixserver kbfix kbsurveynew kbexpertiseadvanced KB2916846

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com