Symptoms
When you log on by using a mandatory profile, you cannot offer Remote Assistance to another user.Â
Note Offered Remote Assistance is also known as unsolicited Remote Assistance. When you use the user interface or the command prompt (MSRA /offerRA computer_name), you receive the following error message. This message is possibly misleading. It states that Remote Assistance is not possible when a guest profile is used.There was a problem starting Remote Assistance - Remote Assistance is unavailable for the current user account. If you are using a Windows Guest account, try logging in with another account. If you are not using a Guest account, try restarting your machine.
Cause
This problem occurs because Remote Assistance that is not unsolicited requires the cryptographic library to encrypt a Remote Assistance ticket. Cryptography is not enabled when mandatory or guest profiles are used because private key material cannot be persisted. However, for unsolicited Remote Assistance, cryptography is not actually required, and the error message is displayed incorrectly.
Resolution
Hotfix information
A supported hotfix is available from Microsoft Support. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.
If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix. Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, go to the following Microsoft website:http://support.microsoft.com/contactus/?ws=supportNote The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
Prerequisites
To apply this hotfix, you must have Service Pack 1 for Windows Server 2008 R2 installed.
Restart requirement
You do not have to restart the computer after you apply this hotfix.
Hotfix replacement information
This hotfix does not replace any previously released hotfix.
The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2008 R2 file information and notesImportant Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
-
The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.
Version
Product
SR_Level
Service branch
6.1.760
1. 22xxxWindows Server 2008 R2
SP1
LDR
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GDR service branches contain only those fixes that are widely released to address widespread, extremely important issues. LDR service branches contain hotfixes in addition to widely released fixes.
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The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows 7 and Windows Server 2008 R2" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows Server 2008 R2
File name |
File version |
File size |
Date |
Time |
Platform |
---|---|---|---|---|---|
Msra.exe |
6.1.7601.22609 |
652,800 |
24-Feb-2014 |
02:31 |
x64 |
Racpldlg.dll |
6.1.7601.22609 |
119,808 |
24-Feb-2014 |
02:32 |
x64 |
Msra.exe |
6.1.7601.22609 |
652,800 |
24-Feb-2014 |
02:31 |
x64 |
Racpldlg.dll |
6.1.7601.22609 |
119,808 |
24-Feb-2014 |
02:32 |
x64 |
Msra.exe |
6.1.7601.22609 |
108,032 |
24-Feb-2014 |
02:00 |
x86 |
Msralegacy.tlb |
6.1.7601.22609 |
7,168 |
24-Feb-2014 |
01:02 |
Not applicable |
Racpldlg.dll |
6.1.7601.22609 |
111,616 |
24-Feb-2014 |
02:00 |
x86 |
Sdchange.exe |
6.1.7601.22609 |
40,960 |
24-Feb-2014 |
02:00 |
x86 |
Msra.exe |
6.1.7601.22609 |
108,032 |
24-Feb-2014 |
02:00 |
x86 |
Msralegacy.tlb |
6.1.7601.22609 |
7,168 |
24-Feb-2014 |
01:02 |
Not applicable |
Racpldlg.dll |
6.1.7601.22609 |
111,616 |
24-Feb-2014 |
02:00 |
x86 |
Sdchange.exe |
6.1.7601.22609 |
40,960 |
24-Feb-2014 |
02:00 |
x86 |
Additional file information
Additional file information for Windows Server 2008 R2
Additional files for all supported x64-based versions of Windows Server 2008 R2
File name |
Amd64_microsoft-windows-remoteassistance-exe_31bf3856ad364e35_6.1.7601.22609_none_961773fc319674b5.manifest |
File version |
Not applicable |
File size |
64,182 |
Date (UTC) |
25-Feb-2014 |
Time (UTC) |
07:36 |
Platform |
Not applicable |
File name |
Amd64_microsoft-windows-remoteassistance-exe_31bf3856ad364e35_7.1.7601.22609_none_8787f041bc7d1d84.manifest |
File version |
Not applicable |
File size |
60,100 |
Date (UTC) |
25-Feb-2014 |
Time (UTC) |
07:36 |
Platform |
Not applicable |
File name |
Wow64_microsoft-windows-remoteassistance-exe_31bf3856ad364e35_6.1.7601.22609_none_a06c1e4e65f736b0.manifest |
File version |
Not applicable |
File size |
55,754 |
Date (UTC) |
24-Feb-2014 |
Time (UTC) |
02:13 |
Platform |
Not applicable |
File name |
Wow64_microsoft-windows-remoteassistance-exe_31bf3856ad364e35_7.1.7601.22609_none_91dc9a93f0dddf7f.manifest |
File version |
Not applicable |
File size |
53,261 |
Date (UTC) |
24-Feb-2014 |
Time (UTC) |
02:14 |
Platform |
Not applicable |
Status
Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.
References
Learn about the terminology that Microsoft uses to describe software updates.