Help and Support
 

powered byLive Search

Сообщение об ошибке "Не удается запустить Windows из-за аппаратных ошибок настройки диска"

Код статьи:314477
Последнее изменение ::15 мая 2008 г.
Редакция:3.0
Версия статьи для системы Windows 2000: 124550 (http://support.microsoft.com/kb/124550/).
На этой странице

Проблема

В процессе запуска Windows XP выводится одно из указанных ниже сообщений об ошибке.

Сообщение об ошибке 1

Не удается запустить Windows из-за аппаратных ошибок настройки диска.

Не удается выполнить чтение с выбранного загрузочного диска. Проверьте указанный путь и исправность оборудования диска.

Дополнительные сведения о требованиях к параметрам жесткого диска см. в документации по системе Windows и документации по имеющемуся оборудованию.

Сообщение об ошибке 2

Не удается запустить Windows NT из-за испорченного или отсутствующего файла:

Winnt_root\System32\Ntoskrnl.exe

Установите заново копию указанного выше файла.

Сообщение об ошибке 3

Winnt_root\System32\Hal.dll отсутствует или поврежден.

Установите заново копию указанного выше файла.
Кроме того, могут возникнуть указанные ниже проблемы.
При запуске компьютера в режиме агента восстановления командная строка не позволяет войти в программу установки Windows.
При попытке открыть папку Windows появляется следующее сообщение об ошибке:
Отказано в доступе.
При попытке выполнить операцию Восстановить c компакт-диска Windows XP не удается обнаружить установленную копию Windows и восстановить систему.

Перейти к началу страницы

Причина

Подобное поведение наблюдается в случае выполнения одного или нескольких из указанных ниже условий.
Отсутствует или повреждено значение Default в разделе загрузки в файле Boot.ini.
В расположении, указанном в файле Boot.ini, отсутствует установленная копия Windows XP.
Отсутствует или поврежден файл Ntoskrnl.exe.
Неверно указан путь к разделу в файле Boot.ini.
Общий сбой оборудования.

Перейти к началу страницы

Решение

Чтобы решить эту проблему, используйте один из указанных ниже способов.

Перейти к началу страницы

Способ 1

Восстановите или исправьте запись Default в файле Boot.ini и убедитесь, что в других записях раздела [Operating Systems] в файле Boot.ini указан путь к соответствующим каталогам.

Дополнительные сведения о редактировании файла Boot.ini см. в следующей статье базы знаний Майкрософт:
289022 (http://support.microsoft.com/kb/289022/) Редактирование файла Boot.ini в Windows XP

Перейти к началу страницы

Способ 2

Чтобы исправить файл Boot.ini, воспользуйтесь программой Bootcfg агента восстановления.
1.Запустите компьютер с помощью компакт-диска Windows XP.
2.Для восстановления системы Windows с помощью агента восстановления нажмите клавишу R при выводе соответствующего запроса.
3.Выберите необходимую копию Windows и при появлении запроса введите пароль администратора.
4.Введите команду bootcfg /rebuild и нажмите клавишу ВВОД.
5.После обнаружения копии Windows появляются следующие команды:
Добавить систему в список загрузки? [Y(да)/N(нет)/All(все)].
[Введите Y (да) в ответ на это сообщение.]

Введите идентификатор загрузки:
[Название операционной системы. Введите Windows XP Professional или Windows XP Home Edition.]

Введите параметры загрузки операционной системы:
[Оставьте поле пустым и нажмите клавишу ВВОД].
После выполнения перечисленных выше действий перезагрузите компьютер и выберите первый вариант в меню загрузки. После этого система Windows XP должна загрузиться в обычном режиме.

После успешной загрузки системы Windows XP в файле Boot.ini можно удалить неверную запись.
Дополнительные сведения о редактировании файла Boot.ini см. в следующей статье базы знаний Майкрософт:
289022 (http://support.microsoft.com/kb/289022/) Редактирование файла Boot.ini в Windows XP

Перейти к началу страницы

Способ 3

1.Загрузите компьютер с помощью компакт-диска Windows XP. Нажмите любую клавишу для загрузки с компакт-диска.
2.После загрузки установочных файлов нажмите клавишу R для запуска агента восстановления.
3.В агенте восстановления выберите загружаемую систему (как правило, под номером 1) и нажмите клавишу ВВОД.
4.Воспользуйтесь учетной записью администратора, введя соответствующий пароль, и нажмите клавишу ВВОД.
5.В командной строке агента восстановления введите указанную ниже команду и затем нажмите клавишу ВВОД.

Для однопроцессорных систем:
expand <дисковод_компакт-дисков>:\i386\ntoskrnl.ex_ <жесткий_диск>:\Windows\system32\ntoskrnl.exe
Для многопроцессорных систем:
expand <дисковод_компакт-дисков>:\i386\ntkrnlmp.ex_ <жесткий_диск>:\Windows\system32\ntoskrnl.exe
Примечание. В этих двух командах <дисковод_компакт-дисков> — буква дисковода компакт-дисков, а <жесткий_диск> — буква жесткого диска, на котором установлена система Windows.
6.При выводе запроса на перезапись файла нажмите клавишу Y.
7.Чтобы выйти из командной строки, введите команду exit и нажмите клавишу ВВОД.

Перейти к началу страницы

Способ 4

Запустите компьютер с помощью агента восстановления и выполните команду CHKDSK /r.

Примечание. Указывать в командной строке Chkdsk параметр /p нет необходимости, поскольку параметр /r служит для обнаружения программой Chkdsk поврежденных секторов и восстановления считываемых данных. Эта команда включает в себя и функции параметра /p.

Перейти к началу страницы

Дополнительная информация

Если в разделе [Boot Loader] файла Boot.ini отсутствует значение Default, в меню загрузки Windows XP появится новая запись Windows (default), и по умолчанию будет загружена соответствующая операционная система. Запись Windows (default) определяет следующий путь для загрузки системы Windows XP:
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
Дополнительные сведения о файле Boot.ini см. в следующей статье базы знаний Майкрософт:
102873 (http://support.microsoft.com/kb/102873/) Файл BOOT.INI и принятые имена ARC-путей, а также их использование
Дополнительные сведения об агенте восстановления в системе Windows XP см. в следующей статье базы знаний Майкрософт:
307654 (http://support.microsoft.com/kb/307654/) Установка и использование консоли восстановления в Windows XP

Перейти к началу страницы


Информация в данной статье относится к следующим продуктам.
Microsoft Windows XP 64-Bit Edition
Microsoft Windows XP Professional
Microsoft Windows XP Home Edition

Перейти к началу страницы

Ключевые слова: 
kbhardware kberrmsg kbfaq kbprb KB314477

Перейти к началу страницы

Переводы статьи

 

Related Support Centers

Other Support Options

  • Need More Help?
    Contact a Support professional by Email, Online or Phone.
  • Customer Service
    For non-technical assistance with product purchases, subscriptions, online services, events, training courses, corporate sales, piracy issues, and more.
  • Newsgroups
    Pose a question to other users. Discussion groups and Forums about specific Microsoft products, technologies, and services.