Id. de artículo: 315353 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

Síntomas

Cuando intenta instalar un programa, como Microsoft Plus! para Windows XP o Microsoft Office 2003, en Microsoft Windows XP, puede recibir el mensaje de error siguiente:
No se tiene acceso al servicio de Windows Installer.
Esto se puede producir si está ejecutando Windows en el modo a prueba de errores
o si Windows Installer no está correctamente
instalado. Póngase en contacto con el personal de soporte técnico para obtener asistencia.

Causa

Este problema se puede producir cuando se cumplen las dos condiciones siguientes:
  • Está utilizando Windows XP en el modo Normal.
  • El servicio Windows Installer que se incluye con Windows XP no está registrado o está dañado.

Solución

Para resolver este problema, siga estos pasos:
  1. Inicie sesión en el equipo como administrador.
  2. Haga clic en Inicio y, a continuación, en Ejecutar.
  3. En el cuadro Abrir, escriba cmd y haga clic en Aceptar.
  4. En el símbolo del sistema, escriba msiexec.exe /unregister y, a continuación, presione ENTRAR.
  5. Escriba msiexec /regserver y, a continuación, presione ENTRAR.
  6. Compruebe que la cuenta del sistema tiene permisos de acceso de control completos para la sección
    HKEY_CLASSES_ROOT
    en el Registro de Windows. En algunos casos, también puede tener que agregar cuentas de Administrador. Para ello:Importante: esta sección, método o tarea contiene pasos que le indican cómo modificar el Registro. Sin embargo, se pueden producir graves problemas si modifica el Registro incorrectamente. Por tanto, asegúrese de que sigue estos pasos cuidadosamente. Para obtener más protección, haga una copia de seguridad del Registro antes de modificarlo. De este modo, podrá restaurarlo si se produce algún problema. Para obtener más información acerca de cómo realizar una copia de seguridad del Registro y restaurarlo, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
    322756 Cómo realizar una copia de seguridad del Registro y restaurarlo en Windows
    1. Haga clic en Inicio y en Ejecutar, escriba regedit en el cuadro Abrir y haga clic en Aceptar.
    2. Haga clic en la sección del Registro siguiente:
      HKEY_CLASSES_ROOT
    3. En el menú Edición, haga clic en Permisos.
    4. Si Sistema no aparece en la lista Nombres de grupos o usuarios, haga clic en Agregar, asegúrese de que el nombre del equipo local aparece en el cuadro Desde esta ubicación, escriba sistema en el cuadro Escribir los nombres de objeto para seleccionar, haga clic en Comprobar nombres y, a continuación, haga clic en Aceptar.
    5. Haga clic en Sistema en la lista Nombres de grupos o usuarios y, a continuación, en el cuadro Permisos de sistema, en Permitir, active la casilla de verificación Control total.
    6. Haga clic en Aplicar, haga clic en Aceptar y, a continuación, cierre el Editor del Registro.
  7. Reinicie el equipo. Si el problema no se ha resuelto, repare Windows XP. Para obtener más información acerca de cómo reparar Windows XP, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
    978788 Cómo realizar una actualización en contexto (reinstalación) de Windows XP

Propiedades

Id. de artículo: 315353 - Última revisión: miércoles, 26 de marzo de 2014 - Versión: 7.0
La información de este artículo se refiere a:
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
  • Microsoft Office Outlook 2003
  • Microsoft Office PowerPoint 2003
  • Microsoft Office Publisher 2003
  • Microsoft Office Professional Edition 2003
  • Microsoft Office Small Business Edition 2003
  • Microsoft Office Basic Edition 2003
  • Microsoft Office Access 2003
Palabras clave: 
kbpubtypekc kbtshoot kberrmsg kbprb KB315353

Enviar comentarios

 

Kontaktieren Sie uns, um weitere Hilfe zu erhalten

Kontaktieren Sie uns, um weitere Hilfe zu erhalten
Wenden Sie sich an den Answer Desk, um professionelle Hilfe zu erhalten.