ID do artigo: 319624 - Última revisão: sexta-feira, 18 de novembro de 2005 - Revisão: 6.1

Mensagem de erro "O serviço Windows Installer não pode ser acessado" ao instalar um aplicativo

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.

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Sintomas

Após a atualização para Windows Installer versão 2.0, o Serviço Windows Installer pode não iniciar e a segunte mensagem de erro pode ser exibida:
Não foi possível acessar o serviço Windows Installer. Isso pode ocorrer se você estiver executando o Windows em modo de segurança ou o se Windows Installer não estiver instalado corretamente. Contate o suporte técnico para obter assistência.
Observação Esse comportamento não ocorre nos seguintes produtos:
  • Microsoft Windows XP
  • Microsoft Windows Millennium Edition
  • Microsoft Windows 98

Causa

Esse comportamento pode ocorrer quando uma das seguintes condições existir:
  • Nas permissões DCOM, o nível de autenticação padrão está configurado como Nenhum e o nível de Representação padrão está configurado como Anônimo.
  • A conta do sistema não tem permissões totais em uma pasta ou em uma chave do registro que o Windows Installer está tentando acessar. Isso é específico do NTFS.

Resolução

Dependendo do problema, use um ou todos os métodos a seguir:
  • Método 1: Desfazer o registro e registrar novamente o Windows Installer.
  • Método 2: Verificar as permissões DCOM.
  • Método 3: Fornecer permissões de controle total para a conta SISTEMA.
  • Método 4: Verificar as permissões do Registro.
  • Método 5: Corrigir a chave de segurança quebrada para o serviço MsiServer.

Antes de começar: Verifique se o service pack está instalado

Se estiver usando o Windows 2000, verifique se o SP 2 está instalado.
Se estiver usando o Windows NT 4.0, verifique se o SP 6 está instalado.

Se você não instalar os services packs apropriados, as etapas na seção "Informações Adicionais" deste artigo podem não funcionar da maneira esperada.

Mais Informações

Método 1: Desfazer o registro e registrar novamente o Windows Installer.

  1. Clique em Iniciar, em Executar, digite MSIEXEC /UNREGISTER e clique em OK. Mesmo se fizer isso corretamente, pode parecer que nada ocorre.
  2. Clique em Iniciar, em Executar, digite MSIEXEC /REGSERVER e clique em OK. Mesmo se fizer isso corretamente, poderá parecer que nada ocorre, ou um ampulheta aparecerá brevemente. Após executar esse comando, a operação estará completa.
  3. Tente seu aplicativo com base no Windows Installer novamente.

Método 2: Verificar as permissões DCOM

Esse método envolve a alteração do nível de representação padrão do DCOM para identificar, removendo o arquivo Msisip.dll e reinstalando o SP 3 para o Windows 2000.

Para fazer isso, execute as seguintes etapas:
  1. Clique em Iniciar, em Executar, digite dcomcnfg e em seguida clique em OK.
  2. Na guia Propriedades Padrão:
    1. Na lista Nível de autenticação padrão, clique em Conectar-se.
    2. Na lista Nível de representação padrão, clique em Identificar e em seguida clique em OK.
  3. Clique em Iniciar, clique em Executar, digite explorer /select, %windir%\system32\msisip.dll e clique em OK.
  4. Renomeie o arquivo Msisip.dll como Msisip.old.
  5. Reinstale o Windows 2000 Service Pack 3.

Método 3: Fornecer permissões de controle total para a conta SISTEMA

  1. Inicie o Windows Explorer, clique com o botão direito no disco rígido raiz do computador e clique em Propriedades.
  2. Clique na guia Segurança e clique em Adicionar.
  3. Na caixa de diálogos Selecionar Usuários, Computadores ou Grupos, clique na conta SISTEMA, clique em Adicionar e clique em OK.
  4. Em Permitir, clique para selecionar na caixa de seleção Controle Total e em seguida clique em OK.
  5. Clique na pasta TEMP e verifique se a conta SISTEMA possui controle total.

Método 4: Verificar as permissões do Registro

  1. Clique em Iniciar, em Executar e digite Regedt32.
  2. Para cada seção do Registro, execute essas etapas:
    1. Selecionar a seção.
    2. Para o Windows XP, no menu Editar, clique em Permissões.

      Para o Windows 2000 e o Windows NT 4, no menu Segurança, clique em Permissões.
  3. Verifique se a conta SISTEMA foi adicionada e se tem controle total. Se não tiver, adicione a conta SISTEMA com controle total.

Método 5: Corrigir a chave de segurança quebrada para o serviço MsiServer.

  1. Inicie o computador usando o Windows 2000.
  2. Clique em Iniciar, em Executar, digite regedit.exe e renomeie a seguinte chave como Old_Security:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSIServer\Security
  3. Reinicie o computador (você deve fazer isso).
  4. Execute o Instmsiw.exe for installer 2.0 novamente. Isso corrigirá a chave de segurança quebrada para o serviço MSI.

A informação contida neste artigo aplica-se a:
  • Microsoft Windows Installer 1.0nas seguintes plataformas
    • Microsoft Windows NT 4.0 Service Pack 6
    • Microsoft Windows 2000 Service Pack 1
    • Microsoft Windows 2000 Service Pack 2
    • Microsoft Windows 2000 Service Pack 3
  • Microsoft Windows Installer 1.1nas seguintes plataformas
    • Microsoft Windows NT 4.0 Service Pack 6
    • Microsoft Windows 2000 Service Pack 1
    • Microsoft Windows 2000 Service Pack 2
    • Microsoft Windows 2000 Service Pack 3
  • Microsoft Windows Installer 1.2nas seguintes plataformas
    • Microsoft Windows NT 4.0 Service Pack 6
    • Microsoft Windows 2000 Service Pack 1
    • Microsoft Windows 2000 Service Pack 2
    • Microsoft Windows 2000 Service Pack 3
  • Microsoft Windows Installer 2.0nas seguintes plataformas
    • Microsoft Windows NT 4.0 Service Pack 6
    • Microsoft Windows 2000 Service Pack 1
    • Microsoft Windows 2000 Service Pack 2
    • Microsoft Windows 2000 Service Pack 3
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