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Symptoms

When you try to open a Microsoft Office document or a PDF file by typing an HTTPS URL for the document in the Address bar of Internet Explorer 6 Service Pack 1 (SP1), you may receive the following error message:

Unable to download.

Internet Explorer was unable to open this site. The requested site is either unavailable or cannot be found. Please try again later.

Cause

This issue occurs if the server sends a "Cache-control:no-store" header or sends a "Cache-control:no-cache" header.

Resolution

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:

322756 How to back up and restore the registry in Windows

Important Because all of the hotfix installer packages have the same installer (Q323308.exe), you must be careful to obtain the hotfix that exactly matches your version of Internet Explorer.

Internet Explorer 5.01

A supported hotfix is now available from Microsoft. However, it is intended to correct only the problem that is described in this article. Apply it only to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows 2000 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Customer Support Services to obtain the hotfix. For a complete list of Microsoft Customer Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:

http://support.microsoft.com/contactus/?ws=supportNote In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Date Time Version Size File name
------------------------------------------------------
06-Jun-2002 15:43 5.0.3506.600 461,072 Wininet.dll
To Override the no-cache directive for Internet Explorer 5.01, follow these steps:

  1. Start Registry Editor.

  2. For a per-user setting, locate the following registry key:

    HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings

    For a per-computer setting, locate the following registry key:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings

  3. On the Edit menu, click Add Value, and then add the following registry values:
     

    "BypassSSLNoCacheCheck"=Dword:00000001

  4. Quit Registry Editor.

Internet Explorer 5.5

A supported hotfix is now available from Microsoft. However, it is intended to correct only the problem that is described in this article. Apply it only to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Internet Explorer 5.5 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Customer Support Services to obtain the hotfix. For a complete list of Microsoft Customer Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:

http://support.microsoft.com/contactus/?ws=supportNote In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Date Time Version Size File name
-------------------------------------------------------
06-Jun-2002 13:42 5.50.4918.600 481,040 Wininet.dll
To override the no-cache directive for Internet Explorer 5.5 SP2, follow these steps:

  1. Start Registry Editor.

  2. For a per-user setting, locate the following registry key:

    HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings

    For a per-computer setting, locate the following registry key:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings

  3. On the Edit menu, click Add Value, and then add the following registry values:
     

    "BypassSSLNoCacheCheck"=Dword:00000001

  4. Quit Registry Editor.

Internet Explorer 6

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:

http://support.microsoft.com/contactus/?ws=supportNote The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Date Time Version Size File name
-------------------------------------------------------
28-May-2002 13:32 6.0.2717.2800 583,168 Wininet.dll
To override the no-cache directive for Internet Explorer 5.5 SP2, follow these steps:

  1. Start Registry Editor.

  2. For a per-user setting, locate the following registry key:

    HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings

    For a per-computer setting, locate the following registry key:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings

  3. On the Edit menu, click Add Value, and then add the following registry values:
     

    "BypassSSLNoCacheCheck"=Dword:00000001

  4. Quit Registry Editor.

Internet Explorer 6 SP1

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:

http://support.microsoft.com/contactus/?ws=supportNote The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Date Time Version Size File name
-------------------------------------------------------
23-Sep-2002 14:50 6.0.2800.1121 588,288 Wininet.dll
To override the no-cache directive for Internet Explorer 6 SP1 before you install MS04-004, follow these steps:

  1. Start Registry Editor.

  2. For a per-user setting, locate the following registry key:
     

    HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet SettingsFor a per-computer setting, locate the following registry key:
     

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings

  3. On the Edit menu, click Add Value, and then add the following registry values:
     

    "SSLPragmaNoCache"=Dword:00000001

  4. Quit Registry Editor.

To override the no-cache directive for Internet Explorer 6 SP1 after you install MS04-004, follow these steps:

  1. Start Registry Editor.

  2. For a per-user setting, locate the following registry key:
     

    HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet SettingsFor a per-computer setting, locate the following registry key:
     

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings

  3. On the Edit menu, click Add Value.

  4. To override the directive for HTTPS connections, add the following registry value:

    "BypassSSLNoCacheCheck"=Dword:00000001 To override the directive for HTTP connections, add the following registry value:

    "BypassHTTPNoCacheCheck"=Dword:00000001

  5. Quit Registry Editor.

Internet Explorer 7 and Internet Explorer 8

To resolve this issue in Internet Explorer 7 and in Internet Explorer 8, follow these steps:

  1. Start Registry Editor.

  2. For a per-user setting, locate the following registry key:
     

    HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet SettingsFor a per-computer setting, locate the following registry key:
     

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings

  3. On the Edit menu, click Add Value.

  4. To override the directive for HTTPS connections, add the following registry value:

    "BypassSSLNoCacheCheck"=Dword:00000001 To override the directive for HTTP connections, add the following registry value:

    "BypassHTTPNoCacheCheck"=Dword:00000001

  5. Quit Registry Editor.

Workaround

To work around this problem, use a hypertext reference (HREF) to load the document.

Note This workaround works only if the server uses the "cache-control:no-store" header.

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.
 

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