Nezobrazí se na webu Windows Update nebo webu Microsoft Update a zobrazí následující chybová zpráva: "Chyba při inicializaci 0x800A1391"

Překlady článku Překlady článku
ID článku: 836961 - Produkty, které se vztahují k tomuto článku.
Rozbalit všechny záložky | Minimalizovat všechny záložky

Na této stránce

Při pokusu o webu Windows Update nebo webu Microsoft Update, navštivte webový server se nezobrazí. Může se také zobrazit chybová zpráva. K tomuto problému může dojít z několika důvodů. Proto tento článek obsahuje podrobné pokyny k řešení problému.

Podrobné metody uvedené v tomto článku jsou uvedeny v pořadí z nejčastějších příčin tohoto problému nejméně častou příčinou. Proto je nejvhodnější provést metody v pořadí, ve kterém jsou uvedeny, počínaje metodou 1.

Důležité Tento článek obsahuje informace o tom, jak vedou k oslabení zabezpečení nebo vypnutí funkcí zabezpečení v počítači. Tyto změny lze vyřešit konkrétní problém. Před provedením těchto změn však doporučujeme vyhodnotit nebezpečí spojená s nasazením tohoto řešení v konkrétním prostředí. Pokud se rozhodnete řešení implementovat, přijmout veškerá dodatečná opatření k ochraně počítače.

Tento postup je pro pouze pro účely odstraňování potíží. Takto lze určit, zda všechny funkce nebo aplikace jsou příčinou problému, který se právě jedná. Po potvrzení příčin aktuální problém, doporučujeme znovu povolit veškeré funkce zabezpečení, které byly zakázány při odstraňování problémů. Také doporučujeme, obraťte se na dodavatele aplikace, která je příčinou problému nápovědu s konfigurací aplikace pro práci se systémem Windows.

Tento obsah je určen pro začínající až středně pokročilé uživatele.

Další informace o řešení potíží systému Windows Update naleznete na webu Windows Update Poradce při potížích:
Při potížích systému Windows Update

Příznaky

Při pokusu navštívit Microsoft Windows Update Web serveru nebo webu Microsoft Update, nemusí se zobrazit na webu. Navíc může zobrazit následující chybová zpráva zpráva:
Chyba inicializace 0x800A1391

Příčina

K tomuto problému může dojít, pokud nelze stáhnout součásti modelu COM (Component Object) na webu Windows Update nebo webu Microsoft Update. Weby Windows Update a Microsoft Update použít tuto součást COM. prohledat váš počítač a nainstalujte aktualizace. Technologie Microsoft COM v aplikaci Microsoft Windows rodinných operačních systémů umožňuje komunikaci softwarových součástí.

Řešení

Upozornění: Toto řešení může způsobit počítači nebo síti zranitelnější vůči útoku uživatelů se zlými úmysly nebo škodlivému softwaru, například virům. Doporučujeme toto řešení nedoporučujeme, ale poskytujeme tyto informace tak, aby vám pomocí můžete řešení implementovat podle vlastního uvážení. Toto řešení používáte na vlastní nebezpečí.

Metoda 1: Skenování virů v počítači

Hodnocení této metody: snadné.
Odhadovaný čas: 20 minut na 1 hodinu či více.

Může se jednat o problém protože máte v počítači virus. Chcete-li vyřešit tento problém, je nutné v počítači vyhledat viry a pak odeberte všechny viry, které můžete najít. Chcete-li provést tento postup, postupujte takto:
  1. Prohledejte počítač neobsahuje viry.

    Prohledat váš počítač neobsahuje viry, pomocí antivirového programu, která je nainstalována ve vašem počítači. Jak v počítači vyhledat a odstranit viry je různá pro každý antivirový program. Měli byste si v systému nápovědy antivirový program pro postup, který lze použít k odstranění virů. Obvykle lze najít postup pro antivirový program v síti Internet. Chcete-li najít proceduru, zadejte "hledání virů" a potom na název antivirového programu do vašeho oblíbeného vyhledávače a klepněte na tlačítko Hledat.

    Pokud nemáte v počítači nainstalován antivirový program, postupujte takto:
    1. Spusťte volného bezpečnostní skener Základy zabezpečení společnosti Microsoft Chcete-li provést prohledání počítače. Spustit bezpečnostní skener Základy zabezpečení společnosti Microsoft, navštivte následující Web společnosti Microsoft:
      http://Windows.microsoft.com/en-us/Windows/Products/Security-Essentials
    2. Klepněte Ochrana možnost.
    3. Klepněte Ochrana skenování. Další informace o tom, jak použít bezpečnostní skener Základy zabezpečení společnosti Microsoft navštivte následující Web společnosti Microsoft:
      http://help.live.com
    4. Po dokončení skenování ochranu prohledání vyčistit. Spustit vyčistit, navštivte následující Web společnosti Microsoft: http://www.microsoft.com/security/Scanner/
    5. Klepněte Vyčistit.
    6. Klepněte Vyčistit skenování.
    7. Naleznete na webu Windows Update nebo webu Microsoft Update.
Poznámky
  • Můžete také stáhnout bezplatnou 90denní kopii Základy zabezpečení společnosti Microsoft. Chcete-li to provést, navštivte následující Web společnosti Microsoft:
    http://Windows.microsoft.com/en-us/Windows/Products/Security-Essentials
  • Předpokládaná doba kontroly závisí na velikosti a počtu pevných disků a na druhu skenování. Rychlé hledání virů je velmi rychlé (obvykle méně než několik minut). Kompletní kontrola trvá přibližně 90 minut. V průběhu skener můžete použít počítač a zrušíte prohledávání kdykoli během jeho průběhu.
Je-li tato metoda fungovala: Pokud systém Windows Update nebo Microsoft Update problém vyřešen, jste hotovi!

Pokud tato metoda nebyla úspěšná: Pokud tato metoda problém nevyřeší, pokračujte další metodou.

Metoda 2: Zakázání brány firewall jiných výrobců

Hodnocení této metody: snadné.
Odhadovaný čas: 20 minut nebo více.

Brány firewall jiných výrobců můžete ovlivnit pomocí systému Windows Update a s jinými aplikacemi, které lze stáhnout soubory do vašeho počítače. K řešení problému, budete muset povolit bránu Windows Firewall zakázat bránu firewall jiného výrobce, spusťte službu Windows Update a opětovné povolení brány firewall jiného výrobce. Chcete-li to provést, postupujte takto:
  1. Pokud používáte systém Windows XP, zapněte bránu Firewall systému Windows před zakázáním všech bran firewall jiných výrobců. Chcete-li zapnout bránu Firewall systému Windows, postupujte takto:
    1. Klepněte Starta potom klepněte na tlačítko Spustit.
    2. Zadejte následující příkaz a potom klepněte na tlačítko OK:
      Příkaz firewall.cpl
    3. Vyberte Naa potom klepněte na tlačítko OK.
  2. Zakázání brány firewall jiného výrobce. Podívejte se v systému nápovědy programu brány firewall jiného výrobce pro kroky, které lze použít k zakázání brány firewall.
  3. Naleznete na webu Windows Update nebo webu Microsoft Update.
  4. Povolte vaší brány firewall jiného výrobce. Podívejte se v systému nápovědy programu brány firewall jiného výrobce pro kroky, které můžete použít, chcete-li povolit bránu firewall.
Je-li tato metoda fungovala: Pokud systém Windows Update nebo Microsoft Update problém vyřešen, jste hotovi!

Pokud tato metoda nebyla úspěšná: Pokud tato metoda problém nevyřeší, pokračujte další metodou.

Metoda 3: Zakázat antivirový software

Hodnocení této metody: Středně obtížná.
Odhadovaný čas: 20 minut nebo více.

Antivirový software pomáhá chránit počítač proti virům a dalším ohrožením zabezpečení. Antivirový software byste ve většině případů zakazovat neměli. V případě, že bude třeba dočasně zakázat z důvodu instalace jiného softwaru, měli byste znovu zapnout jej co nejdříve po dokončení. Pokud jste připojeni k Internetu nebo k síti po dobu, kdy je zakázán antivirový software, počítač je vystaven hrozbě útoků.

Antivirový software jiných výrobců mohou narušit systém Windows Update a dalších aplikací, které lze stáhnout soubory do vašeho počítače. Chcete-li vyřešit tento problém, budete muset zakázat antivirový software jiného výrobce, spusťte službu Windows Update a potom znovu povolit antivirový software jiného výrobce.
  1. Zakážete antivirový software. Vyhledejte v nápovědě systému antivirový program pro kroky, jak zakázat antivirový program.
  2. Naleznete na webu Windows Update nebo webu Microsoft Update.
  3. Povolte antivirový software. Vyhledejte v nápovědě systému antivirový program pro postup, jak povolit antivirový program.
Je-li tato metoda fungovala: Pokud systém Windows Update nebo Microsoft Update problém vyřešen, jste hotovi!

Pokud tato metoda nebyla úspěšná: Pokud tato metoda problém nevyřeší, pokračujte další metodou.

Metoda 4: Přidáte do zóny Důvěryhodné servery v aplikaci Internet Explorer na webech Windows Update

Hodnocení této metody: snadné.
Odhadovaný čas: 5 minut či déle.

Jestliže jste ověřili, že brány firewall a antivirový software není příčinou problému, přidejte následující weby Microsoft Internet Explorer důvěryhodné zóny servery v počítači, kde jsou pomocí služby Windows Update. Po přidání na následujících webech společnosti Microsoft Internet Explorer důvěryhodné zóny servery, spusťte službu Windows Update. Chcete-li provést tento postup, postupujte takto:
  1. Spustit Internet Explorer.
  2. V Nástroje nabídky, klepněte na tlačítko Možnosti Internetu.
  3. Klepněte Zabezpečení kartu a potom klepněte na tlačítko Důvěryhodné servery.
  4. Klepněte Weby.
  5. Zrušte zaškrtnutí políčka Vyžadovat ověření serverem (https:) pro všechny weby v této zóně Zaškrtávací políčko.
  6. V Přidat tento webový server do následující zóny, zadejte všechny následující adresy webu a potom klepněte na tlačítko Přidat:
    • https://*.microsoft.com
    • https://download.windowsupdate.com
    • https://Update.microsoft.com/windowsupdate
    • http://*.Update.microsoft.com
    • https://*.Update.microsoft.com
    • http://download.windowsupdate.com
  7. Klepněte Zavříta potom klepněte na tlačítko OK.
  8. Naleznete na webu Windows Update nebo webu Microsoft Update.
Je-li tato metoda fungovala: Pokud systém Windows Update nebo Microsoft Update problém vyřešen, jste hotovi!

Pokud tato metoda nebyla úspěšná: Pokud tato metoda problém nevyřeší, a přesto nelze použít na webu Windows Update nebo Microsoft Update, můžete požádat někoho o pomoc nebo se obraťte na podporu. Informace o postupu kontaktování podpory naleznete na tomto webu společnosti Microsoft:
http://support.microsoft.com/contactus/

Vlastnosti

ID článku: 836961 - Poslední aktualizace: 27. prosince 2012 - Revize: 10.0
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Windows Update na těchto platformách
    • Microsoft Windows XP Professional
    • Microsoft Windows XP Home Edition
    • Microsoft Windows 2000 Advanced Server
    • Microsoft Windows 2000 Server
    • Microsoft Windows 2000 Professional Edition
  • Microsoft Update
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
Klíčová slova: 
kbresolve atdownload kbqfe kbhowto kbexpertisebeginner kbtshoot kbdownload kbwindowsupdate kberrmsg kbprb kbmt KB836961 KbMtcs
Strojově přeložený článek
Důležité: Tento článek byl přeložen pomocí software společnosti Microsoft na strojový překlad, ne profesionálním překladatelem. Společnost Microsoft nabízí jak články přeložené překladatelem, tak články přeložené pomocí software na strojový překlad, takže všechny články ve Znalostní databázi (Knowledge Base) jsou dostupné v češtině. Překlad pomocí software na strojový překlad ale není bohužel vždy dokonalý. Obsahuje chyby ve skloňování slov, skladbě vět, nebo gramatice, podobně jako když cizinci dělají chyby při mluvení v češtině. Společnost Microsoft není právně zodpovědná za nepřesnosti, chyby nebo škody vzniklé chybami v překladu, nebo při použití nepřesně přeložených instrukcí v článku zákazníkem. Společnost Microsoft aktualizuje software na strojový překlad, aby byl počet chyb omezen na minimum.
Projděte si také anglickou verzi článku: 836961

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com