ไม่ปรากฏในเว็บไซต์ Windows Update หรือ Microsoft Update เว็บไซต์ และคุณได้รับข้อความแสดงข้อผิดพลาดต่อไปนี้: "ข้อผิดพลาดการเตรียมใช้งาน 0x800A1391"

การแปลบทความ การแปลบทความ
หมายเลขบทความ (Article ID): 836961 - ผลิตภัณฑ์ที่เกี่ยวข้องในบทความนี้
ขยายทั้งหมด | ยุบทั้งหมด

เนื้อหาบนหน้านี้

เมื่อคุณพยายามที่จะเยี่ยมชมเว็บไซต์ Windows Update หรือ Microsoft Update เว็บไซต์ เว็บไซต์ที่ไม่ปรากฏขึ้น นอกจากนี้ คุณอาจได้รับข้อความข้อผิดพลาด ปัญหานี้อาจเกิดขึ้นได้ด้วยเหตุผลหลายประการ ดังนั้น บทความนี้ประกอบด้วยวิธีการทีละขั้นตอนต่าง ๆ เพื่อช่วยคุณแก้ไขปัญหา

วิธีการทีละขั้นตอนในบทความนี้ปรากฏในใบสั่งจากสาเหตุของปัญหานี้บ่อยที่สุดสาเหตุบ่อยน้อยที่สุด ดังนั้น จึงเป็นดีที่สุดในการดำเนินการวิธีการในใบสั่งซึ่งแสดง Start ด้วยวิธีที่ 1

สิ่งสำคัญ บทความนี้ประกอบด้วยข้อมูลที่แสดงวิธีการตั้งค่าความปลอดภัยที่ต่ำกว่า หรือวิธีการปิดคุณลักษณะการรักษาความปลอดภัยบนเครื่องคอมพิวเตอร์ คุณสามารถทำการเปลี่ยนแปลงเหล่านี้เมื่อต้องการแก้ไขปัญหาที่เฉพาะเจาะจง ก่อนที่คุณจะทำการเปลี่ยนแปลงเหล่านี้ เราขอแนะนำให้คุณประเมินความเสี่ยงที่เกี่ยวข้องกับการใช้วิธีแก้ปัญหานี้ในสภาพแวดล้อมที่เจาะจงของคุณ หากคุณใช้วิธีแก้ปัญหานี้ในเบื้องต้น ใช้ขั้นตอนเพิ่มเติมใด ๆ ที่เหมาะสมเพื่อช่วยปกป้องคอมพิวเตอร์

ขั้นตอนเหล่านี้สำหรับวัตถุประสงค์เฉพาะในการแก้ไขปัญหาได้ ขั้นตอนเหล่านี้จะกำหนดว่า ลักษณะการทำงานหรือโปรแกรมประยุกต์ใด ๆ ที่เป็นสาเหตุของปัญหาที่คุณประสบอยู่ในขณะนี้หรือไม่ หลังจากคุณได้ยืนยันสาเหตุของปัญหาปัจจุบันของคุณ เราขอแนะนำว่า คุณเปิดใช้งานคุณลักษณะความปลอดภัยใด ๆ ที่ถูกปิดใช้งานในระหว่างการแก้ไขปัญหาเบื้องต้น นอกจากนี้ เราขอแนะนำให้ คุณติดต่อผู้จำหน่ายโปรแกรมประยุกต์ที่เป็นสาเหตุของการตัดสินค้าจากคลังสำหรับความช่วยเหลือ ด้วยการตั้งค่าคอนฟิกแอพลิเคชันการทำงานกับ Windows

เนื้อหานี้ถูกออกแบบมาสำหรับการเริ่มต้นจนถึงผู้ใช้คอมพิวเตอร์ระดับกลาง

สำหรับข้อมูลเพิ่มเติมเกี่ยวกับวิธีการแก้ไขปัญหา Windows Update แวะไปตัวแก้ไขปัญหาเว็บไซต์ Windows Update:
ตัวแก้ไขปัญหาการปรับปรุง Windows

อาการ

เมื่อคุณพยายามเยี่ยมชมเว็บ Microsoft Windows Update ไซต์หรือเว็บไซต์ Microsoft Update เว็บไซต์อาจไม่ปรากฏขึ้น นอกจากนี้ คุณอาจได้รับข้อผิดพลาดต่อไปนี้ ข้อความ:
ข้อผิดพลาดการเตรียมใช้งาน 0x800A1391

สาเหตุ

ปัญหานี้อาจเกิดขึ้นถ้าคุณไม่สามารถดาวน์โหลดคอมโพเนนต์ของคอมโพเนนต์วัตถุแบบจำลอง (COM) เว็บไซต์ Windows Update หรือ Microsoft Update เว็บไซต์ Windows Update และ Microsoft Update ใช้คอมโพเนนต์ COM นี้เพื่อสแกนคอมพิวเตอร์ของคุณ และติดตั้งโปรแกรมปรับปรุง เทคโนโลยี Microsoft COM ใน Microsoft Windows-ตระกูลของระบบปฏิบัติการเปิดใช้งานคอมโพเนนต์ของซอฟต์แวร์ในการสื่อสาร

การแก้ไข

คำเตือน วิธีแก้ปัญหานี้อาจทำให้คอมพิวเตอร์หรือเครือข่ายมีความเสี่ยงที่สูงขึ้นต่อการถูกโจมตีโดยผู้ใช้ที่เป็นอันตรายหรือโดยซอฟต์แวร์ที่เป็นอันตราย เช่น ไวรัส เราไม่แนะนำวิธีแก้ปัญหานี้แต่เสนอข้อมูลนี้เพื่อให้คุณสามารถใช้วิธีแก้ปัญหานี้ตามดุลยพินิจของคุณเอง ใช้วิธีแก้ปัญหานี้ความน่าเชื่อถือ

วิธีที่ 1: การสแกนหาไวรัสในคอมพิวเตอร์ของคุณ

วิธีนี้ถูกจัดอันดับ: ง่ายขึ้น
เวลาโดยประมาณ: 20 นาทีถึง 1 ชั่วโมงหรือมากกว่านั้น

คุณอาจประสบปัญหานี้ได้เนื่องจากคุณมีไวรัสบนคอมพิวเตอร์ของคุณ เมื่อต้องการแก้ไขปัญหานี้ คุณต้องการสแกนหาไวรัสในคอมพิวเตอร์ของคุณ และจากนั้น ลบไวรัสต่าง ๆ ที่คุณค้นหา เมื่อต้องการทำวิธีนี้ ทำต่อไปนี้:
  1. สแกนหาไวรัสในคอมพิวเตอร์ของคุณ

    สามารถสแกนหาไวรัสในคอมพิวเตอร์ของคุณ ใช้โปรแกรมป้องกันไวรัสที่ติดตั้งบนคอมพิวเตอร์ของคุณ วิธีคุณสแกนคอมพิวเตอร์ของคุณ และลบไวรัสจะแตกต่างกันสำหรับแต่ละโปรแกรมป้องกันไวรัส คุณควรมองหาในระบบ'วิธีใช้'ของโปรแกรมป้องกันไวรัสสำหรับกระบวนงานที่คุณใช้ในการเอาไวรัสออก โดยปกติแล้วคุณสามารถค้นหาขั้นตอนสำหรับโปรแกรมป้องกันไวรัสบนอินเทอร์เน็ต เมื่อต้องการค้นหาวิธีดำเนินการ พิมพ์ "การสแกนหาไวรัส" และชื่อของโปรแกรมป้องกันไวรัสในเครื่องมือค้นหาที่ชื่นชอบ และจากนั้น คลิกค้นหา

    ถ้าคุณไม่มีโปรแกรมป้องกันไวรัสที่ติดตั้งบนคอมพิวเตอร์ของคุณ ให้ทำตามขั้นตอนเหล่านี้:
    1. เรียกใช้สแกนเนอร์ความปลอดภัยของสิ่งจำเป็นสำหรับการรักษาความปลอดภัย Microsoft ฟรีเพื่อทำการสแกนเครื่องคอมพิวเตอร์ของคุณ เมื่อต้องการเรียกใช้สแกนเนอร์ความปลอดภัยของสิ่งจำเป็นสำหรับการรักษาความปลอดภัย Microsoft แวะไปที่เว็บไซต์ต่อไปนี้ของ Microsoft:
      http://windows.microsoft.com/en-US/windows/products/security-essentials
    2. คลิก การป้องกัน ตัวเลือก
    3. คลิก ตรวจสอบการป้องกัน. สำหรับข้อมูลเพิ่มเติมเกี่ยวกับวิธีการใช้สแกนเนอร์ความปลอดภัยของสิ่งจำเป็นสำหรับการรักษาความปลอดภัย Microsoft โปรดเยี่ยมชมเว็บไซต์ต่อไปนี้ของ Microsoft:
      http://help.live.com
    4. หลังจากการป้องกันการสแกนเสร็จสมบูรณ์แล้ว เรียกใช้การสแกนล้าง เมื่อต้องการเรียกใช้การล้าง แวะไปที่เว็บไซต์ต่อไปนี้ของ Microsoft: http://www.microsoft.com/security/scanner/
    5. คลิก ล้างข้อมูล.
    6. คลิก ล้างข้อมูลการสแกน.
    7. แวะไปเว็บไซต์ Windows Update หรือ Microsoft Update เว็บไซต์
หมายเหตุ
  • นอกจากนี้คุณสามารถดาวน์โหลดฟรี 90 วันได้สำเนาของสิ่งจำเป็นสำหรับการรักษาความปลอดภัย Microsoft เมื่อต้องการทำเช่นนี้ ให้ไปที่เว็บไซต์ต่อไปนี้ของ Microsoft:
    http://windows.microsoft.com/en-US/windows/products/security-essentials
  • เวลาที่ประเมินของการสแกนขึ้นอยู่ กับขนาดและจำนวนของฮาร์ดดิสก์ของคุณ และชนิดของการสแกน การสแกนไวรัสอย่างรวดเร็วจะได้อย่างรวดเร็ว (โดยปกติจะน้อยกว่าสองสามนาที) การสแกนเสร็จสมบูรณ์ full-service จะใช้เวลาประมาณ 90 นาที คุณสามารถใช้คอมพิวเตอร์ของคุณในขณะที่สแกนเนอร์ทำงาน และคุณสามารถยกเลิกการสแกนที่จุดใด ๆ ระหว่างความคืบหน้าได้
ถ้าวิธีการนี้ในการทำงาน: หากมีแก้ไขปัญหา Windows Update หรือ Microsoft Update คุณจะเสร็จเรียบร้อยแล้ว

ถ้าวิธีนี้ใช้ไม่ได้ผล: ถ้าวิธีการนี้ไม่สามารถแก้ปัญหาของคุณ ต่อไปวิธีถัดไป

วิธีที่ 2: ปิดใช้งานไฟร์วอลล์ของบริษัทอื่น

วิธีนี้ถูกจัดอันดับ: ง่ายขึ้น
เวลาโดยประมาณ: 20 นาทีหรือมากกว่านั้น

ไฟร์วอลล์ของบริษัทอื่นอาจรบกวน กับการปรับ ปรุงของ Windows และโปรแกรมประยุกต์อื่นที่อาจดาวน์โหลดแฟ้มลงในคอมพิวเตอร์ของคุณ เมื่อต้องการแก้ไขปัญหา คุณจะต้องเปิดใช้งานไฟร์วอลล์ Windows การปิดใช้งานไฟร์วอลล์ของบริษัทอื่น เรียกใช้ Windows Update และจากนั้น เปิดใช้งานไฟร์วอลล์ของบริษัทอื่น ในการดำเนินการดังกล่าว ให้ทำตามขั้นตอนต่อไปนี้
  1. ถ้าคุณกำลังเรียกใช้ Windows XP เปิดไฟร์วอลล์ Windows ก่อนที่คุณปิดใช้งานไฟร์วอลล์ของบริษัทอื่นใด ๆ เมื่อต้องการเปิดไฟร์วอลล์ Windows ให้ทำตามขั้นตอนเหล่านี้:
    1. คลิก เริ่มแล้ว คลิก เรียกใช้.
    2. พิมพ์ต่อไปนี้ และจากนั้น คลิก ตกลง:
      Firewall.cpl
    3. เลือก บนแล้ว คลิก ตกลง.
  2. ปิดใช้งานไฟร์วอลล์ของบริษัทอื่น ค้นหาในระบบ'วิธีใช้'ของโปรแกรมไฟร์วอลล์ของบริษัทอื่นสำหรับขั้นตอนที่คุณสามารถใช้เพื่อปิดใช้งานไฟร์วอลล์
  3. แวะไปเว็บไซต์ Windows Update หรือ Microsoft Update เว็บไซต์
  4. เปิดใช้งานไฟร์วอลล์ของบริษัทของคุณ ค้นหาในระบบ'วิธีใช้'ของโปรแกรมไฟร์วอลล์ของบริษัทอื่นสำหรับขั้นตอนที่คุณสามารถใช้เพื่อเปิดใช้งานไฟร์วอลล์
ถ้าวิธีการนี้ในการทำงาน: หากมีแก้ไขปัญหา Windows Update หรือ Microsoft Update คุณจะเสร็จเรียบร้อยแล้ว

ถ้าวิธีนี้ใช้ไม่ได้ผล: ถ้าวิธีการนี้ไม่สามารถแก้ปัญหาของคุณ ต่อไปวิธีถัดไป

วิธีที่ 3: ปิดใช้งานซอฟต์แวร์ป้องกันไวรัส

วิธีนี้ถูกจัดอันดับ: ง่ายปานกลาง
เวลาโดยประมาณ: 20 นาทีหรือมากกว่านั้น

ซอฟต์แวร์ป้องกันไวรัสสามารถช่วยป้องกันคอมพิวเตอร์ของคุณจากไวรัสและการคุกคามด้านความปลอดภัยอื่น ๆ ในกรณีส่วนใหญ่ คุณไม่ควรปิดซอฟต์แวร์ป้องกันไวรัสของคุณ ถ้าคุณจำเป็นต้องเป็นการชั่วคราวปิดใช้งานการติดตั้งซอฟต์แวร์อื่น ๆ คุณควรเปิดได้ทันทีที่คุณทำเสร็จแล้ว ถ้าคุณเชื่อมต่อกับอินเทอร์เน็ตหรือเครือข่ายในช่วงเวลาซอฟต์แวร์ป้องกันไวรัสของคุณถูกปิดการใช้งาน เครื่องคอมพิวเตอร์ของคุณมีความเสี่ยงต่อการโจมตี

ซอฟต์แวร์ป้องกันไวรัสของบริษัทอื่นอาจรบกวนการปรับปรุงของ Windows และโปรแกรมประยุกต์อื่นที่อาจดาวน์โหลดแฟ้มลงในคอมพิวเตอร์ของคุณ เพื่อที่จะแก้ไขปัญหานี้ คุณจะต้องปิดใช้งานซอฟต์แวร์ป้องกันไวรัสของบริษัทอื่น เรียกใช้ Windows Update และจากนั้น เปิดใช้งานซอฟต์แวร์ป้องกันไวรัสของบริษัทอื่น
  1. ปิดใช้งานซอฟต์แวร์ป้องกันไวรัส ค้นหาในระบบ'วิธีใช้'ของโปรแกรมป้องกันไวรัสสำหรับขั้นตอนเกี่ยวกับวิธีการปิดการใช้งานโปรแกรมป้องกันไวรัสไว้
  2. แวะไปเว็บไซต์ Windows Update หรือ Microsoft Update เว็บไซต์
  3. เปิดใช้งานซอฟต์แวร์ป้องกันไวรัส ค้นหาในระบบ'วิธีใช้'ของโปรแกรมป้องกันไวรัสสำหรับขั้นตอนเกี่ยวกับวิธีการเปิดใช้งานโปรแกรมป้องกันไวรัสไว้
ถ้าวิธีการนี้ในการทำงาน: หากมีแก้ไขปัญหา Windows Update หรือ Microsoft Update คุณจะเสร็จเรียบร้อยแล้ว

ถ้าวิธีนี้ใช้ไม่ได้ผล: ถ้าวิธีการนี้ไม่สามารถแก้ปัญหาของคุณ ต่อไปวิธีถัดไป

วิธีที่ 4: เพิ่ม Windows การปรับปรุงเว็บไซต์ในโซนไซต์ที่เชื่อถือได้ใน Internet Explorer

วิธีนี้ถูกจัดอันดับ: ง่ายขึ้น
เวลาโดยประมาณ: 5 นาทีหรือมากกว่านั้น

ถ้าคุณได้ตรวจสอบว่า ไฟร์วอลล์และซอฟต์แวร์ป้องกันไวรัสของคุณทำให้ไม่เกิดปัญหา ลองเพิ่มเว็บไซต์ต่อไปนี้ลงใน Microsoft Internet Explorer Trusted โซนไซต์บนคอมพิวเตอร์ที่คุณกำลังใช้ Windows Update หลังจากที่คุณได้เพิ่มเว็บไซต์ต่อไปนี้ลงในโซนไซต์ที่เชื่อถือ Microsoft Internet Explorer เรียกใช้ Windows Update เมื่อต้องการทำวิธีนี้ ทำตามขั้นตอนเหล่านี้:
  1. เริ่มโปรแกรม Internet Explorer
  2. ในการ เครื่องมือ เมนู คลิก Internet Options.
  3. คลิก รักษาความปลอดภัย แท็บ และคลิก ไซต์ที่เชื่อถือได้.
  4. คลิก ไซต์.
  5. คลิกเพื่อยกเลิกเลือก จำเป็นต้องมีการตรวจสอบเซิร์ฟเวอร์ (https:) สำหรับทุกไซต์ในโซนนี้ เมื่อคุณเลือกกล่องกาเครื่องหมาย
  6. ใน เพิ่มเว็บไซต์นี้ลงในโซนพิมพ์อยู่เว็บไซต์ต่อไปนี้อย่างใดอย่างหนึ่ง และจากนั้น คลิก เพิ่ม:
    • https://*.microsoft.com
    • https://download.windowsupdate.com
    • https://update.microsoft.com/windowsupdate
    • http://*.update.microsoft.com
    • https://*.update.microsoft.com
    • http://download.windowsupdate.com
  7. คลิก ปิดแล้ว คลิก ตกลง.
  8. แวะไปเว็บไซต์ Windows Update หรือ Microsoft Update เว็บไซต์
ถ้าวิธีการนี้ในการทำงาน: หากมีแก้ไขปัญหา Windows Update หรือ Microsoft Update คุณจะเสร็จเรียบร้อยแล้ว

ถ้าวิธีนี้ใช้ไม่ได้ผล: ถ้าวิธีการนี้ไม่สามารถแก้ปัญหาของคุณ และคุณยังคงไม่สามารถใช้เว็บไซต์ Windows Update หรือ Microsoft Update คุณอาจต้องขอความช่วยเหลือจากบุคคลอื่น หรือติดต่อฝ่ายสนับสนุน สำหรับข้อมูลเกี่ยวกับวิธีการติดต่อฝ่ายสนับสนุน แวะไปที่เว็บไซต์ต่อไปนี้ของ Microsoft:
http://support.microsoft.com/contactus/

คุณสมบัติ

หมายเลขบทความ (Article ID): 836961 - รีวิวครั้งสุดท้าย: 28 มิถุนายน 2556 - Revision: 6.0
ใช้กับ
  • Microsoft Windows Update เมื่อใช้กับ:
    • Microsoft Windows XP Professional Edition
    • Microsoft Windows XP Home Edition
    • Microsoft Windows 2000 Advanced Server
    • Microsoft Windows 2000 Server
    • Microsoft Windows 2000 Professional Edition
  • Microsoft Update
  • Microsoft Windows Server 2003 Standard Edition
Keywords: 
kbresolve atdownload kbqfe kbhowto kbexpertisebeginner kbtshoot kbdownload kbwindowsupdate kberrmsg kbprb kbmt KB836961 KbMtth
แปลโดยคอมพิวเตอร์
ข้อมูลสำคัญ: บทความนี้แปลโดยซอฟต์แวร์การแปลด้วยคอมพิวเตอร์ของ Microsoft แทนที่จะเป็นนักแปลที่เป็นบุคคล Microsoft มีบทความที่แปลโดยนักแปลและบทความที่แปลด้วยคอมพิวเตอร์ เพื่อให้คุณสามารถเข้าถึงบทความทั้งหมดในฐานความรู้ของเรา ในภาษาของคุณเอง อย่างไรก็ตาม บทความที่แปลด้วยคอมพิวเตอร์นั้นอาจมีข้อบกพร่อง โดยอาจมีข้อผิดพลาดในคำศัพท์ รูปแบบการใช้ภาษาและไวยากรณ์ เช่นเดียวกับกรณีที่ชาวต่างชาติพูดผิดเมื่อพูดภาษาของคุณ Microsoft ไม่มีส่วนรับผิดชอบต่อความคลาดเคลื่อน ความผิดพลาดหรือความเสียหายที่เกิดจากการแปลเนื้อหาผิดพลาด หรือการใช้บทแปลของลูกค้า และ Microsoft มีการปรับปรุงซอฟต์แวร์การแปลด้วยคอมพิวเตอร์อยู่เป็นประจำ
ต่อไปนี้เป็นฉบับภาษาอังกฤษของบทความนี้:836961

ให้ข้อเสนอแนะ

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com