คุณได้รับข้อความแสดงข้อความแสดงข้อผิดพลาด "การปรับปรุง Windows พบข้อผิดพลาด และไม่สามารถแสดงหน้าการร้องขอ" เมื่อคุณพยายามติดตั้งการปรับปรุง

หมายเลขบทความ (Article ID): 883614 - ผลิตภัณฑ์ที่เกี่ยวข้องในบทความนี้
ขยายทั้งหมด | ยุบทั้งหมด

เนื้อหาบนหน้านี้

อาการ

เมื่อคุณพยายามใช้ Windows Update เพื่อติดตั้งการปรับปรุง คุณได้รับข้อความแสดงข้อความแสดงข้อผิดพลาดต่อไปนี้:
การปรับปรุง Windows พบข้อผิดพลาด และไม่สามารถแสดงเพจที่ร้องขอ ไม่มีเริ่มบริการจำเป็น "Automatic Updates" (WUAUSERV) หรือ Background Intelligent Transfer Service (BITS) ถูกปิดใช้งาน ข้อผิดพลาด 0x8DDD0018

สาเหตุ

ปัญหานี้เกิดขึ้นถ้า Background Intelligent Transfer Service (BITS) หรือบริการการปรับปรุงอัตโนมัติจะหยุดทำงาน

การแก้ไข

เมื่อต้องแก้ไขปัญหานี้ ใช้หนึ่งในวิธีต่อไปนี้ ขึ้นอยู่กับสถานการณ์ของคุณ

วิธีที่ 1: ตรวจสอบว่า บริการกำลังเริ่มต้นแล้ว

ตรวจสอบให้แน่ใจว่า BITS และบริการการปรับปรุงอัตโนมัติได้เริ่มต้นขึ้นแล้ว ในการดำเนินการดังกล่าว ให้ทำตามขั้นตอนต่อไปนี้
  1. คลิก เริ่มคลิก เรียกใช้ชนิด services.mscแล้ว คลิก ตกลง.
  2. ในรายการของบริการ คลิกขวา ปรับปรุงอัตโนมัติแล้ว คลิก คุณสมบัติ.
  3. ในการ ชนิดการเริ่มต้น รายการ คลิก โดยอัตโนมัติแล้ว คลิก นำไปใช้.
  4. ถ้า สถานะการบริการ ตั้งค่าเป็น หยุดการทำงานคลิก เริ่มแล้ว คลิก ตกลง.
  5. คลิกขวา Background Intelligent Transfer Serviceแล้ว คลิก คุณสมบัติ.
  6. ในการ ชนิดการเริ่มต้น รายการ คลิก ด้วยตนเองแล้ว คลิก นำไปใช้.
  7. ถ้า สถานะการบริการ ตั้งค่าเป็น หยุดการทำงานคลิก เริ่มแล้ว คลิก ตกลง.

วิธีที่ 2: หนึ่งหรือทั้งสองที่บริการไม่ปรากฏขึ้นในบริการควบคุม Manager

หมายเหตุ ถ้าคุณพิมพ์คำสั่งด้วยตนเองในส่วนนี้ โปรดจำไว้ว่า จะเล็ก

ถ้าบริการการปรับปรุงอัตโนมัติหรือของ Background Intelligent Transfer Service ไม่ปรากฏในตัวจัดการการควบคุมของบริการ ติดตั้งการบริการหรือบริการเหล่านั้น เมื่อต้องการทำเช่นนี้ ใช้หนึ่งหรือทั้งสองวิธีต่อไปนี้ ขึ้นอยู่กับสถานการณ์ของคุณ:

เซอร์วิส Automatic Updates จะหายไป

เมื่อต้องการติดตั้งบริการการปรับปรุงอัตโนมัติ ทำตามขั้นตอนเหล่านี้:
  1. คลิก เริ่มคลิก เรียกใช้พิมพ์คำสั่งต่อไปนี้ และจากนั้น คลิก ตกลง:
    setupapi %windir%\System32\rundll32.exe, %windir%\inf\au.inf InstallHinfSection DefaultInstall 132
  2. ถ้าคุณได้รับการพร้อมท์ให้ใส่แผ่นซีดีระบบปฏิบัติการของคุณ ให้พิมพ์เส้นทางต่อไปนี้ในการ คัดลอกแฟ้ม กล่อง และจากนั้นคลิก ตกลง:
    %windir%\ServicePackFiles\i386
    หมายเหตุ ตำแหน่งที่ตั้งนี้ประกอบด้วยแฟ้ม service pack มีการปรับปรุงล่าสุด ถ้าคุณไม่สามารถใช้เส้นทางนี้ การคัดลอกแฟ้มที่จำเป็นต้องใส่ซีดีระบบปฏิบัติการ และจากนั้น คลิก ตกลง.

ของ Background Intelligent Transfer Service หายไป

เมื่อต้องการติดตั้งใหม่ของ Background Intelligent Transfer Service ทำตามขั้นตอนเหล่านี้:
  1. คลิก เริ่มคลิก เรียกใช้พิมพ์คำสั่งต่อไปนี้ และจากนั้น คลิก ตกลง:
    setupapi %windir%\System32\rundll32.exe, %windir%\inf\qmgr.inf InstallHinfSection DefaultInstall 132
  2. ถ้าคุณได้รับการพร้อมท์ให้ใส่แผ่นซีดีระบบปฏิบัติการของคุณ ให้พิมพ์เส้นทางต่อไปนี้ในการ คัดลอกแฟ้ม กล่อง และจากนั้นคลิก ตกลง:
    %windir%\ServicePackFiles\i386
    หมายเหตุ ตำแหน่งที่ตั้งนี้ประกอบด้วยแฟ้ม service pack มีการปรับปรุงล่าสุด ถ้าคุณไม่สามารถใช้เส้นทางนี้ การคัดลอกแฟ้มที่จำเป็นต้องใส่ซีดีระบบปฏิบัติการ และจากนั้น คลิก ตกลง.

สถานะ

Microsoft ยืนยันว่า ปัญหานี้เป็นปัญหาที่เกิดขึ้นกับผลิตภัณฑ์ของ Microsoft ที่ระบุไว้ในส่วน "นำไปใช้งาน"

คุณสมบัติ

หมายเลขบทความ (Article ID): 883614 - รีวิวครั้งสุดท้าย: 16 มกราคม 2556 - Revision: 9.0
ใช้กับ
  • Microsoft Windows Update
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Media Center Edition 2005 Update Rollup 2
  • Microsoft Windows XP Professional Edition
  • Microsoft Windows XP Tablet PC Edition
  • Microsoft Update
Keywords: 
kbwindowsupdate kberrmsg kbtshoot kbprb kbmt KB883614 KbMtth
แปลโดยคอมพิวเตอร์
ข้อมูลสำคัญ: บทความนี้แปลโดยซอฟต์แวร์การแปลด้วยคอมพิวเตอร์ของ Microsoft แทนที่จะเป็นนักแปลที่เป็นบุคคล Microsoft มีบทความที่แปลโดยนักแปลและบทความที่แปลด้วยคอมพิวเตอร์ เพื่อให้คุณสามารถเข้าถึงบทความทั้งหมดในฐานความรู้ของเรา ในภาษาของคุณเอง อย่างไรก็ตาม บทความที่แปลด้วยคอมพิวเตอร์นั้นอาจมีข้อบกพร่อง โดยอาจมีข้อผิดพลาดในคำศัพท์ รูปแบบการใช้ภาษาและไวยากรณ์ เช่นเดียวกับกรณีที่ชาวต่างชาติพูดผิดเมื่อพูดภาษาของคุณ Microsoft ไม่มีส่วนรับผิดชอบต่อความคลาดเคลื่อน ความผิดพลาดหรือความเสียหายที่เกิดจากการแปลเนื้อหาผิดพลาด หรือการใช้บทแปลของลูกค้า และ Microsoft มีการปรับปรุงซอฟต์แวร์การแปลด้วยคอมพิวเตอร์อยู่เป็นประจำ
ต่อไปนี้เป็นฉบับภาษาอังกฤษของบทความนี้:883614

ให้ข้อเสนอแนะ