Cómo abrir documentos utilizando la característica Abrir y reparar de Word

Seleccione idioma Seleccione idioma
Id. de artículo: 893672 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

INTRODUCCIÓN

En este artículo se describe cómo abrir documentos utilizando la característica Abrir y reparar de Microsoft Office Word 2007, Microsoft Office Word 2003 o Microsoft Word 2002.

Más información

Microsoft Word utiliza automáticamente la característica Abrir y reparar si detecta un problema en un documento al abrirlo. Sin embargo, puede hacer que Word use la característica Abrir y reparar al abrir cualquier documento. Esto puede ser especialmente útil si piensa guardar el documento en un formato de archivo diferente. Si guarda un documento dañado en un formato de archivo distinto, quizá no pueda abrirlo. Para obtener más información acerca de cómo solucionar problemas de documentos de Word dañados, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
826864 Cómo solucionar problemas de documentos dañados de Word
Para abrir un documento con la característica Abrir y reparar de Word, utilice uno de los métodos siguientes.

Método 1: abrir un documento concreto

Para abrir un documento concreto con la característica Abrir y reparar de Word, siga estos pasos:
  1. Inicie Word.
  2. En el menú Archivo, haga clic en Abrir.

    Nota: en Word 2007, haga clic en el Botón de Microsoft Office y, a continuación, haga clic en Abrir.
  3. En el cuadro de diálogo Abrir, haga clic para seleccionar el archivo que desea abrir.
  4. Haga clic en la flecha abajo en el botón Abrir y haga clic en Abrir y reparar.

Método 2: abrir todos los documentos

Microsoft proporciona ejemplos de programación solamente como ilustración, sin ninguna garantía ya sea expresa o implícita. Esto incluye, entre otras, las garantías implícitas de comerciabilidad e idoneidad para un fin determinado. En este artículo se da por supuesto que ya conoce el lenguaje de programación que se muestra, así como las herramientas empleadas para crear y depurar procedimientos. Los ingenieros de soporte técnico de Microsoft pueden explicarle la funcionalidad de un determinado procedimiento, pero no modificarán estos ejemplos para ofrecer mayor funcionalidad ni crearán procedimientos adaptados a sus necesidades específicas. Para abrir todos los documentos con la característica Abrir y reparar de Word, reemplace la macro integrada de Word FileOpen con una macro de Microsoft Visual Basic para Aplicaciones (VBA). Para ello, siga estos pasos:
  1. Inicie Word y abra un documento en blanco.
  2. En Word 2007, en la ficha Programador, haga clic en Macros. En Word 2003, elija Macro en el menú Herramientas y haga clic en Macros.
  3. Haga clic en la flecha abajo en el cuadro Macros en y, a continuación, haga clic en Comandos de Word.
  4. En la lista Nombre de macro, haga clic en FileOpen.
  5. Haga clic en la flecha abajo en el cuadro Macros en y, a continuación, haga clic en Normal.dot (plantilla global).

    Nota: en Word 2007, haga clic en Normal.dotm (plantilla global).
  6. Haga clic en Crear.
  7. La macro integrada FileOpen aparece como en el ejemplo siguiente:
    Sub FileOpen()
    '
    ' FileOpen Macro
    ' Opens an existing document or template
    '
        Dialogs(wdDialogFileOpen).Show
    
    End Sub
    
  8. Reemplace la macro integrada FileOpen con el ejemplo de macro siguiente:
    Option Explicit
    
    ' WARNING: ANY USE BY YOU OF THE CODE PROVIDED IN THIS EXAMPLE IS
    ' AT YOUR OWN RISK. Microsoft provides this macro code "as is" without warranty of
    ' any kind, either expressed or implied, including but not limited to the implied 
    ' warranties of merchantability and/or fitness for a particular purpose.
    
    Sub FileOpen()
    '
    ' FileOpen Macro
    ' Opens an existing document or template
    '
    Dim sFileName As String
    
    ' Display the File Open dialog and capture the filename selected and pass it to a
    ' variable
    With Application.Dialogs(wdDialogFileOpen)
        .Display
        sFileName = .Name
    End With
    
    ' Test to verify the filename has a value
    ' If no file is chosen or if the Open dialog is dismissed, 
    ' the following code is skipped
    If sFileName <> "" Then
        ' Use the filename as a variable to be opened using Open and Repair feature
        Documents.Open FileName:=sFileName, OpenAndRepair:=True
    End If
    
    End Sub
    
  9. En el menú Archivo, haga clic en Cerrar y volver a Microsoft Word.
  10. En el menú Archivo, presione Mayús y después haga clic en Guardar todo.
Notas
  • La nueva macro FileOpen únicamente se ejecutará si abre un documento con cualquiera de los métodos siguientes:
    • Hace clic en Abrir en el menú Archivo.
    • Hace clic en Abrir en la barra de herramientas Estándar.
  • La nueva macro FileOpen no se ejecutará si abre un documento con cualquiera de los métodos siguientes:
    • Abre el documento en el Explorador de Windows.
    • Abre el documento desde la lista de archivos usados recientemente (MRU).

Propiedades

Id. de artículo: 893672 - Última revisión: sábado, 14 de mayo de 2011 - Versión: 3.0
La información de este artículo se refiere a:
  • Microsoft Office Word 2007
  • Microsoft Word 2002 Standard Edition
  • Microsoft Word 2010
Palabras clave: 
kbopenfile kbprogramming kbautomation kbvba kbhowto KB893672

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com