Word'deki Aç ve Onar özelliğini kullanarak belgeleri açma

Makale çevirileri Makale çevirileri
Makale numarası: 893672 - Bu makalenin geçerli olduğu ürünleri görün.
Hepsini aç | Hepsini kapa

Bu Sayfada

GİRİŞ

Bu makalede, Microsoft Office Word 2007, Microsoft Office Word 2003 ve Microsoft Word 2002'deki Aç ve Onar özelliğini kullanarak belgeleri nasıl açacağınız açıklanır.

Daha fazla bilgi

Microsoft Word, açmakta olduğunuz belgede bir sorun algılarsa Aç ve Onar özelliğini otomatik olarak kullanır. Ancak Word'ü, herhangi bir belgeyi açarken Aç ve Onar özelliğini kullanmaya zorlayabilirsiniz. Bu işlem, belgeyi farklı bir dosya biçiminde kaydetmeyi düşünüyorsanız kullanışlı olabilir. Bozuk bir belgeyi farklı bir dosya biçiminde kaydederseniz, kaydettiğiniz belgeyi açamayabilirsiniz. Bozuk Word belgelerinde sorun giderme hakkında ek bilgi için, Microsoft Bilgi Bankası'ndaki makaleyi görüntülemek üzere aşağıdaki makale numarasını tıklatın:
826864 Bozuk Word belgelerinde nasıl sorun giderilir
Word'deki Aç ve Onar özelliğini kullanarak bir belgeyi açmak için, aşağıdaki yöntemlerden birini kullanın.

Yöntem 1: Belirli bir belgeyi açmak için

Word'deki Aç ve Onar özelliğini kullanarak belirli bir belgeyi açmak için şu adımları izleyin:
  1. Word'ü başlatın.
  2. Dosya menüsünde, 'ı tıklatın.

    Not Word 2007'de, Microsoft Office Düğmesi'ni ve ardından 'ı tıklatın.
  3. iletişim kutusunda, açmak istediğiniz dosyayı tıklatıp seçin.
  4. düğmesindeki aşağı oku ve sonra da Aç ve Onar'ı tıklatın.

Yöntem 2: Tüm belgeleri açmak için

Microsoft, programlama örneklerini yalnızca gösterim amacıyla sağlar; örtülü veya açık garanti vermez. Buna satılabilirlik veya belirli bir amaca uygunluk zımni garantileri de dahildir, ancak bunlarla sınırlı değildir. Bu makale, gösterilen programlama dilini ve yordamları oluşturmak ve hata ayıklamak amacıyla kullanılan araçları kullanmayı bildiğinizi varsayar. Microsoft destek mühendisleri, belirli bir yordamın işlevselliğinin açıklanmasına yardımcı olabilir, ancak gereksinimlerinizi karşılamaya yönelik olarak ek işlevsellik sağlamak veya yordamlar geliştirmek amacıyla bu örnekleri değiştirmezler. Word'deki Aç ve Onar özelliğini kullanarak tüm belgeleri açmak için, Word'de yerleşik olarak bulunan FileOpen makrosu yerine bir Microsoft Visual Basic for Applications (VBA) makrosu kullanın. Bunu yapmak için şu adımları izleyin:
  1. Word'ü başlatın ve yeni bir boş belge açın.
  2. Word 2007'de, Geliştirici sekmesinde Makrolar'ı tıklatın. Word 2003'te, Araçlar menüsünde Makro'nun üzerine gelin ve Makrolar'ı tıklatın.
  3. Makro yeri kutusundaki aşağı oku ve ardından Word komutları'nı tıklatın.
  4. Makro adı listesinde, FileOpen makrosunu tıklatın.
  5. Makro yeri kutusundaki aşağı oku ve ardından Normal.dot (genel şablon) öğesini tıklatın.

    Not Word 2007'de, Normal.dotm (genel şablon) öğesini tıklatın.
  6. Oluştur'u tıklatın.
  7. Yerleşik FileOpen makrosu aşağıdaki örnekteki gibi görünür:
    Sub FileOpen()
    '
    ' FileOpen Macro
    ' Varolan bir belgeyi veya şablonu açar
    '
        Dialogs(wdDialogFileOpen).Show
    
    End Sub
    
  8. Yerleşik FileOpen makrosu yerine aşağıdaki makro örneğini kullanın:
    Option Explicit
    
    ' UYARI: BU ÖRNEKTE SAĞLANAN KODU KULLANMAK KENDİ
    ' SORUMLULUĞUNUZDADIR. Microsoft bu makro kodunu, satılabilirlik ve/veya belirli bir amaca
    ' uygunluk da dahil ancak bunlarla sınırlı olmamak kaydıyla, örtülü veya 
    ' açık hiçbir garanti vermeden "olduğu gibi" sağlar.
    
    Sub FileOpen()
    '
    ' FileOpen Macro
    ' Varolan bir belgeyi veya şablonu açar
    '
    Dim sFileName As String
    
    ' Dosya Aç iletişim kutusunu görüntüleyin ve seçili dosya adını yakalayıp bir
    ' değişkene geçirin
    With Application.Dialogs(wdDialogFileOpen)
        .Display
        sFileName = .Name
    End With
    
    ' Dosya adının bir değeri olup olmadığını sınayın
    ' Dosya seçilmemişse veya Aç iletişim kutusu yoksayılmışsa, 
    ' aşağıdaki kod atlanır
    If sFileName <> "" Then
        ' Dosya adını, Aç ve Onar özelliği kullanılarak açılacak bir değişken olarak kullanın
        Documents.Open FileName:=sFileName, OpenAndRepair:=True
    End If
    
    End Sub
    
  9. Dosya menüsünde, Kapat ve Microsoft Word Uygulamasına Dön'ü tıklatın.
  10. Dosya menüsünde, SHIFT tuşuna basın ve sonra Tümünü Kaydet'i tıklatın.
Notlar
  • Yeni FileOpen makrosu yalnızca bir belgeyi aşağıdaki yöntemlerden birini kullanarak açarsanız çalıştırılır:
    • Dosya menüsünde 'ı tıklatırsınız.
    • Standart araç çubuğundaki Dosya düğmesini tıklatırsınız.
  • Bir belgeyi aşağıdaki yöntemlerden birini kullanarak açarsanız yeni FileOpen makrosu çalıştırılmaz:
    • Belgeyi Windows Gezgini'nden açarsınız.
    • Belgeyi en son kullanılan (MRU) dosya listesinden açarsınız.

Özellikler

Makale numarası: 893672 - Last Review: 17 Mayıs 2011 Salı - Gözden geçirme: 3.0
Bu makaledeki bilginin uygulandığı durum:
  • Microsoft Office Word 2007
  • Microsoft Word 2002 Standard Edition
  • Microsoft Word 2010
Anahtar Kelimeler: 
kbopenfile kbprogramming kbautomation kbvba kbhowto KB893672

Geri Bildirim Ver

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com