Recibe un mensaje de error "Internet Explorer ha detectado un problema y debe cerrarse" cuando usa Internet Explorer 6 para ver una página Web que aloja un control ActiveX

Seleccione idioma Seleccione idioma
Id. de artículo: 899812 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Síntomas

Cuando utiliza Microsoft Internet Explorer 6 para ver una página Web que aloja un control ActiveX, puede aparecer un mensaje de error similar al siguiente:
Internet Explorer ha detectado un problema y debe cerrarse.
Al hacer clic en el vínculo situado en la parte inferior del cuadro del mensaje para ver los detalles, aparece una firma de error similar a la siguiente:
Firma del error:
AppName: iexplore.exe
AppVer: 6.0.2800.1106 
ModName: mshtml.dll
ModVer: 6.0.2800.1498 
Offset: 002291f4

Causa

El problema se produce después de instalar la actualización de seguridad 890923 que se documenta en el boletín de seguridad MS05-020 de Microsoft.

Este problema se produce porque el archivo Mshtml.dll no trata correctamente un puntero nulo.

Solución

Windows Server 2003

Información del Service Pack

Para resolver este problema, obtenga el Service Pack más reciente para Windows Server 2003. Para obtener más información al respecto, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
889100 Cómo obtener la versión más reciente del Service Pack para Windows Server 2003

Información de la revisión

Hay disponible una revisión para la que Microsoft proporciona soporte técnico. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplíquela solamente en los sistemas que experimenten este problema específico. Esta revisión podría ser sometida a comprobaciones adicionales. Por tanto, si no se ve muy afectado por este problema, se recomienda que espere al próximo Service Pack de Windows Server 2003 que contenga esta revisión.

Para resolver este problema, envíe una solicitud a los servicios al cliente en línea de Microsoft con el fin de obtener la revisión. Para enviar una solicitud en línea y obtener la revisión, visite el siguiente sitio web de Microsoft:
http://go.microsoft.com/?linkid=6294451
Nota: si se producen más problemas o si hay que solucionarlos, es posible que tenga que crear una solicitud de servicio independiente. Se aplicarán los costos de soporte habituales a las preguntas y problemas de soporte técnico adicionales que no reúnan las condiciones necesarias para esta revisión en cuestión. Para crear una solicitud de servicio independiente, visite el siguiente sitio web de Microsoft:
http://support.microsoft.com/default.aspx?scid=fh;[LN];CNTACTMS

Requisitos previos

Debe tener instalado Windows Server 2003 Service Pack 1 para poder aplicar esta revisión.

Requisito de reinicio

No es necesario reiniciar el equipo una vez aplicada esta revisión.

Información de reemplazo de la revisión

Esta revisión no sustituye a ninguna otra.

Información sobre los archivos

La versión en inglés de esta revisión tiene los atributos de archivo mostrados en la siguiente tabla (u otros posteriores). Las fechas y las horas de estos archivos se muestran según el Horario universal coordinado (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para ver la diferencia entre la hora UTC y la hora local, utilice la ficha Zona horaria de la herramienta Fecha y hora del Panel de control.

Microsoft Windows Server 2003, versiones x64

Contraer esta tablaAmpliar esta tabla
FechaHoraVersiónTamañoNombre de archivo
38.51219:436.0.3790.24615.932.544Mshtml.dll
38.51219:436.0.3790.24613.109.376Wmshtml.dll

Windows Server 2003, versiones x86

Contraer esta tablaAmpliar esta tabla
FechaHoraVersiónTamañoNombre de archivo
38.51218:586.0.3790.24613.109.376Mshtml.dll

Windows Server 2003 Service Pack 1

Contraer esta tablaAmpliar esta tabla
FechaHoraVersiónTamañoNombre de archivo
09-jun-0520:586.0.3790.24613.109.376Mshtml.dll

Windows XP

Información de la revisión

Hay disponible una revisión para la que Microsoft proporciona soporte técnico. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplíquela solamente en los sistemas que experimenten este problema específico. Esta revisión podría ser sometida a comprobaciones adicionales. Por tanto, si no se ve muy afectado por este problema, se recomienda que espere al próximo Service Pack de Windows XP que contenga esta revisión.

Para resolver este problema, envíe una solicitud a los servicios al cliente en línea de Microsoft con el fin de obtener la revisión. Para enviar una solicitud en línea y obtener la revisión, visite el siguiente sitio web de Microsoft:
http://go.microsoft.com/?linkid=6294451
Nota: si se producen más problemas o si hay que solucionarlos, es posible que tenga que crear una solicitud de servicio independiente. Se aplicarán los costos de soporte habituales a las preguntas y problemas de soporte técnico adicionales que no reúnan las condiciones necesarias para esta revisión en cuestión. Para crear una solicitud de servicio independiente, visite el siguiente sitio web de Microsoft:
http://support.microsoft.com/default.aspx?scid=fh;[LN];CNTACTMS

Requisitos previos

Para poder aplicar esta revisión, debe tener instalado Windows XP Service Pack 2.

Requisito de reinicio

No es necesario reiniciar el equipo una vez aplicada esta revisión.

Información de reemplazo de la revisión

Esta revisión no sustituye a ninguna otra.

Información sobre los archivos

La versión en inglés de esta revisión tiene los atributos de archivo mostrados en la siguiente tabla (u otros posteriores). Las fechas y las horas de estos archivos se muestran según el horario universal coordinado (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para ver la diferencia entre la hora UTC y la hora local, utilice la ficha Zona horaria de la herramienta Fecha y hora del Panel de control.

Internet Explorer 6 Service Pack 1

Contraer esta tablaAmpliar esta tabla
FechaHoraVersiónTamañoNombre de archivo
09-jun-0522:106.0.2800.15102.704.896Mshtml.dll

Internet Explorer 6 para Microsoft Windows XP Service Pack 2

Contraer esta tablaAmpliar esta tabla
FechaHoraVersiónTamañoNombre de archivo
13-jun-0517:446.0.2900.26963.015.168Mshtml.dll

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a".

Este problema se corrigió por primera vez en Windows Server 2003 Service Pack 2.

Más información

Para obtener más información acerca de la actualización de seguridad 890923 para Internet Explorer, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
890923 MS05-020: Actualización de seguridad acumulativa para Internet Explorer

Soporte técnico para las ediciones de 64 bits de Windows

El fabricante del hardware proporciona soporte técnico y ayuda para las ediciones de 64 bits de Microsoft Windows. Su fabricante de hardware le proporciona soporte técnico, porque incluyó en el hardware una edición de 64 bits de Windows. El fabricante de hardware podría haber personalizado con componentes exclusivos la instalación de la edición de 64 bits de Windows. Esos componentes exclusivos podrían incluir controladores de dispositivo específicos o configuraciones opcionales para maximizar el rendimiento del hardware. Microsoft hará un esfuerzo razonable para proporcionarle ayuda si necesita ayuda técnica para su edición de Windows de 64 bits. Sin embargo, es posible que deba contactar directamente con el fabricante. El fabricante es el mejor cualificado para proporcionar el soporte técnico del software que él mismo instaló en el hardware.

Para obtener más información acerca de Microsoft Windows XP Professional x64 Edition, visite el siguiente sitio Web de Microsoft:
http://www.microsoft.com/spain/windowsxp/64bit/default.mspx
Para obtener más información acerca de las ediciones de 64 bits de Microsoft Windows Server, visite el siguiente sitio Web de Microsoft:
http://www.microsoft.com/spain/servidores/windowsserver2003/64bit/x64/default.mspx

Propiedades

Id. de artículo: 899812 - Última revisión: miércoles, 14 de noviembre de 2007 - Versión: 2.4
La información de este artículo se refiere a:
  • Service Pack 1 de Microsoft Internet Explorer 6.0 sobre las siguientes plataformas
    • Service Pack 1 de Microsoft Windows XP
    • Service Pack 4 de Microsoft Windows 2000
    • Microsoft Windows 2000 Professional Edition
    • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
    • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows XP Service Pack 2
Palabras clave: 
kbbug kbfix kbqfe kbpubtypekc kbhotfixserver kbwinserv2003sp2fix KB899812

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com