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Problems may occur when you try to transfer files to or from a device that is connected to a USB 2.0 hub in Microsoft Windows XP

Article ID:908673
Last Review:May 13, 2008
Revision:4.1
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SYMPTOMS

You try to transfer files to or from a device that is connected to a universal serial bus (USB) 2.0 hub in Microsoft Windows XP. When you do this, you may experience one or more of the following symptoms:
When you try to transfer files, the file transfer fails. You may receive an error message about a delayed write failure. The error message that you receive may vary, depending on the device that you are using.
Other USB devices that are connected to the USB 2.0 hub may stop working. You may receive notification that the USB devices have been disconnected or reconnected.
Power may be disabled on USB devices. Then, the devices are reenumerated.
A USB keyboard may stop working correctly. For example, the behavior of keys may be irregular. When you press a key, the key entry may be repeated many times. Alternatively, when you press a key, nothing may occur at all.
Note Some computers have an internal USB 2.0 hub. For example, a portable computer may have a single USB bus and may use an internal USB hub to provide two or more available USB ports on the computer. Therefore, this issue may occur if the device is connected directly to a USB port on the computer.

This issue may also occur if the device is internal and is connected internally to the internal USB 2.0 hub. For example, this problem might occur if you use a portable computer that has an internal Bluetooth radio that is connected to an internal USB 2.0 hub. When you use this Bluetooth device to transfer the files to another device, you may experience the symptoms that are described in the "Symptoms" section.

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CAUSE

This problem may occur when there is lots of traffic on the USB 2.0 hub, and you transfer files to a low-speed or a full-speed USB device. The problem does not occur when you transfer files to a high-speed USB device.

For more information about USB 2.0 data transfer rates, see the "More Information" section.

Additionally, this problem has been observed on computers that use Transmeta processors (CPUs).

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RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Usbehci.sys5.1.2600.278327,26425-Oct-200523:39x86SP2SP2QFE
Usbport.sys5.1.2600.2783143,10425-Oct-200523:39x86SP2SP2QFE
When you apply this hotfix package, the following registry key is automatically added and configured:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\USB\EnSoftRetry
The registry key is configured to have a DWORD value of 1. This value enables the Soft-Retry code path that is used in this hotfix.

When this hotfix is applied, a USB transfer that fails for specific reasons is silently retried instead of completed and given a "failure" status. When this process occurs, USB client device drivers may not receive notification that communication with the device failed because of a lower-level error on the USB bus.

If the affected USB device driver requires accurate error reporting to function correctly, you should not apply this hotfix. Or, you should disable the Soft-Retry functionality by setting the EnSoftRetry registry value to 0.

A Soft-Retry process will occur when the following conditions are true:
The registry value is enabled
The error that is reported by the USB Enhanced Host Controller Interface (EHCI) host controller for the completed transfer is one of the following errors:
Transaction error (XactErr)
Missed micro-frame
These error conditions are documented in the USB EHCI controller specification as follows:
Transaction Error (XactErr). Set to a one by the Host Controller during status update in the case where the host did not receive a valid response from the device (Timeout, CRC, Bad PID, etc.). Refer to Section 4.15.1.1 for summary of the conditions that affect this bit. 
Missed Micro-Frame. This bit is set when the host controller detected that a host-induced hold-off caused the host controller to miss a required complete-split transaction. 
For more information about the USB EHCI specification, visit the following Web site:
http://www.intel.com/technology/usb/ehcispec.htm (http://www.intel.com/technology/usb/ehcispec.htm)

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STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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MORE INFORMATION

Data transfer rates that USB 2.0 supports

USB 2.0 supports the following maximum data transfer rates, depending on the amount of bus bandwidth that a device requires:
1.5 megabits per second (Mbps) for low-speed devices that do not require lots of bandwidth. These devices include mouse devices and keyboards.
12 Mbps for full-speed, higher-performing devices. These devices include storage devices, speakers, scanners, and video cameras.
480 Mbps for high-speed devices. These devices include mass storage devices and Hi-Speed CD or DVD recorders.
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 (http://support.microsoft.com/kb/824684/) Description of the standard terminology that is used to describe Microsoft software updates

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APPLIES TO
Microsoft Windows XP Home Edition
Microsoft Windows XP Professional

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Keywords: 
kbautohotfix kbexpertisebeginner kbqfe kbhotfixserver KB908673

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