You receive a "0x80070002" or "0x80070003" error code after you download an update from Windows Update, from Microsoft Update, or from Windows Server Update Services

Article ID: 910336 - View products that this article applies to.
Expand all | Collapse all

Fix the problem automatically

Fix this problem
Microsoft Fix it 50202

Note This Fix it Solution has two modes Default and Aggressive. You should run the Fix it solution in Default mode and determine if it resolves your problem with Windows Update before running it in Aggressive mode.

Note If you would rather fix this problem yourself, go to the "Let me fix it myself" section.

Note This wizard may be in English only; however, the automatic fix also works for other language versions of Windows.

Note If you are not on the computer that has the problem, save the Fix it solution to a flash drive or a CD and then run it on the computer that has the problem.

SYMPTOMS

You download an update from one of the following locations:
  • The Microsoft Windows Update Web site
  • The Microsoft Update Web site
  • The Microsoft Windows Server Update Services (WSUS) server
After you do this, the update may fail, and a red X may appear adjacent to the update. In this case, you receive one of the following error codes:
  • 0x80070002
  • 0x80070003
Note To view error messages, you must click the red X that is adjacent to the failed update on the Review your update history Web page.

CAUSE

This problem occurs when some files in the update are missing, even though the update is downloaded and extracted successfully.

Let me fix it myself

To fix this problem yourself, remove the download directory, and then visit the update locations again.
  1. Stop the Automatic Updates service. To do this, follow these steps:
    1. Click Start, click Run, type services.msc, and then click OK.
    2. Right-click the Automatic Updates service, and then click Stop.
    3. Minimize the Services snap-in.
  2. Rename the SoftwareDistribution directory. To do this, follow these steps:
    1. Click Start, click Run, type cmd, and then click OK.
    2. Type cd %windir%, and then press ENTER.
    3. Type ren SoftwareDistribution SDTemp, and then press ENTER
    4. Type exit, and then press ENTER .


    Note When you remove the %windir%\softwaredistribution folder, the history list is erased from the "Review your Updates" section of the Windows Update Web site. This action will not affect the currently installed updates on your computer. Subsequent updates will appear in the history list.
  3. Start the Automatic Updates service. To do this, follow these steps:
    1. Maximize the Services snap-in.
    2. Right-click the Automatic Updates service, and then click Start.
    3. Close the Services snap-in window.
  4. Visit the Windows Update Web site, the Microsoft Update Web site, or the WSUS server again, and then download an update.
  5. If you still receive the same errors, verify that you have correctly performed steps 1 through 3.
  6. If you still cannot install the update, see the following Microsoft Knowledge Base article:
    906602 How to troubleshoot Windows Update, Microsoft Update, and Windows Server Update Services installation issues

Properties

Article ID: 910336 - Last Review: May 2, 2012 - Revision: 7.0
APPLIES TO
  • Microsoft Update
  • Microsoft Windows Update
Keywords: 
kbtshoot kbmsifixme kbfixme KB910336

Give Feedback