Poderá receber uma mensagem de erro com o código "0x8DDD0018" ou o código "0x80246008" quando tentar transferir actualizações a partir do Web site Microsoft Windows Update ou do Web site Microsoft Update

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Sumário

Quando tentar transferir actualizações a partir do Web site Microsoft Windows Update ou do Web site Microsoft Update, poderá receber uma mensagem de erro quando o Serviço de transferência inteligente em fundo (BITS, Background Intelligent Transfer Service) não estiver em execução ou quando o BITS não conseguir ligar com êxito ao Web site. Este artigo descreve como resolver este problema configurando o BITS.

Quando tentar iniciar o BITS, poderá receber mensagens de erro que dependem da configuração do computador. Este artigo também lista estas mensagens e explica como resolver os erros.


Este artigo poderá conter hiperligações para conteúdo em inglês (ainda não traduzido).

Sintomas

Quando tentar transferir actualizações a partir do Web site Microsoft Windows Update ou do Web site Microsoft Update, poderá receber uma mensagem de erro que inclua um dos seguintes códigos de erro:
  • 0x8DDD0018
  • 0x80246008
Além disso, quando clicar em Rever o Histórico de Actualizações e visualizar o ficheiro %Windows%\Windowsupdate.log, poderá ver os seguintes códigos de erro:
  • 0x80200013
  • 0x80246008
Nota: para ver um código de erro depois de clicar em Rever o Histórico de Actualizações, clique no ícone na coluna Estado.

Causa

Este problema ocorre quando se verificar uma das seguintes condições:
  • O BITS não está em execução.
  • O BITS não consegue ligar com êxito ao Web site.

Resolução

Se receber uma mensagem de erro que inclua o código de erro "0x8DDD0018" ou o código de erro "0x80246008", siga os passos da secção "Verificar se o BITS está correctamente configurado" para resolver este problema.

Se vir o código de erro "0x80200013" depois de clicar em Rever o Histórico de Actualizações, siga os passos da secção "Erro 0x80200013" para resolver este problema.

Verificar se o BITS está correctamente configurado

Certifique-se de que o BITS está correctamente configurado. Em seguida, tente iniciar o BITS. Quando tentar iniciar o BITS, poderá receber uma de várias mensagens de erro. Estas mensagens de erro são apresentadas na secção "Passos de resolução de problemas". Se receber uma mensagem de erro quando tentar iniciar o BITS, siga os passos constantes da secção que corresponde à mensagem de erro que recebe.

Para verificar se o BITS está correctamente configurado e, em seguida, iniciar o BITS, siga estes passos:
  1. Clique em Iniciar, clique em Executar, escreva services.msc e clique em OK.
  2. Faça duplo clique em Serviço de transferência inteligente em fundo.
  3. Na caixa Tipo de arranque, clique em Manual e clique em Aplicar.
  4. Clique no separador Iniciar sessão e certifique-se de que o serviço está activado em todos os perfis de hardware listados. Se o serviço estiver desactivado num ou mais perfis de hardware, clique no perfil de hardware, clique em Activar e clique em Aplicar.
  5. Clique no separador Geral e clique em Iniciar.
Se o BITS for iniciado com êxito, visite o Web site do Windows Update ou o Web site do Microsoft Update para obter actualizações. Se obtiver actualizações com êxito, siga os passos 1 a 3 novamente. No entanto, no passo 3, clique em Automático em vez de Manual.

Passos de resolução de problemas

Erro 1083: O programa executável em que este serviço está configurado para ser executado não implementa o serviço. (0x8007043B)
Se receber esta mensagem de erro, siga estes passos:
  1. Clique em Iniciar, clique em Executar, escreva Regsvr32 %windir%\system32\qmgr.dll e clique em OK.
  2. Clique em Iniciar, clique em Executar, escreva regsvr32 %windir%\system32\qmgrprxy.dll e clique em OK.
  3. Clique em Iniciar, clique em Executar, escreva services.msc e clique em OK.
  4. Faça duplo clique em Serviço de transferência inteligente em fundo.
  5. No separador Geral, clique em Iniciar.
Erro 1068: O serviço ou grupo de dependência não conseguiu ser iniciado. (0x8007042c)
Se receber esta mensagem de erro, utilize um dos seguintes métodos para resolver o problema, consoante o sistema operativo.

Microsoft Windows 2000
  1. Clique em Iniciar, clique em Executar, escreva services.msc e clique em OK.
  2. Se um ou mais dos seguintes serviços não estiver em execução, clique com o botão direito do rato no serviço e clique em Iniciar:
    • Sistema de eventos do COM+
    • Notificação de evento de sistema
    • Extensões do contr. da instrum. de gestão do Windows
  3. Clique com o botão direito do rato em Serviço de transferência inteligente em fundo e clique em Iniciar.
Microsoft Windows Server 2003 e Microsoft Windows XP
  1. Clique em Iniciar, clique em Executar, escreva services.msc e clique em OK.
  2. Clique com o botão direito do rato em Chamada de procedimento remoto (RPC) e clique em Inicar.
  3. Clique com o botão direito do rato em Serviço de transferência inteligente em fundo ou Serviço de transferência inteligente em segundo plano e clique em Iniciar.
O Windows não conseguiu iniciar Serviço de transferência inteligente em fundo em computador local. Para mais informações, reveja o 'Registo de eventos de sistema'. Se este for um serviço sem ser da Microsoft, contacte o fabricante do serviço e refira o código de erro específico do serviço -2147024894. (0x80070002)
Se receber esta mensagem de erro, siga estes passos:
  1. Clique em Iniciar, clique em Executar, escreva regedit e clique em OK.
  2. Localize a seguinte subchave do registo:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\BackupRestore\FilesNotToBackup
  3. Se a subchave do registo existir, avance para o passo 4. Se a subchave do registo não existir, crie a subchave. Para o fazer, siga estes passos:
    1. Clique com o botão direito do rato em Backup Restore, aponte para Novo e clique em Chave.
    2. Escreva FilesNotToBackup e prima ENTER.
  4. Saia do Editor de registo.
  5. Clique em Iniciar, clique em Executar, escreva services.msc e clique em OK.
  6. Faça duplo clique em Serviço de transferência inteligente em fundo.
  7. No separador Geral, clique em Iniciar.
Erro 1079: A conta especificada para este serviço é diferente da conta especificada para outros serviços executando no mesmo processo. (0x80004015)
Se receber esta mensagem de erro, siga estes passos:
  1. Clique em Iniciar, clique em Executar, escreva services.msc e clique em OK.
  2. Faça duplo clique em Serviço de transferência inteligente em fundo.
  3. Clique no separador Iniciar sessão.
  4. Clique em Conta do sistema local e clique em OK.
  5. Clique com o botão direito do rato em Serviço de transferência inteligente em fundo e clique em Iniciar.
O Windows não conseguiu iniciar Serviço de transferência inteligente em fundo em computador local. Para mais informações, reveja o 'Registo de eventos de sistema'. Se este for um serviço sem ser da Microsoft, contacte o fabricante do serviço e refira o código de erro específico do serviço 2147942487. (0x80070057)
Este erro indica que as definições do proxy de HTTP do Windows são inválidas. Para resolver este problema, remova as definições do proxy de HTTP. Para o fazer, siga estes passos:
  1. Clique em Iniciar, clique em Executar, escreva cmd e clique em OK.
  2. Escreva Proxycfg.exe e prima ENTER.

    As definições de proxy actuais são apresentadas.
  3. Escreva Proxycfg ?d e prima ENTER para remover as definições do proxy.
  4. Clique em Iniciar, clique em Executar, escreva services.msc e clique em OK.
  5. Faça duplo clique em Serviço de transferência inteligente em fundo.
  6. No separador Geral, clique em Iniciar.
Erro 5: O acesso é negado
Este erro indica que as permissões de acesso do BITS foram modificadas. Para reparar estas permissões de acesso, utilize um dos seguintes métodos, consoante o sistema operativo.

Windows XP
  1. Clique em Iniciar, clique em Executar, escreva cmd e clique em OK.
  2. Escreva o seguinte comando e prima ENTER:
    sc sdset bits D:(A;;CCLCSWRPWPDTLOCRRC;;;SY)(A;;CCDCLCSWRPWPDTLOCRSDRCWDWO;;;BA)(A;;CCLCSWLOCRRC;;;AU)(A;;CCLCSWRPWPDTLOCRRC;;;PU)
  3. Clique em Iniciar, clique em Executar, escreva services.msc e clique em OK.
  4. Faça duplo clique em Serviço de transferência inteligente em fundo.
  5. No separador Geral, clique em Iniciar.
Windows 2000

Nota: para seguir estes passos, necessita do utilitário SubInACL. Para obter este utilitário, visite o centro de transferências da Microsoft.

O ficheiro que se segue está disponível para transferência a partir do centro de transferências da Microsoft:

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Transferir
Transferir o pacote SubInACL.exe agora.

Para obter mais informações sobre como transferir ficheiros de suporte da Microsoft, clique no número de artigo que se segue para visualizar o artigo na base de dados de conhecimento da Microsoft (KB, Microsoft Knowledge Base):
119591 Como obter ficheiros de suporte da Microsoft a partir de serviços online
A Microsoft procedeu à detecção de vírus neste ficheiro. A Microsoft utilizou o software de detecção de vírus mais actual, disponível na data de publicação do ficheiro. O ficheiro está armazenado em servidores com segurança melhorada, que ajudam a impedir quaisquer alterações não autorizadas ao ficheiro.
  1. Clique em Iniciar, clique em Executar, escreva cmd e clique em OK.
  2. Escreva o seguinte comando e prima ENTER:
    Subinacl /service wuauserv /sddl=D:(A;;CCLCSWRPWPDTLOCRRC;;;SY)(A;;CCDCLCSWRPWPDTLOCRSDRCWDWO;;;BA)(A;;CCLCSWLOCRRC;;;AU)(A;;CCLCSWRPWPDTLOCRRC;;;PU)
    .
  3. Clique em Iniciar, clique em Executar, escreva services.msc e clique em OK.
  4. Faça duplo clique em Serviço de transferência inteligente em fundo.
  5. No separador Geral, clique em Iniciar.
O Windows não conseguiu iniciar Serviço de transferência inteligente em fundo em computador local. Para mais informações, reveja o 'Registo de eventos de sistema'. Se este for um serviço sem ser da Microsoft, contacte o fabricante do serviço e refira o código de erro específico do serviço -2147467243. (0x80080005)
Esta mensagem de erro é semelhante à mensagem de erro "Erro 5: O acesso é negado". Para resolver este problema, siga os passos descritos na secção "Erro 5: O acesso é negado".
Erro: Caminho não encontrado (0x80070003)
Se receber esta mensagem de erro, siga estes passos:
  1. Verifique se a seguinte pasta existe:
    %systemdrive%\Documents and Settings\All users\Dados da aplicação\Microsoft\Network\Downloader
    Se esta pasta não existir, crie-a.
  2. Verifique se as localizações do perfil no registo estão correctas. Para obter mais informações sobre este procedimento, clique no número de artigo que se segue para visualizar o artigo na base de dados de conhecimento da Microsoft (KB, Microsoft Knowledge Base):
    214653 How to set the path for the All Users profile
O Windows não conseguiu iniciar Serviço de transferência inteligente em fundo em computador local. Para mais informações, reveja o 'Registo de eventos de sistema'. Se este for um serviço sem ser da Microsoft, contacte o fabricante do serviço e refira o código de erro específico do serviço 2147746132 ou -2147220986. (0x80040154)
Este erro indica que o catálogo do COM+ está danificado. Para resolver este problema, siga os passos indicados no seguinte artigo da base de dados de conhecimento da Microsoft (KB, Microsoft Knowledge Base):
315296 How to clean up a damaged COM+ catalog

Erro 0x80200013

O BITS pode pedir conjuntos de actualizações. No entanto, se o proxy de rede ou o dispositivo de firewall não suportar pedidos de conjuntos, o BITS não conseguirá transferir actualizações. Por este motivo, o BITS devolve o código de erro 0x80200013. Quando ocorre este problema, o %windir%\Windowsupdate.log apresenta a seguinte entrada:
Download job failed due to insufficient range support
Para resolver este problema, contacte o fornecedor do proxy de rede ou do dispositivo de firewall.

Propriedades

Artigo: 910337 - Última revisão: 9 de maio de 2011 - Revisão: 3.0
A informação contida neste artigo aplica-se a:
  • Microsoft Update
  • Microsoft Windows Update
Palavras-chave: 
kbtshoot kbprb KB910337

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