При загрузке обновлений с веб-узлов Microsoft Windows Update и Microsoft Update может появиться сообщение об ошибке с кодом «0x8DDD0018» или «0x80246008».

Переводы статьи Переводы статьи
Код статьи: 910337 - Vizualiza?i produsele pentru care se aplic? acest articol.
Развернуть все | Свернуть все

В этой статье

Аннотация

При загрузке обновлений с веб-узлов Microsoft Windows Update или Microsoft Update может появляться сообщение об ошибке, если фоновая интеллектуальная служба передачи (BITS) не работает или не может подключиться к веб-узлу. В данной статье описывается разрешение этой проблемы с помощью настройки службы BITS.

При попытке запуска службы BITS могут появляться сообщения об ошибке, зависящие от конфигурации компьютера. В данной статье также приводятся эти сообщения об ошибках и способы решения таких проблем.

Проблема

При загрузке обновлений с веб-узлов Microsoft Windows Update и Microsoft Update может появиться сообщение об ошибке, содержащее один из перечисленных ниже кодов ошибки:
  • 0x8DDD0018
  • 0x80246008
Кроме того при щелчке Review your update history (Просмотр истории обновлений) и просмотре файла %Windows%\Windowsupdate.log могут появляться следующие коды ошибок:
  • 0x80200013
  • 0x80246008
Примечание Для просмотра кода ошибки после щелчка Review your update history (Просмотр истории обновлений) щелкните значок в столбце Status (Состояние).

Причина

Подобное поведение наблюдается при выполнении одного из следующих условий:
  • Фоновая интеллектуальная служба передач (BITS) не работает.
  • Службе BITS не удается подключиться к веб-узлу.

Решение

При появлении сообщения об ошибке с кодом «0x8DDD0018» или «0x80246008» выполните действия в разделе «Проверьте правильность настройки службы BITS» для разрешения проблемы.

При появлении кода ошибки «0x80200013» после щелчка Review your update history (Просмотр истории обновлений) выполните действия в разделе «Error 0x80200013» для разрешения проблемы.

Проверка правильности настройки службы BITS

Проверьте правильность настройки службы BITS. Затем запустите службу BITS. При запуске службы BITS может появиться одно или несколько сообщений об ошибках. Эти сообщения об ошибках перечислены в разделе «Действия по устранению неполадок». При появлении сообщения об ошибке при запуске службы BITS выполните действия, приведенные в разделе, относящемся к полученному сообщению об ошибке.

Для проверки правильности настройки службы BITS и запуска этой службы выполните следующие действия.
  1. Нажмите кнопку Пуск, выберите пункт Выполнить, введите команду services.msc и нажмите кнопку ОК.
  2. Дважды щелкните Background Intelligent Transfer Service (Фоновая интеллектуальная служба передачи).
  3. В окне Тип запуска выберите значение Вручную и нажмите кнопку Применить.
  4. Выберите вкладку Вход, затем убедитесь, что служба включена в каждом профиле оборудования в списке. Если служба отключена в одном или нескольких профилях оборудования, выберите профиль оборудования, нажмите кнопку Включить, затем нажмите кнопку Применить.
  5. Откройте вкладку Общие и нажмите кнопку Запуск.
Если служба BITS запускается правильно, посетите веб-узел Windows Update или Microsoft Update, чтобы загрузить обновления. После загрузки обновлений снова выполните шаги 1 - 3. При этом в шаге 3 вместо Авто нажмите кнопку Вручную.

Действия по устранению неполадок

Ошибка 1083: исполняемая программа, на запуск которой настроена служба, не выполняет функции службы. (0x8007043B)
В случае появления этого сообщения выполните следующие действия.
  1. Нажмите кнопку Пуск, выберите Выполнить, введите команду Regsvr32 %windir%\system32\qmgr.dll и нажмите кнопку ОК.
  2. Нажмите кнопку Пуск, выберите Выполнить, введите команду regsvr32 %windir%\system32\qmgrprxy.dll и нажмите кнопку ОК.
  3. Нажмите кнопку Пуск, выберите пункт Выполнить, введите команду services.msc и нажмите кнопку ОК.
  4. Дважды щелкните Background Intelligent Transfer Service (Фоновая интеллектуальная служба передачи).
  5. На вкладке Общие нажмите кнопку Запуск.
Ошибка 1068: не удалось запустить дочернюю службу или группу. (0x8007042c)
При появлении этого сообщения об ошибке для разрешения проблемы используйте один из следующих способов в зависимости от операционной системы.

Microsoft Windows 2000.
  1. Нажмите кнопку Пуск, выберите пункт Выполнить, введите команду services.msc и нажмите кнопку ОК.
  2. Если одна или несколько следующих служб не работают, щелкните службу правой кнопкой мыши, затем выберите Запуск:
    • Система событий Com+
    • Уведомление о системных событиях
    • Расширения драйвера инструментария управления Windows
  3. Правой кнопкой мыши щелкните Фоновая интеллектуальная служба передачи, а затем выберите Запуск.
Microsoft Windows Server 2003 и Microsoft Windows XP
  1. Нажмите кнопку Пуск, выберите пункт Выполнить, введите команду services.msc и нажмите кнопку ОК.
  2. Щелкните правой кнопкой мыши службу Удаленный вызов процедур (RPC) и выберите Запуск.
  3. Правой кнопкой мыши щелкните Фоновая интеллектуальная служба передачи, а затем выберите Запуск.
Операционная система Windows не может запустить фоновую интеллектуальную службу передачи. Дополнительные сведения содержатся в журнале событий. Если это служба не корпорации Майкрософт, обратитесь к разработчику и сообщите код ошибки -2147024894. (0x80070002)
При появлении этого сообщения об ошибке выполните следующие действия.
  1. Выберите в меню Пуск пункт Выполнить, введите команду regedit и нажмите кнопку ОК.
  2. Найдите следующий раздел реестра:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\BackupRestore\FilesNotToBackup
  3. Если раздел реестра существует, перейдите к шагу 4. Если раздел реестра не существует, создайте его. Для этого выполните следующие действия.
    1. Щелкните правой кнопкой мыши элемент Backup Restore, выберите пункт Создать, а затем — Раздел.
    2. Введите FilesNotToBackup и нажмите клавишу ВВОД.
  4. Закройте редактор реестра.
  5. Нажмите кнопку Пуск, выберите пункт Выполнить, введите команду services.msc и нажмите кнопку ОК.
  6. Дважды щелкните Background Intelligent Transfer Service (Фоновая интеллектуальная служба передачи).
  7. На вкладке Общие нажмите кнопку Запуск.
Ошибка 1079. Учетная запись, указанная для этой службы, отличается от учетной записи, указанной для других служб, работающих в том же процессе. (0x80004015)
В случае появления этого сообщения выполните следующие действия.
  1. Нажмите кнопку Пуск, выберите пункт Выполнить, введите команду services.msc и нажмите кнопку ОК.
  2. Дважды щелкните Background Intelligent Transfer Service (Фоновая интеллектуальная служба передачи).
  3. Перейдите на вкладку Вход в систему.
  4. ВЫберите С системной учетной записью и нажмите кнопку OK.
  5. Правой кнопкой мыши щелкните Фоновая интеллектуальная служба передачи, а затем выберите Запуск.
Операционная система Windows не может запустить фоновую интеллектуальную службу передачи. Дополнительные сведения содержатся в журнале событий. Если это служба не корпорации Майкрософт, обратитесь к разработчику и сообщите код ошибки 2147942487. (0x80070057)
Эта ошибка означает неверность параметров HTTP-прокси Windows. Для разрешения этой проблемы удалите параметры HTTP-прокси. Для этого выполните следующие действия.
  1. Выберите в меню Пуск пункт Выполнить, введите команду cmd и нажмите кнопку ОК.
  2. Введите Proxycfg.exe и нажмите клавишу ВВОД.

    Отобразятся текущие параметры прокси.
  3. Введите Proxycfg –d, затем нажмите клавишу ВВОД для удаления параметров прокси.
  4. Нажмите кнопку Пуск, выберите пункт Выполнить, введите команду services.msc и нажмите кнопку ОК.
  5. Дважды щелкните Background Intelligent Transfer Service (Фоновая интеллектуальная служба передачи).
  6. На вкладке Общие нажмите кнопку Запуск.
Ошибка 5. доступ запрещен
Эта ошибка означает, что права на доступ для службы BITS были изменены. Для восстановления этих прав на доступ используйте один из следующих способов в зависимости от операционной системы.

Windows XP
  1. Выберите в меню Пуск пункт Выполнить, введите команду cmd и нажмите кнопку ОК.
  2. Введите следующую команду, затем нажмите клавишу ВВОД:
    sc sdset bits D:(A;;CCLCSWRPWPDTLOCRRC;;;SY)(A;;CCDCLCSWRPWPDTLOCRSDRCWDWO;;;BA)(A;;CCLCSWLOCRRC;;;AU)(A;;CCLCSWRPWPDTLOCRRC;;;PU)
  3. Нажмите кнопку Пуск, выберите пункт Выполнить, введите команду services.msc и нажмите кнопку ОК.
  4. Дважды щелкните Background Intelligent Transfer Service (Фоновая интеллектуальная служба передачи).
  5. На вкладке Общие нажмите кнопку Запуск.
Windows 2000

Примечание Для выполнения этих действий необходима служебная программа SubInACL. Для получения этой служебной программы посетите веб-узел центра загрузки корпорации Майкрософт.

Загрузите следующий файл с веб-узла центра загрузки корпорации Майкрософт:

Свернуть это изображениеРазвернуть это изображение
Загрузка
Загрузить пакет SubInACL.exe.

Для получения дополнительных сведений о загрузке файлов с веб-узла технической поддержки Майкрософт щелкните следующий номер статьи базы знаний Майкрософт:
119591 Как загрузить файлы поддержки Microsoft из Интернета
Корпорация Майкрософт проверила этот файл на наличие вирусов. Корпорация Майкрософт использует последние версии антивирусного программного обеспечения на момент публикации файла для проверки его на наличие вирусов. Файл хранится на защищенном сервере, что предотвращает его несанкционированное изменение.
  1. Выберите в меню Пуск пункт Выполнить, введите команду cmd и нажмите кнопку ОК.
  2. Введите следующую команду, затем нажмите клавишу ВВОД:
    Subinacl /service wuauserv /sddl=D:(A;;CCLCSWRPWPDTLOCRRC;;;SY)(A;;CCDCLCSWRPWPDTLOCRSDRCWDWO;;;BA)(A;;CCLCSWLOCRRC;;;AU)(A;;CCLCSWRPWPDTLOCRRC;;;PU)
    .
  3. Нажмите кнопку Пуск, выберите пункт Выполнить, введите команду services.msc и нажмите кнопку ОК.
  4. Дважды щелкните Background Intelligent Transfer Service (Фоновая интеллектуальная служба передачи).
  5. На вкладке Общие нажмите кнопку Запуск.
Операционная система Windows не может запустить фоновую интеллектуальную службу передачи. Дополнительные сведения содержатся в журнале событий. Если это служба не корпорации Майкрософт, обратитесь к разработчику и сообщите код ошибки -2147467243. (0x80080005)
Эта ошибка похожа на сообщение об ошибке «Ошибка 5: доступ запрещен». Для разрешения этой проблемы выполните действия, описанные в разделе «Ошибка 5: доступ запрещен».
Ошибка: путь не найден (0x80070003)
В случае появления этого сообщения выполните следующие действия.
  1. Проверьте наличие следующей папки:
    %systemdrive%\Documents and Settings\All users\Application Data\Microsoft\Network\Downloader
    Если эта папка не существует, создайте ее.
  2. Проверьте правильность разделов профиля в реестре. Дла получения дополнительных сведений о том, как это сделать, щелкните следующий номер статьи базы знаний Майкрософт:
    214653 Как изменить расположение профиля "All Users" в Microsoft Windows 2000
Операционная система Windows не может запустить фоновую интеллектуальную службу передачи. Дополнительные сведения содержатся в журнале событий. Если это служба не корпорации Майкрософт, обратитесь к разработчику и сообщите код ошибки 2147746132 или -2147220986. (0x80040154)
Эта ошибка означает повреждение каталога COM+. Для решения этой проблемы выполните указания в следующей статье базы знаний Майкрософт:
315296 Очистка поврежденного каталога COM+

Ошибка 0x80200013

Служба BITS может запрашивать ряд обновлений. Однако если сетевой прокси или брандмауэр не поддерживают запросы диапазона, служба BITS не может загрузить обновления. Поэтому служба BITS возвращает код ошибки 0x80200013. При возникновении этой неполадки в файле %windir%\Windowsupdate.log появляется следующая запись:
Download job failed due to insufficient range support (Ошибка задания загрузки, поддерживается недостаточный диапазон)
Для устранения этой неполадки обратитесь к разработчику сетевого прокси или изготовителю брандмауэра.

Свойства

Код статьи: 910337 - Последний отзыв: 14 сентября 2010 г. - Revision: 2.0
Информация в данной статье относится к следующим продуктам.
  • Microsoft Windows Update
  • Microsoft Update
Ключевые слова: 
kbtshoot kbprb KB910337

Отправить отзыв

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com