Recibe un mensaje de error cuando visita el sitio Web de Windows Update o el sitio Web de Microsoft Update: "0x800A0046"

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Síntomas

Cuando visita el sitio Web de Microsoft Windows Update o de Microsoft Update, parece que el sitio Web deja de responder. Además, es posible que aparezca el siguiente mensaje de error:
0x800A0046
Puede grabarse una de las entradas siguientes en el archivo %windir%\Windowsupdate.log:
Fecha	Hora	3096	c1c	COMAPI	ADVERTENCIA: No se puede escuchar el suceso de actualización automática/apagado (hr=0X80070005)
Fecha	Hora	3096	c1c	COMAPI	ADVERTENCIA: No se pudo establecer la conexión con el servicio. (hr=80070005)

Causa

Este problema se produce cuando se cumple una o varias de las condiciones siguientes:
  • La configuración DCOM es incorrecta.
  • Su cuenta de usuario es miembro del grupo Invitados.
  • El descriptor de seguridad del servicio Actualizaciones automáticas es incorrecto.
  • La directiva de seguridad local es incorrecta.

Solución

Para resolver este problema, siga estos pasos en los equipos cliente.

Paso 1: Comprobar la seguridad DCOM

  1. Haga clic en Inicio y en Ejecutar, escriba Dcomcnfg y haga clic en Aceptar.
  2. Expanda Servicios de componentey, a continuación, expanda Equipos.
  3. Haga clic con el botón secundario en Mi PC y, a continuación, haga clic en Propiedades.
  4. Haga clic en la ficha Seguridad COM.
  5. En Permisos de acceso, haga clic en Editar valores predeterminados.
  6. Compruebe que se muestran las cuentas siguientes:

    En clientes con Microsoft Windows XP o Microsoft Windows Server 2003
    Contraer esta tablaAmpliar esta tabla
    Nombre de cuentaTipo de permisoPermiso
    El propio usuario, administradores o un usuario que pertenece al grupo AdministradoresAcceso localPermitir
    SistemaAcceso localPermitir
    En clientes con Microsoft Windows 2000
    Contraer esta tablaAmpliar esta tabla
    Nombre de cuentaTipo de permisoPermiso
    AdministradoresAcceso localPermitir
    SistemaAcceso localPermitir
  7. Si cualquiera de estas cuentas no se encuentra en el cuadro Permisos de acceso, siga estos pasos:
    1. Haga clic en Agregar, en Avanzadas y en Ubicaciones.
    2. En el cuadro Ubicaciones, haga clic en equipoLocal y en Aceptar.
    3. Haga clic en Buscar ahora.
    4. Presione CTRL, haga clic en los nombres de cuenta necesarios y, a continuación, haga clic en Aceptar dos veces.
    5. En el cuadro Nombres de grupos o usuarios, haga clic en una cuenta que haya agregado, haga clic en Acceso local en el Permisos para nombreCuenta y, a continuación, haga clic para activar la casilla de verificación en la columna Permitir.
    6. Repita el paso 7e para todas las cuentas que acaba de agregar y, a continuación, haga clic en Aceptar.

Paso 2: Comprobar las propiedades predeterminadas de DCOM

  1. Haga clic en la ficha Propiedades predeterminadas.
  2. Compruebe la configuración siguiente:
    • La casilla de verificación Habilitar COM distribuido en este equipo está activada.
    • En el cuadro Nivel de autenticación predeterminado, Conectar está activado.
    • En el cuadro Nivel de suplantación predeterminado, Identificar está activado.
  3. Realice cualquier cambio requerido y, a continuación, haga clic en Aceptar.
  4. Reinicie el equipo.

Paso 3: Comprobar que la cuenta de usuario no es miembro del grupo Invitados

Nota: este paso sólo se aplica a equipos con Windows Server 2003, Windows XP Professional o Windows 2000 que no están unidos a un dominio.
  1. Haga clic en Inicio, en Configuración y, a continuación, en Panel de control.
  2. Haga doble clic en Herramientas administrativas.
  3. Expanda Administración de equiposy, a continuación, expanda Usuarios y grupos locales.
  4. Haga clic en Usuarios.
  5. En el panel derecho, haga doble clic en la cuenta que utilizaba para iniciar sesión en el equipo.
  6. Haga clic en la ficha Miembro de.
  7. Haga clic en Invitados, en Quitar y, a continuación, en Aceptar.

Paso 4: Comprobar el descriptor de seguridad en el servicio Actualizaciones automáticas

En clientes con Windows Server 2003 y Windows XP
  1. Haga clic en Inicio y en Ejecutar, escriba cmd y haga clic en Aceptar.
  2. En el símbolo del sistema, escriba el comando siguiente y presione ENTRAR para reiniciar el descriptor de seguridad:
    Sc sdset wuauserv D:(A;;CCLCSWRPWPDTLOCRRC;;;SY)(A;;CCDCLCSWRPWPDTLOCRSDRCWDWO;;;BA)(A;;CCLCSWLOCRRC;;;AU)(A;;CCLCSWRPWPDTLOCRRC;;;PU)
    Nota: un objeto de directiva de grupo podría establecer esta configuración de seguridad en un entorno de dominio. Si el problema sólo se resuelve temporalmente después de escribir este comando, probablemente se ha configurado un objeto de directiva de grupo. El administrador de dominio debe modificar la directiva de grupo para incluir la configuración de seguridad correcta.
En clientes con Windows 2000
  1. Descargue la utilidad Subinacl. Para ello, visite el siguiente sitio Web de Microsoft:
    http://www.microsoft.com/downloads/details.aspx?FamilyID=e8ba3e56-d8fe-4a91-93cf-ed6985e3927b&DisplayLang=en
  2. Haga doble clic en el archivo descargado y, a continuación, siga las instrucciones del Asistente para instalación de herramientas del kit de recursos de Windows. De forma predeterminada, la utilidad Subinacl está instalada en el directorio siguiente:
    C:\Archivos de programa\Windows Resource Kits\Tools
  3. Haga clic en Inicio y en Ejecutar, escriba cmd y haga clic en Aceptar.
  4. En el símbolo del sistema, escriba cd C:\Archivos de programa\Windows Resource Kits\Tools para ir al directorio donde está instalada la utilidad Subinacl.
  5. Escriba el comando siguiente y, a continuación, presione ENTRAR:
    Subinacl /service wuauserv /sddl=D:(A;;CCLCSWRPWPDTLOCRRC;;;SY)(A;;CCDCLCSWRPWPDTLOCRSDRCWDWO;;;BA)(A;;CCLCSWLOCRRC;;;AU)(A;;CCLCSWRPWPDTLOCRRC;;;PU)
    Nota: un objeto de directiva de grupo podría establecer esta configuración de seguridad en un entorno de dominio. Si el problema sólo se resuelve temporalmente después de escribir este comando, probablemente se ha configurado un objeto de directiva de grupo. El administrador de dominio debe modificar la directiva de grupo para incluir la configuración de seguridad correcta.

Paso 5: Comprobar la directiva de seguridad local

Notas:
  • Este paso sólo se aplica a equipos con Windows Server 2003, Windows XP Profesional o Windows 2000.
  • Si la cuenta de usuario pertenece a un dominio, un objeto de directiva de grupo ubicado en la red podría establecer esta configuración de seguridad. Póngase en contacto con el administrador de la red o vea el siguiente artículo de Microsoft Knowledge Base para obtener más información:
    810739 Notas del producto: Solucionar problemas de directiva de grupo en Windows 2000
  1. Haga clic en Inicio y en Ejecutar, escriba gpedit.msc y haga clic en Aceptar.
  2. Expanda Configuración del equipo, Configuración de Windows, Configuración de seguridad y, por último, Directivas locales.
  3. Haga clic en Asignación de derechos de usuario.
  4. En el panel de la derecha, haga doble clic en Suplantar a un cliente tras la autenticación.
  5. Compruebe si están incluidas las cuentas Servicio y Administradores.
  6. Si la cuenta Servicio o Administradores no se encuentra, siga estos pasos para agregar la cuenta:
    1. Haga clic en Agregar usuario o grupo y en Avanzadas y, a continuación, haga clic en Ubicaciones.
    2. En el cuadro Ubicaciones, haga clic en equipoLocal y en Aceptar.
    3. Haga clic en Buscar ahora.
    4. Presione CTRL, haga clic en los nombres de cuenta necesarios y, a continuación, haga clic en Aceptar tres veces.
  7. Reinicie el equipo.

Paso 6: Habilitar la persistencia de los datos del usuario en Microsoft Internet Explorer

  1. Abra Internet Explorer.
  2. En el menú Herramientas, haga clic en Opciones de Internet.
  3. Haga clic en la ficha Seguridad y, a continuación, haga clic en Internet.
  4. Haga clic en Nivel personalizado.
  5. En el cuadro de diálogo Configuración, desplácese a la sección Varios.
  6. En Persistencia de los datos del usuario, haga clic en Habilitar.
  7. Haga clic en Aceptar dos veces.

Referencias

Para obtener más información al respecto, haga clic en los números de artículo siguientes para verlos en Microsoft Knowledge Base:
902093 Cómo leer el archivo Windowsupdate.log
906602 Cómo solucionar problemas de instalación de Windows Update, Microsoft Update y Windows Server Update Services

Propiedades

Id. de artículo: 910338 - Última revisión: martes, 14 de septiembre de 2010 - Versión: 2.0
La información de este artículo se refiere a:
  • Microsoft Windows Update
  • Microsoft Update
Palabras clave: 
kbtshoot kbprb KB910338

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