The Windows Update Web site and the Microsoft Update Web site do not scan for updates when you repair a failed installation of Windows XP Service Pack 2 or of Windows XP Service Pack 1

Article translations Article translations
Article ID: 916259 - View products that this article applies to.
Expand all | Collapse all

SYMPTOMS

You repair a failed installation of Microsoft Windows XP Service Pack 2 (SP2) or of Windows XP Service Pack 1 (SP1) by using a Windows XP original release version CD. However, when you visit the Microsoft Windows Update Web site and the Microsoft Update Web site, the Web sites no longer scan for updates.

Additionally, the WindowsUpdate.log file contains an error message that resembles the following:
0x800700B6 The Windows Update ActiveX Control is not the right version.

CAUSE

This problem occurs because the repair replaces version 6 of the Windows Update ActiveX control with version 4 of this control.

RESOLUTION

To resolve this problem, follow these steps:
  1. Download and reinstall version 6 of the Windows Update ActiveX control. To do this, follow these steps:
    1. Click the following link to download the package:
      http://go.microsoft.com/fwlink/?LinkID=91237
    2. Save the package to the desktop, and then extract the files to a temp folder.
    3. Open the temp folder, right-click Wusetup.inf, and then click Install.
  2. Restart the computer.
  3. Visit the Windows Update Web site or the Microsoft Update Web site. If the problem is still not resolved, follow these steps:
    1. Click Start, click Run, type explorer, and then click OK.
    2. Locate and then double-click the %windir%\System32 folder.

      Note %windir% represents the path of the Windows system folder. Typically, this path is C:\Windows.
    3. Delete the following files:
      • Cdm.dll
      • Iuengine.dll
      • Wuapi.dll
      • Wuauclt.exe
      • Wuauclt1.exe
      • Wuaucpl.cpl
      • Wuaueng.dll
      • Wuaueng1.dll
      • Wucltui.dll
      • Wups.dll
      • Wuweb.dll
      Note To delete a file, right-click the file, click Delete, and then click Yes.
    4. Repeat steps 1 and 2.

Properties

Article ID: 916259 - Last Review: September 14, 2010 - Revision: 3.0
APPLIES TO
  • Microsoft Windows Update
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
  • Microsoft Update
Keywords: 
kbtshoot KB916259

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com