Article ID: 918717 - Last Review: March 10, 2009 - Revision: 3.0

You cannot change a user's categories when you work as a delegate in Outlook 2007

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SYMPTOMS

If you have access to another Exchange user’s mailbox folder(s), your ability to apply, create, delete, or change categories for items in these folders is a function of the permissions that you have on the folder and the permissions that you have to their Calendar folder.
For example, if you have less than Editor permissions to a shared folder when you try to apply or remove a category for an item in the shared folder, you receive the following error message:
You do not have sufficient permission to perform this operation on this object. See the folder contact or your system administrator.
Also, if you open the Color Categories dialog box when you are in a shared folder, the New, Rename, and Delete buttons may be unavailable (dimmed).

CAUSE

To apply or remove an existing category to or from an item in a shared folder, you must have Editor permissions or greater on that folder. The list of color categories in a mailbox is stored in a hidden message in the Calendar folder of a mailbox. Therefore, if you are working in any shared folder of another user’s mailbox, you must have Owner permissions to the other user’s Calendar folder to create new categories, or delete existing categories for any shared folder in the other user’s mailbox.

RESOLUTION

Configure the permissions that are listed in the following sections to match the level of access that you want for categories in shared folders in another user’s mailbox.

Add categories to or remove categories from items in a shared folder

  1. Start Outlook.
  2. On the Go menu, click Folder List.
  3. Right-click the shared folder, and then click Properties.
  4. Click the Permissions tab.
  5. Add or click to select the user who needs to work with categories in the shared folder.
  6. Under Permissions, click Editor or a higher level permission in the Permissions Level box, and then click OK.
Note If you do not have Owner permissions to the Calendar folder of the user who is sharing folders, you will not be able to add, or delete categories in the Color Categories dialog box. You will only be able to add categories to or remove categories from items in the shared folder based on the existing list of categories in the Color Categories dialog box.

Create, rename, or delete categories in a shared folder

If you want to add new categories or delegate existing categories in a shared folder, you have to have Owner permissions to the Calendar folder of the mailbox owner who is sharing their folders. To change the permissions on the Calendar folder, follow these steps on the Outlook client of the user who owns the mailbox with the shared folder(s):
  1. Start Outlook.
  2. On the Go menu, click Folder List.
  3. Right-click the Calendar folder, and then, click Properties.
  4. Click the Permissions tab.
  5. Add or click to select the user who needs to manage categories in the shared folder.
  6. Under Permissions, click to select Owner in the Permissions Level box, and then click OK.

Rename categories in a shared folder

Even if you have Owner permissions to the Calendar folder of the user who is sharing folders, the Rename button is always disabled in the Color Categories dialog box for someone other than the mailbox owner. When you rename a category in the Color Categories dialog box Outlook has to go through every categorized item in every folder to rename the category, if apppropriate. Because of this, only the mailbox owner can rename a category displayed in the Color Categories dialog box. Please ask the owner of the shared folder to rename the category if you need to have a category renamed.

APPLIES TO
  • Microsoft Office Outlook 2007
Keywords: 
kbemail kbcalendar kbpermissions kbexpertisebeginner kbprb KB918717