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Some Windows Vista functions may not work, or Windows Vista may stop responding

Article ID:929833
Last Review:March 17, 2007
Revision:1.3

SYMPTOMS

When you try to use Windows Vista, Windows Vista may not behave as expected. For example, some Windows Vista functions may not work, or Windows Vista may stop responding.

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CAUSE

This issue may occur if a Windows Resource Protection (WRP) file is missing or is corrupted.

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RESOLUTION

To resolve this issue, use the System File Checker tool (SFC.exe) to determine which file is causing the issue, and then replace the file. To do this, follow these steps:
1.Open an elevated command prompt. To do this, click Start, click All Programs, click Accessories, right-click Command Prompt, and then click Run as administrator. If you are prompted for an administrator password or for a confirmation, type the password, or click Allow.
2.Type the following command, and then press ENTER:
sfc /scannow
The sfc /scannow command scans all protected system files and replaces incorrect versions with correct Microsoft versions.
To determine which files could not be repaired by the System File Checker tool, follow these steps:
1.Open an elevated command prompt.
2.Type the following command, and then press ENTER:
findstr /C:"[SR] Cannot repair member file" %windir%\logs\cbs\cbs.log >sfcdetails.txt
Note The Sfcdetails.txt file contains details from every time that the System File Checker tool has been run on the computer. The file includes information about files that were not repaired by the System File Checker tool. Verify the date and time entries to determine the problem files that were found the last time that you ran the System File Checker tool.
3.Type the following command, and then press ENTER:
edit sfcdetails.txt
The Sfcdetails.txt file uses the following format:
Date/Time SFC detail
The following sample log file contains an entry for a file that could not be repaired:
2007-01-12 12:10:42, Info                  CSI    00000008 [SR] Cannot 
repair member file [l:34{17}]"Accessibility.dll" of Accessibility, Version = 
6.0.6000.16386, pA = PROCESSOR_ARCHITECTURE_MSIL (8), Culture neutral, 
VersionScope neutral, PublicKeyToken = {l:8 b:b03f5f7f11d50a3a}, Type 
neutral, TypeName neutral, PublicKey neutral in the store, file is missing

If the System File Checker tool cannot repair a file, follow these steps:
1.At an elevated command prompt, type the following command, and then press ENTER:
takeown /f Path_And_File_Name
For example, type takeown /f E:\windows\system32\jscript.dll.
2.Type the following command, and then press ENTER to grant administrators full access to the file:
icacls Path_And_File_Name /GRANT ADMINISTRATORS:F
For example, type icacls E:\windows\system32\jscript.dll /grant administrators:F.
3.Type the following command to replace the file with a known good copy of the file:
Copy Path_And_File_Name_Of_Source_File Path_And_File_Name_Of_Destination
For example, type copy E:\temp\jscript.dll E:\windows\system32\jscript.dll.

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APPLIES TO
Windows Vista Enterprise 64-bit edition
Windows Vista Ultimate 64-bit edition
Windows Vista Business
Windows Vista Business 64-bit edition
Windows Vista Enterprise
Windows Vista Ultimate

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Keywords: 
kbtshoot kbexpertisebeginner kbprb KB929833

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