Resolver las teclas de control de volumen o teclas de acceso rápido no funciona en los teclados de Microsoft

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Síntomas

Atajos de teclado o las teclas de control de volumen no funcionan como se esperaba en el teclado de Microsoft. Algunas teclas de acceso rápido pueden comportarse como se esperaba, pero otros no.

Puede recibir un mensaje de error similar al siguiente al intentar iniciar el servicio de interfaz humana:
Código de error 126
Error 2

Causa

Este problema puede producirse si hay un problema con la conexión USB en el equipo.Este problema también puede producirse si se ejecuta una utilidad de control del teclado de otro fabricante en el equipo. Ejemplos de utilidades de control del teclado de otros fabricantes son los siguientes:
  • Acceso fácil de Compaq
  • Máquina de E es el tablero electrónico
  • Puerta de enlace teclado multifunción
  • Utilidad de teclado Multimedia de Hewlett-Packard
  • IBM Rapid Access ?Logitech Key Commander
  • Packard Bell MediaSelect
Utilidades de control del teclado de otros fabricantes también se proporcionan con los equipos Acer, Gateway 2000 y Sony Multimedia.

Este problema se produce porque los códigos de exploración emitidos por el teclado se interpretan de forma distinta por cada utilidad de control del teclado. Esto también puede ser debido a tener predeterminado inesperado o asignaciones de programa volver a definido para las claves. Muchas de las asignaciones predeterminadas requieren que tiene instalado un programa específico o que está utilizando un programa de correo electrónico compatibles, el Explorador de Internet o Reproductor multimedia.

Si no dispone del programa compatible, puede seguir utilizando la clave de reasignar la tecla.

Solución

Pruebe cada uno de los métodos a continuación en orden, las pruebas las claves después de cada método. Si el problema persiste, continúe con el método siguiente.

Método 1: Pruebe otro puerto USB

Conecte el teclado a un puerto USB diferente y, a continuación, compruebe el comportamiento del teclado. (Este método comprueba para problemas específicos de un puerto).

Nota Omitir cualquier replicadores de puertos, concentradores USB, conmutadores KVM y así sucesivamente. Conectar el receptor directamente a un puerto en el equipo.

Método 2: Deshabilite o desinstale cualquier software de teclado instalado previamente

Deshabilite cualquier otro software de control de teclado instalado en este equipo y vuelva a intentar reasignar las teclas.


Para obtener más información acerca de cómo asignar funciones a las teclas, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
237179 Asignar macro o función a las teclas en el teclado


Si el problema persiste, quite cualquier software de teclado en el equipo. Para desinstalar cualquier IntelliPoint, Logitech u otro software de teclado, siga estos pasos:
  1. Realice una de las siguientes acciones:
    • Windows Vista o Windows 7:
      1. Utilice las teclas de dirección para buscar el cuadro Iniciar búsqueda , tipo appwiz.cpl, y, a continuación, presione ENTRAR.
      2. En la lista de programas, utilice las teclas de dirección para seleccionar programas y característicasy, a continuación, presione ENTRAR.
      3. Utilice las teclas de dirección para buscar un teclado de cualquier software de control, presione la tecla TAB para buscar Quitary, a continuación, presione ENTRAR. Si tiene instalado otro software de mouse (ratón), es aconsejable tener en cuenta que el software de la desinstalación también.
    • Windows XP y versiones anteriores de Windows:
      1. Haga clic en Inicio, haga clic en Ejecutar, tipo appwiz.cpl en el cuadro Abrir y a continuación, haga clic en Aceptar.
      2. Utilice las teclas de dirección para buscar un teclado de cualquier software de control, presione la tecla TAB para buscar Quitary, a continuación, presione ENTRAR.
  2. Reinicie el equipo si se le pide hacerlo.
  3. Descargue el software IntelliType más reciente. Para obtener más información, visite el siguiente sitio Web de Microsoft:
    http://www.Microsoft.com/hardware/download/download.aspx?Category=MK

Método 3: Reiniciar el servicio de la interfaz de usuario de HID

Para solucionar este problema, siga estos pasos:
  1. Abra el complemento Microsoft Management Console (MMC) para servicios.
    • En Windows Vista o Windows 7, haga clic en Inicio<b00> </b00>
      Contraer esta imagenAmpliar esta imagen
      Botón Inicio
      , tipo Services.msc en el cuadro Iniciar búsqueda y presione ENTRAR.

      Contraer esta imagenAmpliar esta imagen
      Permiso de Control de cuentas de usuario
      Si se le pide una contraseña de administrador o una confirmación, escriba la contraseña o haga clic en continuar.
    • En Windows XP, haga clic en Inicio, Ejecutar, tipo Services.msc en el cuadro Abrir y a continuación, haga clic en Aceptar.
  2. En la lista de servicios en el panel de Detalles , haga doble clic en Servicio de interfaz humana HIDy, a continuación, asegúrese de que el tipo de inicio está establecido en automático.
Si recibe un código de error cuando intenta iniciar el servicio de interfaz humana HID, pruebe el método 4. Sin embargo, si recibe el código de error 126 o código de error 2, pruebe uno de los procedimientos siguientes:
  • Si recibe un código de error 126, extraiga el archivo Hidserv.dll. Para ello, siga estos pasos:
    1. Buscar el Hidserv.dll en la unidad del sistema. Si no lo encuentra en la unidad del sistema, busque el archivo en el CD de Windows.
    2. Utilice las teclas de dirección para seleccionar el extractoy, a continuación, presione ENTRAR.
    3. Utilice las teclas de dirección para seleccionar la carpeta C:\Windows\System32 y, a continuación, seleccione esta carpeta como destino.
    4. Reinicie el equipo.
  • Si recibe un código de error 2, cambiar la configuración del registro. Para ello, siga estos pasos.

    Nota Este problema también puede producirse debido a cambios en la configuración del registro.

    Importante: Esta sección, el método o la tarea contiene pasos que le indican cómo modificar el registro. Sin embargo, pueden producirse problemas graves si modifica incorrectamente el registro. Por lo tanto, asegúrese de que sigue estos pasos cuidadosamente. Para una mayor protección, copia de seguridad del registro antes de modificarlo. Luego puede restaurar el registro si surge algún problema. Para obtener más información acerca de cómo hacer copia de seguridad y restaurar el registro, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
    322756 Cómo hacer copia de seguridad y restaurar el registro en Windows
    Para resolver este problema, active los servicios HID en el equipo. Para ello, siga estos pasos:
    1. Inicie el Editor del registro.
      • En Windows Vista o Windows 7, haga clic en Inicio<b00> </b00>
        Contraer esta imagenAmpliar esta imagen
        el botón Inicio
        , tipo Regedit en el cuadro Iniciar búsqueda y presione ENTRAR.

        Contraer esta imagenAmpliar esta imagen
        Permiso de Control de cuentas de usuario
        Si se le pide una contraseña de administrador o una confirmación, escriba la contraseña o haga clic en continuar.
      • En Windows XP, haga clic en Inicio, Ejecutar, tipo Regedit en el cuadro Abrir y a continuación, haga clic enAceptar.
    2. Busque y, a continuación, haga clic en la clave del registro siguiente:
      HKEY_LOCAL_MACHINE/System
    3. Expanda el sistema.
    4. Expanda ControlSet001.
    5. Expanda Serviciosy, a continuación, haga clic en HidServ.
    6. En el panel derecho, haga clic en tipoy, a continuación, haga clic en Modificar.
    7. En el cuadro información del valor , asegúrese de que el valor se establece en 20y, a continuación, haga clic en Aceptar.
    8. Expanda HidServy, a continuación, haga clic en parámetros.

      Nota Si la clave del registro de parámetros no existe, siga estos pasos:
      1. Haga clic en HidServ.
      2. En el menú Edición , seleccione nuevoy, a continuación, haga clic en clave.
      3. Tipo Parámetros, y, a continuación, presione ENTRAR.
    9. En el panel derecho, haga clic en ServiceDlly, a continuación, haga clic en Modificar.

      Nota Si el valor de registro ServiceDll no existe, siga estos pasos:
      1. Haga clic en parámetros.
      2. En el menú Edición , seleccione nuevoy, a continuación, haga clic en Valor de cadena expandible.
      3. Tipo ServiceDll, y, a continuación, presione ENTRAR.
    10. En el cuadro información del valor , compruebe que el valor se establece en %SystemRoot%\System32\hidserv.dll. (Compruebe que no hay ningún espacio antes, después o en este valor). Si el valor no es%SystemRoot%\System32\hidserv.dll, escriba %SystemRoot%\System32\hidserv.dll en los datos del valor y a continuación, haga clic en Aceptar.
    11. Repita los pasos del 5 al 10 para cada clave del registro que contiene "ControlSet" en el nombre de clave. Por ejemplo, si hay una clave del registro que se denomina CurrentControlSet o ControlSet002, haga clic en CurrentControlSet o haga clic en ControlSet002. A continuación, repita los pasos del 5 al 10.
    12. Salga del Editor del registro y, a continuación, reinicie el equipo.

Método 4: Prueba en un equipo diferente

Si el problema persiste, pruebe el teclado con un equipo diferente. Si el teclado no funciona correctamente con el otro equipo, póngase en contacto con nuestro escritorio de orden para obtener un teclado de reemplazo. Para ello, llame a (800) 360-7561.

Para obtener más información, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
326246 Cómo sustituir perdidos, dañados o que falten o hardware de software de Microsoft

Más información

Para obtener más información acerca de un problema en el que se restablecen los ajustes de audio al cambiar el hardware de audio o de sonido, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
266680 Se restauran los valores predeterminados del sonido usuario a la configuración predeterminada de Windows
Para obtener más información acerca de un problema en qué volumen no persiste la configuración cuando se reinicie el equipo, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
273033 Configuración del control de volumen no puede persistir después de reiniciar el equipo

Propiedades

Id. de artículo: 932875 - Última revisión: jueves, 31 de octubre de 2013 - Versión: 7.0
La información de este artículo se refiere a:
  • Microsoft Basic Wireless Optical Desktop
  • Microsoft Comfort Curve Keyboard 2000
  • Microsoft Digital Media Keyboard 3000
  • Microsoft Digital Media Pro Keyboard
  • Microsoft Multimedia Keyboard
  • Microsoft Natural Ergonomic Desktop 7000
  • Microsoft Natural Ergonomic Keyboard 4000
  • Microsoft Natural MultiMedia Keyboard
  • Microsoft Wireless Entertainment Desktop 8000
  • Microsoft Wireless Entertainment Desktop 7000
  • Microsoft Wireless Laser Desktop 7000
  • Microsoft Wireless Laser Desktop 6000 v2.0
  • Microsoft Wireless Laser Desktop 6000
  • Microsoft Wireless Laser Desktop 5000
  • Microsoft Wireless Laser Desktop 4000
  • Microsoft Wireless Laser Desktop 3000
  • Microsoft Wireless Optical Desktop 5000
  • Microsoft Wireless Optical Desktop 4000
  • Microsoft Wireless Optical Desktop 3000
  • Microsoft Wireless Optical Desktop 2000
  • Microsoft Optical Desktop Elite for Bluetooth
  • Microsoft Wireless Optical Desktop 700 v2.0
  • Microsoft Wireless Optical Desktop 700
  • Microsoft Wireless Optical Desktop Pro 2.0
  • Microsoft Wireless Optical Desktop Elite
  • Microsoft Laser Mouse 6000
  • Microsoft Optical Mouse
  • Microsoft Optical Mouse by Starck
  • Microsoft Wireless IntelliMouse Explorer para Bluetooth
  • Microsoft Wireless Laser Mouse 8000
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Palabras clave: 
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Haga clic aquí para ver el artículo original (en inglés): 932875

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