Windows Media サービスからオーディオまたはビデオ ストリームを Windows Media Player を使用すると、エラー メッセージ:「に指定されたプロトコルがサポートされていません」

文書翻訳 文書翻訳
文書番号: 940029 - 対象製品
すべて展開する | すべて折りたたむ

目次

現象

問題 1

オーディオまたは Microsoft Windows Media サービスからビデオをストリーム配信すると、Microsoft Windows Media Player で、次のようなエラー メッセージが表示されます可能性があります。
指定されたプロトコルがサポートされていません。
メモ ハード ディスク ドライブに格納されているコンテンツを再生すると、この問題は発生しません。

問題 2

Windows Media Player のオプション ] メニューの [の ネットワーク タブをクリックするも何も起こりません。

問題 3

Windows Media Player ネットワーク ] タブ、プロトコルの"ストリーミング プロキシの設定] 一覧は空です。

原因

この現象は、以下のいずれかの条件に該当する場合に発生することがあります:
  • Wmnetmgr.dll ファイルが登録されていません。

    メモ Wmnetmgr.dll ファイルは C:\Windows\System32 フォルダーにあります。
  • Wmsdkns.xml ファイルが壊れています。

    メモ ファイルは、Windows Media Player のネットワークの名前空間ファイルです。
  • Wmsdkns.xml ファイルが不適切なアクセス許可を持ちます。

解決方法

この問題を解決をするには、次の方法のいずれかを使用します。

方法 1

アカウント、Administrators グループ内にあるを使用して Wmnetmgr.dll ファイルを登録します。 コマンド プロンプトで、次のコマンドを実行します。
regsvr32 wmnetmgr.dll

方法 2

Windows Media Player を使用しているユーザー アカウントが、Wmsdkns.xml ファイルに対する変更アクセス許可を確認します。

メモ Windows Vista では、ファイルを C:\Users\ Userame \AppData\Local\Microsoft\Windows Media\11.0 フォルダーにあります。 Windows XP では、ファイルを C:\Documents と Settings\ の UserName の \Local Settings\Application Data\Microsoft\Windows Media\11.0 フォルダーにあります。

方法 3

Wmsdkns.xml ファイルを削除します。 それを削除した後 Windows Media Player は、Wmsdkns.xml ファイルを再作成します。

詳細

この問題を再現する手順

  1. アカウント、Administrators グループ内にあるを使用して、Wmnetmgr.dll ファイル登録を解除します。 コマンド プロンプトで、次のコマンドを実行します。
    regsvr32 /u wmnetmgr.dll
  2. Windows Media Player を使用しているユーザー アカウントが、Wmsdkns.xml ファイルの拒否のアクセス許可を確認します。

プロパティ

文書番号: 940029 - 最終更新日: 2008年2月18日 - リビジョン: 3.0
この資料は以下の製品について記述したものです。
  • Microsoft Windows Media Player 11
キーワード:?
kbtshoot kbprb kbmt KB940029 KbMtja
機械翻訳の免責
重要: このサポート技術情報 (以下「KB」) は、翻訳者による翻訳の代わりに、マイクロソフト機械翻訳システムによって翻訳されたものです。マイクロソフトは、お客様に、マイクロソフトが提供している全ての KB を日本語でご利用いただけるように、翻訳者による翻訳 KB に加え機械翻訳 KB も提供しています。しかしながら、機械翻訳の品質は翻訳者による翻訳ほど十分ではありません。誤訳や、文法、言葉使い、その他、たとえば日本語を母国語としない方が日本語を話すときに間違えるようなミスを含んでいる可能性があります。マイクロソフトは、機械翻訳の品質、及び KB の内容の誤訳やお客様が KB を利用されたことによって生じた直接または間接的な問題や損害については、いかなる責任も負わないものとします。マイクロソフトは、機械翻訳システムの改善を継続的に行っています。
英語版 KB:940029
Microsoft Knowledge Base の免責: Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。

フィードバック

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com