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An update is available to fix a Background Intelligent Transfer Service (BITS) crash on a Windows Vista-based computer

Article ID:940520
Last Review:October 3, 2007
Revision:3.1
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SYMPTOMS

After you download updates from Windows Updates on a Windows Vista-based computer, you may experience the following symptoms:
A dialog appears that indicates that the host process for Windows Services has stopped working.
After you restart the computer, a Windows Update dialog box appears. This dialog box contains the following message:
Some Updates were not installed
Failed: xx updates
Error(s) Found:
Code 800706BA
An event that resembles the following is logged in the Application log:

Event Type: Error
Event Source: Application Error
Event Category: None
Event ID: 1000
Date: date
Time: time
Computer: computer name
User: N/A
Description: Faulting application svchost.exe_BITS, version 6.0.6000.16386, time stamp 0x4549adc4, faulting module qmgr.dll, version 7.0.6000.16386, time stamp 0x4549bd9f, exception code 0xc0000005

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CAUSE

This problem occurs because the Background Intelligent Transfer Service (BITS) state files are corrupted. This problem stops the host process for Windows Services. This behavior prevents you from using BITS to transfer files.

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RESOLUTION

An update is available to resolve this problem. The BITS Repair Tool will help you fix a problem caused by the corruption of BITS state files. The problem stops the host process for Windows Services. This behavior prevents you from using BITS to transfer files. Use this tool to resolve the corruption and to re-enable BITS transfers. After you run this tool, you may have to restart the computer.

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Download information

The following file is available for download from the Microsoft Download Center:

Windows Vista, 32-bit versions

DownloadDownload the 940520 package now. (http://www.microsoft.com/downloads/details.aspx?FamilyId=2829E460-4045-435B-B165-2C1496CD94A4&displaylang=en)

Windows Vista, 64-bit versions

DownloadDownload the 940520 package now. (http://www.microsoft.com/downloads/details.aspx?FamilyId=C9E36415-E97B-46A6-AB7E-4F89FFF4D8AF)

For more information about how to download Microsoft support files, click the following article number to view the article in the Microsoft Knowledge Base:
119591 (http://support.microsoft.com/kb/119591/) How to obtain Microsoft support files from online services
Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help prevent any unauthorized changes to the file.

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You can also resolve this problem manually by using one of the following methods.

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Method 1

1.Enable the View Hidden Files option. To do this, follow these steps:
a. Click Start  the Start button , click Control Panel, click Folder Options, and then click the View tab.
b. Click Show hidden files and folders, and then click OK.
2.As a system administrator, locate the Programdata\Microsoft\Network\Downloader folder, and then delete all files that have a file name that begins with Qmgr. To do this, follow these steps:
a. Click Start  the Start button, type \Programdata\Microsoft\network\downloader in the Start Search box, and then press ENTER.
b. In the Downloader window, select and then delete any files that begin with Qmgr. For example, delete the following files:
Qmgr0.dat
Qmgr1.dat
Notes
If the files are not deleted, restart the computer in safe mode without networking. To do this, use Method 2 or Method 3.
If the files are deleted successfully, immediately open Windows Update, and then install the latest updates.

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Method 2

1. Restart the computer.
2. Press the F8 key as the computer restarts.

Note You have to press the F8 key before the Windows Vista progress indicator appears.
3. When the Advanced Boot Options menu appears, use the arrow keys to select Safe Mode, and then press ENTER.
4.Enable the View Hidden Files option. To do this, follow these steps:
a. Click Start  the Start button , click Control Panel, click Folder Options, and then click the View tab.
b. Click Show hidden files and folders, and then click OK.
5.As a system administrator, locate the Programdata\Microsoft\Network\Downloader folder, and then delete all files that have a file name that begins with Qmgr. To do this, follow these steps:
a. Click Start  the Start button , type Programdata\Microsoft\network\downloader in the Start Search box, and then press ENTER.
b. In the Downloader window, select and then delete any files that begin with Qmgr. For example, delete the following files:
Qmgr0.dat
Qmgr1.dat
6.Immediately open Windows Update, and then install the latest updates.

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Method 3

1. Restart the computer in the safe mode without networking. To do this, follow these steps:
a. Exit all open programs.
b. Click Start  the Start button , type Run in the Start Search box, and then press ENTER.
c. Type msconfig, and then click OK.

The System Configuration Utility appears.
d. Click the Boot tab, click to select the Safe boot check box, click to select the Minimal check box, and then click OK.
e. Restart the computer when you are prompted.
2.Enable the View Hidden Files option. To do this, follow these steps:
a. Click Start  the Start button , click Control Panel, click Folder Options, and then click the View tab.
b. Click Show hidden files and folders, and then click OK.
3.As a system administrator, locate the "Programdata\Microsoft\Network\Downloader" folder, and then delete all files that have a file name that begins with Qmgr. To do this, follow these steps:
a. Click Start  the Start button , type \Programdata\Microsoft\network\downloader in the Start Search box, and then press ENTER.
b. In the Downloader window, select and delete any files that begin with Qmgr. For example, delete the following files:
Qmgr0.dat
Qmgr1.dat
4. Restart the computer in normal mode. To do this, follow these steps:
a. Exit all open programs.
b. Click Start  the Start button, type Run in the Start Search box, and then press ENTER.
c. Type msconfig, and then click OK. The System Configuration Utility appears.
d. On the Boot tab, click to clear the Safe boot check box, and then click OK to restart the computer.
e. Restart the computer when you are prompted.
5.Immediately open Windows Update, and then install the latest updates.

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STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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APPLIES TO
Windows Vista Enterprise 64-bit Edition
Windows Vista Home Basic 64-bit Edition
Windows Vista Home Premium 64-bit Edition
Windows Vista Ultimate 64-bit Edition
Windows Vista Business
Windows Vista Business 64-bit Edition
Windows Vista Enterprise
Windows Vista Home Basic
Windows Vista Home Premium
Windows Vista Starter
Windows Vista Ultimate

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Keywords: 
kbtshoot kbprb kbexpertisebeginner KB940520

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