Problemas de rendimiento causados por una pérdida de memoria en un servidor de impresión basado en Windows Server 2008 que tiene muchos clientes de impresora basada en Windows Vista

Seleccione idioma Seleccione idioma
Id. de artículo: 951638 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Síntomas

Considere el siguiente escenario:
  • Se tener un servidor de impresión basado en Windows Server 2008.
  • Este servidor de impresión tiene muchas ventanas Clientes de impresora basada en la vista.
En este escenario, el uso de memoria de la Servicio de cola de impresión aumenta significativamente con el tiempo. Por ejemplo, este problema se produce cuando varios clientes de miles de impresora envían sus trabajos de impresión al servidor de impresión. Finalmente, el servidor de impresión deja de responder y, a continuación, debe reiniciar el servidor para recuperarse de este problema. Dependiendo de la carga de la impresión, esto problema puede ocurrir después de que el sistema ha estado ejecutándose durante un día o para varias semanas.

Además, cuando un usuario intenta imprimir los documentos un equipo basado en Windows Vista, la impresión aleatoriamente trabajo falla y el usuario recibe el siguiente mensaje de error:
Windows no puede conectarse a la impresora. No se está ejecutando el servicio de cola de impresión del servidor. Por favor, reinicie a la cola en el servidor o reinicie el equipo del servidor

Causa

Este problema se produce debido a una pérdida de memoria en el servicio de cola de impresión. El servicio de cola de impresión mantiene un cola de notificación del cliente sin delimitar. Además, el servicio de cola de impresión almacena en caché una estructura DEVMODE para cada identificador de cliente que se abre de la impresora. En combinación, estas dos funcionalidades consuman mucha memoria cuando muchos clientes de la impresora tener acceso a este servidor de impresión.

Además, Los clientes de la impresora basada en la Vista de Windows utilizan asincrónica llamadas de procedimiento remoto (RPC) para recuperar las notificaciones de cambio de la impresora. Por lo tanto, muchas RPC asincrónicas se programan cuando muchos clientes de la impresora Utilice el servidor de impresión. Después del número total de enviado RPC llega a un límite de 6.000, el usuario de cliente recibe el mensaje de error que se menciona en la sección "Síntomas".

Solución

Información de la revisión

A hotfix compatible está disponible desde Microsoft. Sin embargo, esta revisión se diseñó Para corregir el problema descrito en este artículo. Aplicar este revisión sólo a sistemas que experimenten este problema específico. Este hotfix es posible que se realicen pruebas adicionales. Por lo tanto, si no se ve afectado gravemente por este problema, le recomendamos que espere para el siguiente software de actualización que contenga este hotfix.

Si la revisión está disponible para su descarga, no existe es una sección de "Descarga de revisión disponible" en la parte superior de esta Base de conocimientos artículo. Si no aparece en esta sección, póngase en contacto con el servicio al cliente de Microsoft y soporte técnico para obtener la revisión.

NotaSi se producen problemas adicionales o si cualquier solución de problemas es necesario, es posible que deba crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicará a las cuestiones y problemas que no reúnan los requisitos para Esta revisión en cuestión. Para obtener una lista completa de servicio al cliente de Microsoft y Compatibilidad con los números de teléfono o para crear una solicitud de servicio independiente, visite el sitio Web de Microsoft siguiente:
http://support.Microsoft.com/contactus/?ws=support
NotaEl formulario de "Descarga de revisión disponible" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque un revisión no está disponible para ese idioma.

Revisiones importantes de Windows Vista y Windows Server 2008 se incluyen en los mismos paquetes. Sin embargo, sólo uno de estos productos pueden aparecer en la página de "Solicitud de revisión". Para solicitar el paquete de revisiones que se aplica a Windows Vista y Windows Server 2008, seleccione el producto que aparece en la página.

Requisitos previos

No hay requisitos previos.

Requisito de reinicio

Debe reiniciar el equipo después de aplicar este hotfix.

Información de reemplazo de hotfix

Este hotfix no sustituye a otras revisiones.

Información de archivo

La versión en inglés de esta revisión tiene el archivo atributos (u otros posteriores) que figuran en la tabla siguiente. Las fechas y horas de estos archivos se muestran en hora Universal coordinada (UTC). Al ver la información del archivo, se convierte en hora local. Para encontrar la diferencia entre la hora UTC y la hora local, utilice elTiempo Zonaficha en laFecha y horaelemento de Control Panel.
Windows Server 2008, versiones basadas en 86 x
Contraer esta tablaAmpliar esta tabla
Nombre de archivoVersión del archivoArchivo tamañoFechaTiempoPlataforma
Localspl.dll6.0.6001.22200634,36811-Jun-200805: 23x 86
Spoolss.dll6.0.6001.22200163,84011-Jun-200805: 23x 86
Spoolsv.exe6.0.6001.22200126,97611-Jun-200803: 41x 86
Windows Server 2008, versiones basadas en Itanium
Contraer esta tablaAmpliar esta tabla
Nombre de archivoVersión del archivoArchivo tamañoFechaTiempoPlataformaRama de servicio
Localspl.dll6.0.6001.222001,617,92011-Jun-200805: 36IA-64No disponible
Spoolss.dll6.0.6001.22200446,46411-Jun-200805: 39IA-64No disponible
Spoolsv.exe6.0.6001.22200437,24811-Jun-200819: 04IA-64No disponible
Localspl.dll6.0.6001.22200634,36811-Jun-200805: 23x 86SysWOW64
Spoolss.dll6.0.6001.22200163,84011-Jun-200805: 23x 86SysWOW64
Windows Server 2008, las versiones de 64 x
Contraer esta tablaAmpliar esta tabla
Nombre de archivoVersión del archivoArchivo tamañoFechaTiempoPlataformaRama de servicio
Localspl.dll6.0.6001.22200788,48011-Jun-200805: 50x 64No disponible
Spoolss.dll6.0.6001.22200241,66411-Jun-200805: 50x 64No disponible
Spoolsv.exe6.0.6001.22200268,80011-Jun-200804: 26x 64No disponible
Localspl.dll6.0.6001.22200634,36811-Jun-200805: 23x 86SysWOW64
Spoolss.dll6.0.6001.22200163,84011-Jun-200805: 23x 86SysWOW64

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft que se enumeran en la sección "Se refiere a:".

Más información

Para obtener más información acerca de terminología de la actualización de software, haga clic en el artículo siguiente número para ver el artículo de Microsoft Knowledge Base:
824684Descripción de la terminología estándar que se utiliza para describir las actualizaciones de software de Microsoft

Propiedades

Id. de artículo: 951638 - Última revisión: martes, 15 de marzo de 2011 - Versión: 1.0
La información de este artículo se refiere a:
  • Windows Server 2008 Standard
  • Windows Server 2008 Enterprise
  • Windows Server 2008 Datacenter
  • Windows Server 2008 Standard without Hyper-V
  • Windows Server 2008 Enterprise without Hyper-V
  • Windows Server 2008 Datacenter without Hyper-V
  • Windows Server 2008 for Itanium-Based Systems
  • Windows Web Server 2008
Palabras clave: 
kbautohotfix kbexpertiseinter kbbug kbfix kbqfe kbmt KB951638 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 951638

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com