Error message when you use the Windows Update Web site or Microsoft Update Web site to install updates: "0x80070017"

Article translations Article translations
Article ID: 956704 - View products that this article applies to.
Expand all | Collapse all

On This Page

SYMPTOMS

When you try to install updates from the Microsoft Windows Update Web site or the Microsoft Update Web site, you may receive the following error message:
0x80070017

CAUSE

This issue may occur if there is a cyclic redundancy check (CRC) failure during the update process. This failure may occur if the received file is not the file that is expected by Windows Update

RESOLUTION

To resolve this issue, use one of the following methods.

Method 1

Run the Chkdsk.exe tool to check the disk for errors

For Windows 2000, Windows XP, or Windows Server 2003, follow these steps:
  1. Click Start, and then click Run.
  2. Type cmd in the Open box, and then click OK.
  3. At the command prompt, type Chkdsk /f, and then press ENTER.
  4. Press Y when you are prompted to check the disk next time that the system restarts.
  5. Close all applications and restart the computer.

    Note During the restart process, Windows checks the disk for errors and then start.s
  6. After the computer has restarted, install the updates again.
For Windows Vista and Windows Server 2008, follow these steps:
  1. Click Start, type cmd in the Start Search box, right-click cmd in the Programs list, and then click Run as administrator. If you are prompted for an administrator password or confirmation, type your password, or click Continue.
  2. At the command prompt, type Chkdsk /f, and then press ENTER.
  3. Press Y when you are prompted to check the disk next time that the system restarts.
  4. Close all applications, and then restart the computer.

    Note During the restart process, Windows checks the disk for errors and then starts.
  5. After the computer has restarted, install the updates again.
If Method 1 does not resolve this issue, try Method 2.

Method 2

Rename the Download folder.

For Windows 2000, for Windows XP, and for Windows Server 2003, follow these steps:
  1. Click Start, click Run, type notepad in the Open box, and then click OK.
  2. Copy the following commands, and then paste them into the Notepad file:
    net stop wuauserv
    CD %systemroot%\SoftwareDistribution
    Ren Download Download.old
    net start wuauserv
  3. On the File menu, click Save as.
  4. In the File name box, type rename.bat, and then click All Files in the Save as type box.
  5. Save the rename.bat file to the desktop.
  6. Double-click the rename.bat file to register the Windows Update files.
  7. Try to install updates again.
Note When the updates are installed successfully, you can safely delete the rename.bat file.

For Windows Vista and for Windows Server 2008, follow these steps:
  1. Click Start, type notepad in the Start Search box, and then click notepad in the Programs list.
  2. Copy the following commands, and then paste them into the Notepad file:
    net stop wuauserv
    CD %systemroot%\SoftwareDistribution
    Ren Download Download.old
    net start wuauserv
  3. On the File menu, click Save as.
  4. In the File name box, type rename.bat, and then click All Files (*.*) in the Save as type box.
  5. Save the rename.bat file to the desktop.
  6. Right-click the rename.bat file, and then click Run as administrator.

    If you are prompted for an administrator password or for a confirmation, type the password, or click Continue.
  7. Try to install updates again.
Note When the updates are installed successfully, you can safely delete the rename.bat file.

Properties

Article ID: 956704 - Last Review: September 9, 2008 - Revision: 2.0
APPLIES TO
  • Microsoft Windows Update
  • Microsoft Update
Keywords: 
kbtshoot kberrmsg kbexpertisebeginner kbprb KB956704

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com