Artigo: 958044 - Última revisão: quarta-feira, 5 de Janeiro de 2011 - Revisão: 1.0

Obtém um código de erro "0x80070490" ao utilizar os Web sites Windows Update ou Microsoft Update para instalar actualizações

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.

Nesta página

Expandir tudo | Reduzir tudo

Sintomas

Ao tentar ligar aos Web sites Windows Update ou Microsoft Update, poderá receber o seguinte código de erro:
0x80070490

Causa

Este problema pode ocorrer se o manifesto Modelo de Serviço Baseado em Componentes (CBS) estiver danificado.

Resolução

Para resolver o problema, siga os passos adequados ao seu sistema operativo.

Windows 2000, Windows XP e Windows Server 2003

Para resolver este problema, utilize o Verificador de ficheiros de sistema para verificar a existência das versões correctas dos ficheiros de sistema. Para o fazer, siga estes passos:
  1. Clique em Iniciar e, em seguida, clique em Executar.
  2. Copie e cole (ou escreva) o seguinte comando na caixa Abrir e prima ENTER:
    cmd
  3. Na linha de comandos, escreva sfc /scannow e prima ENTER.

    Nota: caso seja solicitado o CD do Windows XP, insira o CD na respectiva unidade.
  4. Depois de concluído o processo do Verificador de ficheiros de sistema, tente instalar novamente as actualizações.
Para mais informações sobre o Verificador de ficheiros de sistema, clique no número de artigo que se segue para ver o artigo na Base de Dados de Conhecimento Microsoft:
310747  (http://support.microsoft.com/kb/310747/ ) Descrição do verificador de ficheiros de sistema do Windows XP e do Windows Server 2003 (Sfc.exe)
Se o Verificador de ficheiros de sistema não tiver resolvido o problema, será necessário efectuar uma instalação de reparação do Windows XP.

Para mais informações sobre como efectuar uma instalação de reparação do Windows XP, clique no número de artigo que se segue para ver o artigo na Base de Dados de Conhecimento Microsoft:
315341  (http://support.microsoft.com/kb/315341/ ) Como efectuar uma actualização directa (reinstalação) do Windows XP

Quando a instalação de reparação estiver concluída, tente instalar novamente as actualizações.

Nota: o processo de instalação de reparação não danifica ficheiros ou aplicações já instalados no computador.

Windows Vista, Windows Server 2008, Windows 7 e Windows Server 2008 R2

Para resolver este problema, siga os passos indicados no método 1. Se este não resolver o problema, avance para o método 2.

Método 1: executar a Ferramenta de Preparação para Actualização do Sistema (Checksur.exe)

  1. Transfira e execute a Ferramenta de Preparação para Actualização do Sistema. Esta ferramenta verifica a existência de inconsistências que possam impedir operações de manutenção futuras uma única vez. Para mais informações sobre como transferir e executar a ferramenta Checksur.exe, clique no número de artigo que se segue para ver o artigo na Base de Dados de Conhecimento Microsoft:
    947821  (http://support.microsoft.com/kb/947821/ ) Descrição da Ferramenta de Preparação para Actualização do Sistema para o Windows Vista, para o Windows Server 2008 e para o Windows 7
  2. Tente instalar actualizações novamente.
Nota: após a ferramenta ter sido executada, o ficheiro Checksur.log é guardado na seguinte localização: %systemroot%\Logs\CBS

Numa instalação padrão do Windows, %systemroot% representa o directório do Windows.

Se este método não tiver resolvido o problema, avance para o Método 2.

Método 2: efectuar uma instalação de reparação do Windows

Se o método 1 não tiver resolvido este problema, será necessário efectuar uma instalação de reparação do Windows Vista, Windows Server 2008, Windows 7 ou Windows Server 2008 R2. O processo de instalação de reparação restaura a instalação actual do Windows para a versão do DVD de instalação. Também será necessário instalar todas as actualizações não incluídas no DVD de instalação.

Nota: o processo de instalação de reparação não danifica ficheiros ou aplicações já instalados no computador.

Para efectuar uma instalação de reparação do Windows Vista, Windows Server 2008, Windows 7 ou Windows Server 2008 R2, siga estes passos:
  1. Feche todas as aplicações e reinicie o computador.
  2. Insira o DVD do Windows Vista, Windows Server 2008, Windows 7 ou Windows Server 2008 R2 na unidade de DVD do computador.
  3. Na janela da configuração, clique em Instalar agora.

    Nota: se o Windows não detectar automaticamente o DVD, siga estes passos:
    1. Clique em Iniciar
      Reduzir esta imagemExpandir esta imagem
       Start button
      e escreva Unidade:\setup.exe na caixa Iniciar procura.

      Nota: o marcador de posição Unidade representa a letra de unidade da unidade de DVD do computador.
    2. Na lista de Programas, clique em Setup.exe.
    3. Na janela da configuração, clique em Instalar agora.
  4. Clique em Aceder à Internet para obter as actualizações mais recentes para instalação (recomendado).
  5. Escreva a chave do CD se tal lhe for solicitado.
  6. Clique em Sim para aceitar os Termos de Licenciamento para Software Microsoft.
  7. No ecrã Que tipo de instalação pretende?, clique em Actualização.
  8. Quando a instalação estiver concluída, reinicie o computador e tente instalar as actualizações.

A informação contida neste artigo aplica-se a:
  • Microsoft Windows Update
  • Microsoft Update
Palavras-chave: 
kbupdateissue kbinstallation kbexpertisebeginner kbtshoot kberrmsg kbprb KB958044