ID do artigo: 958044 - Última revisão: quinta-feira, 28 de julho de 2011 - Revisão: 1.0

Você recebe um código de erro "0x80070490" ao usar os sites do Windows Update ou Microsoft Update para instalar atualizações

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.

Nesta página

Expandir tudo | Recolher tudo

Sintomas

Ao tentar conectar o site do Windows Update ou Microsoft Update, você pode receber o seguinte código de erro:
0x80070490

Causa

Este problema pode ocorrer se há corrupção no manifesto do Serviço Baseado em Componente (CBS).

Resolução

Para resolver este problema, siga as etapas que são adequadas para o seu sistema operacional.

Windows 2000, Windows XP e Windows Server 2003

Para resolver este problema, use o Verificador de Arquivo de Sistema para verificar se as versões corretas dos arquivos do sistema estão presentes. Para fazer isto, execute as seguintes etapas:
  1. Clique em Iniciar e em Executar.
  2. Copie e cole (ou digite) o seguinte comando na caixa Abrir e pressione ENTER.
    cmd
  3. No prompt de comando, digite sfc /scannow e pressione ENTER.

    Observação Se você for solicitado pelo CD do Windows XP, insira o CD na unidade de CD.
  4. Depois que o Verificador de Arquivo de Sistema ser concluído, tente instalar atualizações novamente.
Para obter mais informações sobre o Verificador de Arquivo de Sistema, clique no número do artigo correspondente para visualizá-lo na Base de Dados de Conhecimento Microsoft:
310747  (http://support.microsoft.com/kb/310747/pt-br/ ) Descrição do Verificador de Arquivos de Sistema do Windows XP e do Windows Server 2003 (Sfc.exe)
Se o Verificador de Arquivo de Sistema não resolver o problema, você deve executar uma instalação de reparo do Windows XP.

Para obter mais informações sobre como executar uma instalação de reparo do Windows XP, clique no número de artigo correspondente para visualizá-lo na Base de Dados de Conhecimento Microsoft:
315341  (http://support.microsoft.com/kb/315341/pt-br/ ) Como realizar uma atualização in-loco (reinstalação) do Windows XP

Após a instalação de reparo ser concluída, tente instalar as atualizações novamente.

Observação Executar uma instalação de reparo não danificará os arquivos e aplicativos que estão instalados atualmente no seu computador.

Windows Vista, Windows Server 2008, Windows 7 e Windows Server 2008 R2

Para resolver este problema, siga as etapas no método 1. Se o método 1 não revolver o problema, avance para o método 2.

Método 1: execute a ferramenta de Preparação para Atualização do Sistema (Checksur.exe)

  1. Baixe e execute a ferramenta Preparação para Atualização do Sistema. Esta ferramenta executa uma verificação única para inconsistências que podem prevenir operações de instalação futuras. Para obter mais informações sobre como baixar e executar a ferramenta Checksur.exe, clique no número do artigo correspondente para visualizá-lo na Base de Dados de Conhecimento Microsoft:
    947821  (http://support.microsoft.com/kb/947821/pt-br/ ) Descrição da Ferramenta de Preparação de Atualização do Sistema para Windows Vista, Windows Server 2008, Windows 7 e Windows Server 2008 R2
  2. Tente instalar atualizações novamente.
Observação Após executar a ferramenta, o arquivo Checksur.log é salvo no seguinte local: %systemroot%\Logs\CBS

Em uma instalação padrão do Windows, o %systemroot% representa o diretório do Windows.

Se este método não resolver o problema, vá para o Método 2.

Método 2: execute uma instalação de reparo do Windows

Se o método 1 não resolver o problema, você deve executar uma instalação de reparo do Windows Vista, Windows Server 2008, Windows 7 ou Windows Server 2008 R2. Executar uma instalação de reparo restaurará a instalação atual do Windows para a versão do DVD de instalação. Isso também exige a instalação de todas as atualizações que não estão incluídas no DVD de instalação.

Observação Executar uma instalação de reparo não danificará arquivos e aplicativos que estão atualmente instalados no seu computador.

Para executar uma instalação de reparo do Windows Vista, Windows Server 2008, Windows 7 ou Windows Server 2008 R2, siga estas etapas:
  1. Feche todos os aplicativos em execução.
  2. Insira o DVD do Windows Vista, Windows Server 2008, Windows 7 ou Windows Server 2008 R2 na unidade de DVD.
  3. Na janela de Instalação, clique em Instalar agora.

    Observação Se o Windows não detectar automaticamente o DVD, siga estas etapas:
    1. Clique no botão Iniciar
      Recolher esta imagemExpandir esta imagem
      e digite Unidade:\setup.exe na caixa Iniciar Pesquisa.

      Observação O espaço reservado Unidade é a letra da unidade de DVD do computador.
    2. Na lista Programas clique em Setup.exe.
    3. Na janela de Instalação, clique em Instalar agora.
  4. Clique em Ir online para obter as atualizações mais recentes para instalação (recomendado).
  5. Digite a chave do CD se for solicitado.
  6. Selecione o sistema operacional na página "Instalar Windows" que deseja Atualizar ou Local.
  7. Clique em Sim para aceitar os Termos de Licença para Software Microsoft.
  8. Na tela Que tipo de instalação você deseja?, clique em Atualização.
  9. Quando a instalação for concluída, reinicie o computador e tente instalar as atualizações.

A informação contida neste artigo aplica-se a:
  • Microsoft Windows Update
  • Microsoft Update
Palavras-chave: 
kbupdateissue kbinstallation kbexpertisebeginner kbtshoot kberrmsg kbprb KB958044