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Article ID: 958045 - Last Review: September 26, 2008 - Revision: 1.0

Error code when you try to use Windows Update or Microsoft Update to install updates: "0x800B0001"

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SYMPTOMS

When you try to install updates from the Windows Update or Microsoft Update Web site, you receive the following error code:
0x800B0001

CAUSE

This issue occurs if Windows Update or Microsoft Update determines that the cryptographic service provider is unknown.

RESOLUTION

To resolve this issue, follow the steps that are appropriate for your particular operating system.

In Windows XP, in Windows Server 2003, and in Windows 2000

To resolve this issue, you must register the Softpub.dll, Wintrust.dll, Initpki.dll, and Mssip32.dl files. To do this, follow these steps:
  1. Start Notepad. To do this, click Start, and then click Run.
  2. Copy and then paste (or type) the following command in the Open box, and then press ENTER:
    notepad
  3. Copy and then paste (or type) the following command lines into the Notepad window:
    regsvr32 Softpub.dll /s
    regsvr32 Wintrust.dll /s
    regsvr32 Initpki.dll /s
    regsvr32 Mssip32.dll /s
  4. On the File menu, click Save As, and then type Register.bat.
  5. Click Save as type, and then click All Files.
  6. Save the Register.bat file to your desktop.
  7. Double-click the Register.bat file to register the Windows Update files.
  8. Try to install updates again.
  9. If the issue is resolved, delete the Register.bat file that you created in the previous steps.

In Windows Vista and in Windows Server 2008

Method 1: Run the System Update Readiness tool (Checksur.exe)

  1. Download and run the System Update Readiness tool (Checksur.exe). After you download this tool, it runs a one-time scan for inconsistencies that might prevent future servicing operations.

    For more information about how to download and run the System Update Readiness tool, click the following article number to view the article in the Microsoft Knowledge Base:
    947821  (http://support.microsoft.com/kb/947821/ ) Description of the System Update Readiness Tool for Windows Vista and for Windows Server 2008
    Notes
    • In article 947821, scroll down to the "Microsoft Download Center" section, and then click the associated link to download the System Update Readiness tool for your operating system.
    • After you run this tool, the Checksur.log file will be saved in the following location:
      %systemroot%\Logs\CBS
      In a default installation of Windows Vista, this is the C:\Windows\Logs\CBS folder.
  2. After the System Update Readiness tool runs, try to install updates again.
If these steps in do not resolve the issue, go to Method 2.

Method 2: Register the Wintrust.dll

  1. Click Start
    Collapse this imageExpand this image
     Start button
    , and then type cmd in the Start Search box.
  2. In the results list, right-click cmd, and then click Run as Administrator.
    Collapse this imageExpand this image
    User Account Control permission
    If you are prompted for an administrator password or for confirmation, type the password, or click Continue.
  3. At the command prompt, copy and then paste (or type) the following command.
    regsvr32 Wintrust.dll /s
  4. Close the Command Prompt window.
  5. Try to install updates again.

APPLIES TO
  • Microsoft Windows Update
  • Microsoft Update
Keywords: 
kbregistry kbupdateissue kberrmsg kbexpertisebeginner kbtshoot kbprb KB958045

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