คุณอาจได้รับรหัสข้อผิดพลาด "0x8007F0F4" เมื่อคุณพยายามติดตั้งโปรแกรมปรับปรุง จากเว็บไซต์ Windows Update หรือ จาก Microsoft Update เว็บไซต์

การแปลบทความ การแปลบทความ
หมายเลขบทความ (Article ID): 958051 - ผลิตภัณฑ์ที่เกี่ยวข้องในบทความนี้
ขยายทั้งหมด | ยุบทั้งหมด

เนื้อหาบนหน้านี้

อาการ

เมื่อคุณพยายามติดตั้งโปรแกรมปรับปรุง จากเว็บไซต์ Windows Update หรือ จาก Microsoft Update เว็บไซต์ คุณอาจได้รับรหัสข้อผิดพลาดต่อไปนี้:
0x8007F0F4

สาเหตุ

ปัญหานี้อาจเกิดขึ้นหากมีสถานการณ์สมมติต่อไปนี้มีอยู่บนคอมพิวเตอร์ของคุณ:
  • คุณกำลังพยายามที่ปรับปรุงแล็ปท็อปของคุณเมื่อคุณกำลังใช้พลังงานแบตเตอรี
  • การติดตั้งโปรแกรมปรับปรุงตรวจพบว่า การปรับปรุงไม่ถูกต้องสำหรับคอมพิวเตอร์ของคุณ
  • ปรับปรุงข้อกำหนดเบื้องต้นไม่มีการติดตั้งบนคอมพิวเตอร์ของคุณ

การแก้ไข

เมื่อต้องแก้ไขปัญหานี้ ใช้วิธีการต่อไปนี้จะนำไปใช้กับสถานการณ์ของคุณ

หมายเหตุ คุณอาจได้รับข้อผิดพลาด 0x8007F0F4 เมื่อคุณพยายามติดตั้งการปรับปรุงการรักษาความปลอดภัย 2686509 สำหรับข้อมูลเพิ่มเติมเกี่ยวกับวิธีการแก้ไขปัญหานี้ ให้คลิกหมายเลขบทความต่อไปนี้เพื่อดูบทความในฐานความรู้ของ Microsoft:
2686509 MS12-034: คำอธิบายของการปรับปรุงความปลอดภัยสำหรับ CVE-2012-0181 ใน Windows XP และ Windows Server 2003:8 พฤษภาคม 2012

วิธีที่ 1: เชื่อมต่อแล็ปท็อปไปเป็นไฟกระแสสลับ

ถ้าคุณกำลังพยายามปรับปรุงคอมพิวเตอร์แบบพกพาในขณะทำงานโดยใช้พลังงานจากแบตเตอรี่ ชั่วคราวเชื่อมต่อคอมพิวเตอร์แบบพกพามีไฟ AC และลองติดตั้งโปรแกรมปรับปรุงอีกครั้ง

วิธีที่ 2: ซ่อนการปรับปรุงไม่ถูกต้อง

ถ้าโปรแกรมประยุกต์ที่ติดตั้งการปรับปรุงการตรวจพบว่า การปรับปรุงไม่ถูกต้องสำหรับคอมพิวเตอร์ของคุณ มีเงื่อนไขใด ๆ ต่อไปนี้อาจเป็นจริง:
  • การปรับปรุงอาจมีการติดไว้ก่อนหน้านี้ตั้งไว้
  • การปรับปรุงเป็นรุ่นเก่ากว่าการปรับปรุงที่ติดตั้งอยู่ในขณะนี้
  • การปรับปรุงจะไม่เข้ากันกับคอมพิวเตอร์ของคุณ
การปรับปรุงนี้ควรจะถูกละเว้น หรือซ่อนอยู่ในอินเทอร์เฟซของ Windows Update หรือ Microsoft Update

เมื่อต้องซ่อนการปรับปรุงเพื่อที่จะไม่เสนออีก ให้ทำตามขั้นตอนเหล่านี้:
  1. แวะไปที่ Microsoft Update เว็บไซต์ต่อไปนี้:
    http://update.microsoft.com
  2. ทันทีที่สแกนหาการปรับปรุงเสร็จเรียบร้อยแล้ว คลิก แบบกำหนดเอง ในการ ขอต้อนรับสู่ Microsoft Update หน้า
  3. ในบานหน้าต่างนำทาง ฮาร์ดแวร์ หรือไม่ก็ได้. โปรแกรมปรับปรุงพร้อมใช้งานอยู่ เลือกการปรับปรุงฮาร์ดแวร์ หน้า
  4. ค้นหาโปรแกรมควบคุมฮาร์ดแวร์ที่เกี่ยวข้องกับข้อผิดพลาด คลิกที่ชื่อของการปรับปรุงเพื่อขยายรายละเอียดการปรับปรุง และจากนั้น คลิกเพื่อเปิดใช้งานการ ไม่ต้องแสดงโปรแกรมปรับปรุงนี้อีกครั้ง กล่องกาเครื่องหมาย
  5. คลิก ทบทวน และติดตั้งโปรแกรมปรับปรุง.
  6. ตรวจสอบว่า ไม่มีการปรับปรุงที่ซ่อนไว้สำหรับฮาร์ดแวร์ และจากนั้น คลิก ติดตั้งโปรแกรมปรับปรุง.

วิธีที่ 3: ดาวน์โหลด และติดตั้งการปรับปรุงด้วยตนเอง

เมื่อต้องดาวน์โหลด และติดตั้งการปรับปรุงด้วยตนเอง ให้ทำตามขั้นตอนเหล่านี้:
  1. แวะไปที่ Microsoft Update เว็บไซต์ต่อไปนี้:
    http://update.microsoft.com
  2. คลิก ตรวจทานประวัติการปรับปรุงของคุณ เมื่อต้องดูประวัติการปรับปรุง หรือตรวจสอบข้อผิดพลาดการตรวจสอบการปรับปรุงที่คุณต้องการติดตั้งด้วยตนเอง
  3. แวะไป Windows ดาวน์โหลดเว็บไซต์ต่อไปนี้:
    http://www.microsoft.com/windows/downloads/default.aspx
  4. พิมพ์หมายเลขบทความฐานความรู้ของ Microsoft ในหน้าต่างการค้นหาในการ ดาวน์โหลด หน้า และจากนั้นคลิก ไปยัง.

    ตัวอย่างเช่น ถ้าหมายเลขบทความที่มีอยู่สำหรับการปรับปรุงเป็น KB123456 พิมพ์ 123456 ในกล่องค้นหา และจากนั้นคลิก ไปยัง.
  5. เรียกดูรายการของเนื้อหาที่ส่งคืน และจากนั้น ค้นหาบทความฐานความรู้ที่มีการเชื่อมโยงไปที่ดาวน์โหลด
  6. ในบทความฐานความรู้ ค้นหา และคลิ กที่การเชื่อมโยงที่มีลักษณะต่อไปนี้:
    ดาวน์โหลดแพคเกจนี้
    หมายเหตุ ถ้าคุณได้รับพร้อมท์เพื่อตรวจสอบ Windows ให้ทำตามคำแนะนำในการตรวจสอบ Windows และทำการดาวน์โหลดการปรับปรุงต่อไป
  7. คลิก ดาวน์โหลดแล้ว คลิก บันทึก ในการ การดาวน์โหลดแฟ้ม กล่องโต้ตอบ
  8. จากนั้น บันทึกใน รายการ เลือก เดสก์ท็อป ตัวเลือก และจากนั้นคลิก บันทึก.
  9. ค้นหาแฟ้มที่คุณดาวน์โหลดไปยังเดสก์ท็อปของคุณ และคลิ กสองครั้งแฟ้มการติดตั้งการปรับปรุง
หมายเหตุ การติดตั้งการปรับปรุงอาจยังคงล้มเหลวถ้าการปรับปรุงไม่ถูกต้องสำหรับคอมพิวเตอร์ของคุณ

วิธีที่ 4: ตรวจสอบแฟ้มบันทึกที่มีอยู่สำหรับการปรับปรุงล้มเหลว

ถ้าวิธีที่ 1, 2 หรือ 3 ไม่สามารถแก้ไขปัญหานี้ คุณต้องใช้แฟ้มบันทึกเพื่อเก็บรวบรวมข้อมูลเพิ่มเติม โปรแกรมติดตั้ง Microsoft สร้างแฟ้มบันทึกสำหรับการปรับปรุงบางอย่าง แล้ว จะทำให้แฟ้มที่บันทึกในไดเรกทอรี Windows ถ้าแฟ้มนี้อยู่ บริษัทตัวแทนฝ่ายสนับสนุนของ Microsoft สามารถดูแฟ้มที่ระบุสาเหตุของปัญหา ถ้าไม่มีแฟ้ม.log วิธีที่ 5 แสดงรายการขั้นตอนที่คุณต้องทำตามเมื่อต้องสร้างไฟล์.log ที่บริษัทตัวแทนการสนับสนุน

เมื่อต้องการตรวจสอบแฟ้ม.log ที่ถูกสร้างขึ้นในระหว่างการปรับปรุงล้มเหลว ทำตามขั้นตอนเหล่านี้:
  1. คลิก เริ่ม, โปรแกรมทั้งหมดแล้ว คลิก Windows Update หรือ โปรแกรมปรับปรุงของ Microsoft.
  2. บนไซต์ Windows Update หรือ Microsoft Update เว็บ คลิก ตรวจทานประวัติการปรับปรุงของคุณ.
  3. ในการ สถานะ คอลัมน์ ค้นหาการปรับปรุงที่ล้มเหลว และหมายเหตุหมายเลขบทความฐานความรู้ที่เกี่ยวข้องกับโปรแกรมปรับปรุง

    หมายเหตุ ถ้าไม่มีบทความ Knowledge Base ที่เกี่ยวข้องกับ ล้มเหลวในการปรับปรุง ลองวิธีที่ 5
  4. ปิดหน้าต่าง Windows Update หรือ Microsoft Update
  5. คลิก เริ่มคลิก เรียกใช้ชนิด % systemroot %แล้ว คลิก ตกลง.
  6. ค้นหาตำแหน่งแฟ้ม.log ที่ชื่อหลังจากบทความฐานความรู้สำหรับการปรับปรุงล้มเหลวที่คุณบันทึกไว้ในขั้นตอนที่ 3 ตัวอย่างเช่น เพื่อการอัพเดล้มเหลวที่เกี่ยวข้องกับ KB123456 ค้นหาไฟล์.log ที่ชื่อ 123456.log
  7. ถ้าแฟ้ม.log นี้มีอยู่ ติดต่อฝ่ายสนับสนุนของ Microsoft และการอ้างอิงหมายเลขบทความฐานความรู้แล้ว เมื่อคุณพูดเพื่อเป็นผู้ทำหน้าที่สนับสนุน สำหรับข้อมูลเพิ่มเติมเกี่ยวกับวิธีการติดต่อฝ่ายสนับสนุนของ Microsoft แวะไปที่เว็บไซต์ต่อไปนี้ของ Microsoft:
    http://support.microsoft.com/contactus/?ws=support
  8. ถ้าไม่มีแฟ้ม.log ลองวิธีที่ 5

วิธีที่ 5: เปิดใช้งานการบันทึกข้อมูลการติดตั้ง Microsoft และจากนั้น ให้ติดต่อฝ่ายสนับสนุน

สิ่งสำคัญ ส่วน วิธีการ หรืองานนี้ประกอบด้วยขั้นตอนที่บอกให้คุณทราบวิธีการปรับเปลี่ยนรีจิสทรี อย่างไรก็ตาม ปัญหาร้ายแรงอาจเกิดขึ้นหากคุณปรับเปลี่ยนรีจิสทรีอย่างไม่ถูกต้อง ดังนั้น ให้แน่ใจว่า คุณทำตามขั้นตอนเหล่านี้อย่างระมัดระวัง สำหรับการป้องกันเพิ่มเติม สำรองรีจิสทรีก่อนที่คุณปรับเปลี่ยน จากนั้น คุณสามารถคืนค่ารีจิสทรีหากเกิดปัญหา สำหรับข้อมูลเพิ่มเติมเกี่ยวกับวิธีการสำรอง และคืนค่ารีจิสทรี คลิกหมายเลขบทความต่อไปนี้เพื่อดูบทความในฐานความรู้ของ Microsoft:
322756 วิธีการสำรอง และคืนค่ารีจิสทรีใน Windows
ถ้าวิธีการก่อนหน้านี้ไม่สามารถแก้ปัญหา คุณควรติดต่อฝ่ายสนับสนุนของ Microsoft สำหรับความช่วยเหลือ เมื่อต้องบันทึกเวลา คุณสามารถเปิดใช้งาน และสร้างแฟ้มบันทึกตัวติดตั้ง Microsoft ก่อนที่คุณติดต่อฝ่ายสนับสนุนของ Microsoft การเปิดใช้งานโปรแกรมติดตั้ง Microsoft บันทึก และสร้างแฟ้มบันทึก ให้ทำตามขั้นตอนเหล่านี้:
  1. คลิก เริ่มคลิก เรียกใช้ชนิด แผ่นจดบันทึกแล้ว คลิก ตกลง.
  2. พิมพ์คำสั่งต่อไปนี้ใน Notepad
    Windows Registry Editor Version 5.00
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\Installer]
    "Logging"=dword:voicewarmupx
    "Debug"=dword:00000007
    
  3. ในการ แฟ้ม คลิกที่เมนูใน Notepad บันทึกเป็น.
  4. เลือก เดสก์ท็อป ตัวเลือกจากนั้น บันทึกใน รายการ
  5. ในการ ชื่อแฟ้ม กล่อง ชนิด LoggingOn.regเลือก แฟ้มทั้งหมด ตัวเลือกในการ บันทึกเป็นชนิด รายการ และจากนั้น คลิก บันทึก.
  6. บนเดสก์ท็อป คลิกสองครั้ง LoggingOn.reg แฟ้มเมื่อต้องเพิ่มคีย์รีจิสทรี Windows รีจิสทรี
  7. เมื่อคุณเห็นกล่องโต้ตอบที่บ่งชี้ว่า การติดตั้งเสร็จเรียบร้อยแล้ว คลิก ตกลง.
  8. มีความพยายามที่ติดตั้งการปรับปรุงการจับภาพข้อมูลข้อผิดพลาดในแฟ้ม.log Microsoft Installer
หมายเหตุ อาจใช้เวลาหลายนาทีในการรวบรวมข้อมูลที่บันทึก และกระบวนการปรับปรุงอาจดูเหมือนการ ทำงานอย่างไม่ถูกต้อง ตรวจสอบให้แน่ใจว่า คุณรอสำหรับกระบวนการเสร็จสิ้นการ

สิ่งสำคัญ ทันทีที่ Windows Update หรือ Microsoft Update ได้เสร็จสิ้น การปิดใช้งานการบันทึกข้อมูลการติดตั้ง Microsoft ถ้ายังคงเปิดใช้งานการเข้าสู่ระบบ การติดตั้งโปรแกรมปรับปรุงอาจใช้เวลานาน และคอมพิวเตอร์ของ คุณอาจทำให้ช้าลง เข้าสู่ระบบแฟ้มที่ต้องใช้พื้นที่ดิสก์จำนวนมากอาจถูกสร้างขึ้น

เมื่อต้องการปิดใช้งานการบันทึกข้อมูลการติดตั้ง Microsoft ทำตามขั้นตอนเหล่านี้:
  1. คลิก เริ่มคลิก เรียกใช้ชนิด แผ่นจดบันทึกแล้ว คลิก ตกลง.
  2. พิมพ์คำสั่งต่อไปนี้ใน Notepad
    Windows Registry Editor Version 5.00
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\Installer]
    "Logging"=-
    "Debug"=-
    
  3. ในการ แฟ้ม คลิกที่เมนูใน Notepad บันทึกเป็น.
  4. ในการ บันทึกใน รายการ เลือก เดสก์ท็อป ตัวเลือก
  5. ชนิด LoggingOff.reg ในการ ชื่อแฟ้ม กล่อง เลือก แฟ้มทั้งหมด ตัวเลือกจากนั้น บันทึกเป็นชนิด รายการ และจากนั้น คลิก บันทึก.
  6. บนเดสก์ท็อป คลิกสองครั้ง LoggingOff.reg แฟ้มการเอาค่ารีจิสทรีออกจากรีจิสทรีของ Windows
  7. เมื่อคุณเห็นกล่องโต้ตอบที่บ่งชี้ว่า การติดตั้งเสร็จเรียบร้อยแล้ว คลิก ตกลง.
  8. ลบแฟ้ม LoggingOn.reg และ LoggingOff.reg จากเดสก์ท็อป
ติดต่อฝ่ายสนับสนุนของ Microsoft สำหรับความช่วยเหลือ และการอ้างอิงบทความฐานความรู้นี้แล้ว เมื่อคุณพูดกับตัวแทนฝ่ายสนับสนุน

ข้อมูลเพิ่มเติม

ในบันทึกของโปรแกรมติดตั้ง Microsoft โดยทั่วไปเริ่มต้น ด้วย "msi" และลงท้าย ด้วยนามสกุล ".log" ตัวอย่างเช่น Microsoft Installer ล็อกไฟล์มีชื่อที่คล้ายกับต่อไปนี้:
msib3a6g.log
แฟ้มนี้อยู่ในไดเรกทอรีดังต่อไปนี้:
C:\Documents และ Settings\ชื่อผู้ใช้\Local Settings\Temp\
เมื่อต้องเปิดไดเรกทอรีนี้ เริ่มคลิก เรียกใช้ชนิด % temp %แล้ว คลิก ตกลง.

หมายเหตุ ข้อมูลนี้ถือว่า มีการติดตั้ง Windows บนไดรฟ์ c ถ้า Windows ถูกติดตั้งบนไดรฟ์ C ปรับเปลี่ยนอักษรชื่อไดรฟ์สำหรับเส้นทางของโฟลเดอร์ให้ตรงกับไดรฟ์ของคุณติดตั้ง

ข้อมูลอ้างอิง

สำหรับข้อมูลเพิ่มเติมเกี่ยวกับวิธีการเปิดใช้งานการบันทึกข้อมูลการติดตั้ง Microsoft คลิกหมายเลขบทความต่อไปนี้เพื่อดูบทความในฐานความรู้ของ Microsoft:
314852วิธีการเปิดใช้งาน Windows Installer ที่เข้าสู่ระบบใน Windows XP

คุณสมบัติ

หมายเลขบทความ (Article ID): 958051 - รีวิวครั้งสุดท้าย: 31 ธันวาคม 2555 - Revision: 7.0
ใช้กับ
  • Microsoft Update
  • Microsoft Windows Update
  • Microsoft Windows XP Professional Edition
  • Microsoft Windows XP Home Edition
  • Microsoft Windows Server 2003 Enterprise Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
  • Microsoft Windows Server 2003 Datacenter Edition
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Datacenter Edition for Itanium-Based Systems
  • Microsoft Windows Server 2003 Standard Edition
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Server
Keywords: 
kbtshoot kbPubTypeKC kberrmsg kbprb kbmt KB958051 KbMtth
แปลโดยคอมพิวเตอร์
ข้อมูลสำคัญ: บทความนี้แปลโดยซอฟต์แวร์การแปลด้วยคอมพิวเตอร์ของ Microsoft แทนที่จะเป็นนักแปลที่เป็นบุคคล Microsoft มีบทความที่แปลโดยนักแปลและบทความที่แปลด้วยคอมพิวเตอร์ เพื่อให้คุณสามารถเข้าถึงบทความทั้งหมดในฐานความรู้ของเรา ในภาษาของคุณเอง อย่างไรก็ตาม บทความที่แปลด้วยคอมพิวเตอร์นั้นอาจมีข้อบกพร่อง โดยอาจมีข้อผิดพลาดในคำศัพท์ รูปแบบการใช้ภาษาและไวยากรณ์ เช่นเดียวกับกรณีที่ชาวต่างชาติพูดผิดเมื่อพูดภาษาของคุณ Microsoft ไม่มีส่วนรับผิดชอบต่อความคลาดเคลื่อน ความผิดพลาดหรือความเสียหายที่เกิดจากการแปลเนื้อหาผิดพลาด หรือการใช้บทแปลของลูกค้า และ Microsoft มีการปรับปรุงซอฟต์แวร์การแปลด้วยคอมพิวเตอร์อยู่เป็นประจำ
ต่อไปนี้เป็นฉบับภาษาอังกฤษของบทความนี้:958051

ให้ข้อเสนอแนะ

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com