Tras actualizar WMP, recibe un error de wmploc.dll que indica que el número de versión no es correcto

Seleccione idioma Seleccione idioma
Id. de artículo: 961047 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Origen: Soporte técnico de Microsoft

Action

Instala una revisión o actualización que actualiza wmp.dll.

Resultado

Recibe el error similar al siguiente:
El número de versión del archivo wmploc.dll es 11.0.6001.7000, pero debería ser 11.0.6001.7004.

El Reproductor de Windows Media no se instaló correctamente y debe volverse a instalar.

¿Desea instalar el Reproductor desde el sitio web de Microsoft?

Observe que los números de versión que aparecen pueden variar en función de la versión del Reproductor de Windows Media y de la revisión que instaló.

Causa

La versión del archivo wmp.dll no está sincronizada con las opciones configuradas en el Registro de Windows.

Solución

Para que podamos solucionar su problema, remítase a la sección "Solucionarlo en mi lugar". Si prefiere solucionar el problema usted mismo, vaya a la sección "Solucionarlo por mí mismo".

Solucionarlo en mi lugar

En los sistemas operativos Windows de 64 bits, esta solución de Fix it podrá corregir el problema solo si las versiones de 64 y de 32 bits del Reproductor de Windows Media están instaladas en la máquina. El comando "unregmp2.exe /UpdateWMPVersion" puede actualizar solo el valor de la clave del Registro HKLM\SOFTWARE\Microsoft\MediaPlayer\Setup\Installed Versions\wmp.dll, y no actualiza HKLM\SOFTWARE\Wow6432Node\Microsoft\MediaPlayer\Setup\Installed Versions\wmp.dll.

Para solucionar el problema de forma automática, haga clic en el vínculo Solucionar este problema. A continuación, haga clic en Ejecutar en el cuadro de diálogo Descarga de archivos y siga los pasos que le indica el asistente.

Solucionar este problema
Microsoft Fix it 50579


Nota: puede que este asistente esté sólo en inglés; sin embargo, esta corrección automática también funciona con otras versiones de idiomas de Windows.

Nota: si no está utilizando el equipo que tiene el problema, puede guardar la corrección automática en una unidad flash o en un CD para ejecutarla posteriormente en el equipo que tenga el problema.

Solucionarlo por mí mismo

En Windows Vista:
  1. Reinicie el sistema.
  2. Abra cmd.exe como administrador. Para ello, seleccione Inicio/Todos los programas/Accesorios.
  3. Haga clic con el botón secundario en Símbolo del sistema y elija Ejecutar como administrador.
  4. Escriba
    unregmp2.exe /UpdateWMPVersion
  5. Presione Entrar.

En Windows XP y Windows 2003 y versiones anteriores:
  1. Reinicie el sistema.
  2. Seleccione Inicio/Ejecutar y escriba:
    %SystemRoot%\inf\unregmp2.exe /UpdateWMP
  3. Haga clic en Aceptar.
Nota: es un artículo de "PUBLICACIÓN RÁPIDA" creado directamente por la organización de soporte técnico de Microsoft. La información aquí contenida se proporciona como está, como respuesta a problemas que han surgido. Como consecuencia de la rapidez con la que lo hemos puesto disponible, los materiales podrían incluir errores tipográficos y pueden ser revisados en cualquier momento sin previo aviso. Vea las Condiciones de uso para otras consideraciones

Propiedades

Id. de artículo: 961047 - Última revisión: domingo, 15 de mayo de 2011 - Versión: 2.0
La información de este artículo se refiere a:
  • Microsoft Windows Media Player 11
  • Microsoft Windows Media Player 10
Palabras clave: 
kbnomt kbrapidpub kbmsifixme kbfixme KB961047

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com