Error message when you use Windows Update Web site, Microsoft Update Web site, or Windows Server Update Services to install updates: 0x800704DD

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Source: Microsoft Support

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RAPID PUBLISHING ARTICLES PROVIDE INFORMATION DIRECTLY FROM WITHIN THE MICROSOFT SUPPORT ORGANIZATION. THE INFORMATION CONTAINED HEREIN IS CREATED IN RESPONSE TO EMERGING OR UNIQUE TOPICS, OR IS INTENDED SUPPLEMENT OTHER KNOWLEDGE BASE INFORMATION.

Symptom



When you try to download and install updates from the Microsoft Windows Update Web site, from the Microsoft Update Web site, or from a Windows Server Update Services (WSUS) server, you may receive the following error message:

0x800704DD

Cause



This problem occurs if the Automatic Updates service cannot impersonate the logged-on user to finish downloading and installing the update.

Resolution



To resolve this problem on a computer that is running Windows 2000, follow the steps in Section A.

To resolve this problem on a computer that is running Windows Server 2003 or Windows XP, follow the steps in Section B.

To resolve this problem on a computer that is running Windows Vista or Windows Server 2008, follow the steps in Section C.

 

Section A: Windows 2000

Step 1: Log on and run Microsoft Internet Explorer as a user who is a member of the local Administrators group

1.       Log on as a user who is a member of the local Administrators group.

2.       Right-click the Internet Explorer icon, click Run as, and then run the program as a user who is a member of the local Administrators group.

3.       Visit the Windows Update Web site, visit the Microsoft Update Web site, or connect to a WSUS server.

For more information on Administrator accounts, see the link in the “More Information” section.

Step 2: Verify that Client for Microsoft Networks is installed

1.       Click Start, click Run, type ncpa.cpl, and then click OK.

2.       Right-click the local area connection that is associated with the network adapter, and then click Properties.

3.       Verify that Client for Microsoft Networks appears in the This connection uses the following items box.

4.       Verify that the check box that appears next to Client for Microsoft Networks is selected. If Client for Microsoft Networks does not appear in the This connection uses the following items box, follow these steps:

a.        Click Install, click Client,and then click Add.

b.       Click Client for Microsoft Networks, click OK, and then click Yes.

Step 3: Verify that the System Event Notification Service and the Background Intelligent Transfer Service are started

Note The Background Intelligent Transfer Service (BITS) depends on the System Event Notification Service (SENS) in Windows 2000.

1.       Click Start, click Run, type services.msc, and then click OK.

2.       In the Name list, double-click System Event Notification.

3.       In the Startup type box, click Automatic.

4.       Click Start, wait for the service to start, and then click OK.

5.       Repeat steps 2 through 4 of this procedure for the Background Intelligent Transfer Service.

Step 4: Log on to the console session of Windows 2000 Server

Note This step applies to Windows 2000 Server only.

Note The Background Intelligent Transfer Service does not support Terminal Services sessions in Windows 2000. The Background Intelligent Transfer Service can submit the download job only by using computer credentials. If the firewall or proxy requires user-level authentication, the download job will fail.

1.       Log on locally to the computer. Do not use a Terminal Services session.

2.       Visit the Windows Update Web site, visit the Microsoft Update Web site, or connect to a WSUS server.

Step 5: Verify that the following registry entries are present

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:

 

322756 How to back up and restore the registry in Windows

1.       Click Start, click Run, type Regedit, and then click OK.

2.       Expand the following subkey:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon\Notify\SensLogn

3.       Verify that the following registry entries are present:
Collapse this tableExpand this table


Name


Data type


Data value


Asynchronous


DWORD


00000001


DLLName


String


WlNotify.dll


Impersonate


DWORD


00000001


Lock


String


SensLockEvent


Logoff


String


SensLogoffEvent


Logon


String


SensLogonEvent


MaxWait


DWORD


00000258


Safe


DWORD


00000001


Shutdown


String


SensShutdownEvent


StartScreenSaver


String


SensStartScreenSaverEvent


StartShell


String


SensStartShellEvent


Startup


String


SensStartupEvent


StopScreenSaver


String


SensStopScreenSaverEvent


Unlock


String


SensUnlockEvent


4.       Make any changes or additions that are required.

The following example shows how to change the value of the Shutdown registry entry:

a.        Right-click Shutdown, and then click Modify.

b.       In the Value data box, type SensShutdownEvent to overwrite the existing value, and then click OK.

The following example shows how to add a new registry entry:

a.        In the left pane, click SensLogn.

b.       Click Edit, point to New, and then click the value type that you want. For our example, click DWORD Value.

c.        Type Impersonate, and then press ENTER.

d.       Right-click Impersonate, and then click Modify.

e.       In the Value data box, type 1, and then click OK.

 

5.       Click Start, click Run, copy and paste or type the following command into the Open box, and then click OK:
Regsvr32 wlnotify.dll /s

6.       If you made any changes to the registry, restart the computer. Then, try again to download and install the update.

Section B: Windows Server 2003 and Windows XP

Step 1: Log on and run Internet Explorer as a user who is a member of the local Administrators group

1.       Log on as a user who is a member of the local Administrators group.

2.       Right-click the Internet Explorer icon, click Run as, and then run the program as a user who is a member of the local Administrators group.

3.       Visit the Windows Update Web site, visit the Microsoft Update Web site, or connect to a WSUS server.

For more information on Administrator accounts, see the link in the “More Information” section.

Step 2: Verify that the following registry entries are present

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:

 

322756 How to back up and restore the registry in Windows

1.       Click Start, click Run, type Regedit, and then click OK.

2.       Expand the following subkey:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon\Notify\SensLogn

3.       Verify that the following registry entries are present:
Collapse this tableExpand this table


Name


Data type


Data value


Asynchronous


DWORD


00000001


Disconnect


String


SensDisconnectEvent


DLLName


String


WlNotify.dll


Impersonate


DWORD


00000001


Lock


String


SensLockEvent


Logoff


String


SensLogoffEvent


Logon


String


SensLogonEvent


MaxWait


DWORD


00000258


PostShell


String


SensPostShellEvent


Reconnect


String


SensReconnectEvent


Safe


DWORD


00000001


Shutdown


String


SensShutdownEvent


StartScreenSaver


String


SensStartScreenSaverEvent


StartShell


String


SensStartShellEvent


Startup


String


SensStartupEvent


StopScreenSaver


String


SensStopScreenSaverEvent


Unlock


String


SensUnlockEvent


 

4.       Make any changes or additions that are required.

The following example shows how to change the value of the Shutdown registry entry:

a.        Right-click Shutdown, and then click Modify.

b.       In the Value data box, type SensShutdownEvent to overwrite the existing value, and then click OK.

The following example shows how to add a new registry entry:

a.        In the left pane, click SensLogn.

b.       Click Edit, point to New, and then click the value type that you want. For our example, click DWORD Value.

c.        Type Impersonate, and then press ENTER.

d.       Right-click Impersonate, and then click Modify.

e.       In the Value data box, type 1, and then click OK.

5.       If you made any changes to the registry, restart the computer. Then, try again to download and install the update.

Note The registry subkeys and values in the table in step 3 apply only to Windows Server 2003 and Windows XP. You cannot import these registry subkeys and values from a Windows Server 2003-based or a Windows XP-based computer to a Windows 2000-based computer.

 

 

 

 

 

 

Section C: Windows Vista and Windows Server 2008

Step 1: Log on to the computer as an Administrator or as a user with Administrative permissions

1.       Log on as a user who is a local administrator or is a member of the local Administrators group.

2.       Visit the Windows Update Web site or the Microsoft Update Web site and check for updates.

For more information on Administrator accounts, see the link in the “More Information” section.

Note: To check your current account type, follow the steps below:

1.       Click Start, and then click your user icon in the upper right corner of the Start menu.

2.       Click Manage User Accounts from the Make changes to your account section.

3.       Locate your currently logged on user name in the User Name section, If you are listed as being in the Administrators group, you are logged on with administrative permissions.

Step 2: Verify that the Background Intelligent Transfer Service and the System Event Notification Service are started

1.       Click Start, type services.msc in the Start Search text area, and then click services.msc from the programs list.  If you are prompted for an administrator password or for a confirmation, type the password, or click Continue.

2.       Double-click Background Intelligent Transfer Service.

3.       In the Service Status section, ensure that the service is listed as Started.

4.       If the status is listed as Stopped, click Start, and then click OK.

5.       Try to install updates again.



Step 3: Verify Name Resolution on the computer

1.       Close any Windows Update or Microsoft Update browser windows.

2.       Click Start, type command prompt, and then, in the list of results, right-click Command Prompt, and then click Run as Administrator.  If you are prompted for an administrator password or for a confirmation, type the password, or click Continue.

3.       In the Command window, type the following commands. Press ENTER after each command.

Nslookup

ns

your_computer_name

Note: The text “your_computer_name” should be replaced with the name of your computer. To find your computer name, click Start, right-click Computer, and click Properties. Your computer name is listed in the Computer name, domain, and workgroup settings section.

4.       After you type your computer name into the Command window and press ENTER, you should see your Domain Name Server (DNS) IP Address returned.

5.       Try to install updates again.

More Information



What is an administrator account?

For more information on Administrator accounts click the link below to view the content on the web site

What is an administrator account?

Workaround

To work around this problem, configure Automatic Updates to download and install updates. To do this, follow these steps.

Windows 2000

1. Click Start, point to Settings, and then click Control Panel.

2. Double-click Automatic Updates.

3. Click Automatically download the updates, and install them on the schedule that I specify.

4. Click to select the day and time that you want to download and install updates, and then click OK.

Windows XP

1. Click Start, and then click Control Panel.

2. Double-click Automatic Updates.

3. Click Automatic (recommended).

4. Click to select the day and time that you want to download and install updates, and then click OK.

Windows Server 2003

1. Click Start, and then click Control Panel.

2. Double-click Automatic Updates.

3. Click to select the following check box:

Keep my computer up to date. With this setting enabled, Windows Update software may be automatically updated prior to applying any other updates.

 

4. Click Automatically download the updates, and install them on the schedule that I specify.

5. Click to select the day and time that you want to download and install updates, and then click OK.

 

For more information about how to schedule Automatic Updates, click the following article number to view the article in the Microsoft Knowledge Base:

 

327838 How to schedule automatic updates in Windows Server 2003, in Windows XP, and in Windows 2000

Windows Vista and Windows Server 2008

1.       Click Start, click All Programs, and then click Windows Update.

2.       In the left pane, click Change settings.

3.       Click the automatic updating option that you want.

4.       To get important and recommended updates for your computer, under Recommended updates, select the Include recommended updates when downloading, installing, or notifying me about updates check box.

5.       Click OK. If you are prompted for an administrator password or confirmation, type the password or provide confirmation.

References

For more information, click the following article number to view the article in the Microsoft Knowledge Base:



902093 How to read the Windowsupdate.log file

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Properties

Article ID: 968001 - Last Review: December 23, 2013 - Revision: 2.0
Applies to
  • Microsoft Windows Update
Keywords: 
kbnomt kbrapidpub KB968001

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