Description of the security update for the Microsoft Visual C++ 2008 Redistributable Package (for previously installed versions): July 28, 2009

Article translations Article translations
Article ID: 973924 - View products that this article applies to.
Expand all | Collapse all

On This Page

INTRODUCTION

Microsoft has released security bulletin MS09-035. To view the complete security bulletin, visit one of the following Microsoft Web sites:

How to obtain help and support for this security update

Help installing updates: Support for Microsoft Update

Security solutions for IT professionals: TechNet Security Troubleshooting and Support

Help protect your computer that is running Windows from viruses and malware: Virus Solution and Security Center

Local support according to your country: International Support

More information about this security update

In addition to the product version that is specified in the "Applies to" section, this security update is only meant to be used with the following product:
  • Microsoft Visual C++ 2008 Service Pack 1 Redistributable Package
This security update cannot be applied to any other editions of Microsoft Visual Studio 2008 Service Pack 1.

Note The Microsoft Download Center update KB numbers for Visual C++ Redistributable packages differ from the SMS, SCCM, WSUS and MU update KB numbers. The full versions of the fixed Visual C++ 2005 and 2008 redistributable packages (KB973544, KB973551, and KB973552) are listed on the Microsoft Download Center only as these are full new versions of the products. The updates listed on SMS, SCCM, WSUS, and MU (KB973923, KB9739234) are updates only for customers who have previously installed vulnerable versions of the Visual C++ redistributable packages. These updates are not the versions on the download center. Microsoft does not recommend customers redistribute any version other than the full versions that can be downloaded from the Microsoft Download Center (KB973544, KB973551, and KB973552).

MORE INFORMATION

Prerequisites to install this security update

To install this security update, you must have at least Windows Installer 3.1 or a later version installed on the computer. To obtain the latest version of Windows Installer for the computer, visit the following Microsoft Web site:
http://www.microsoft.com/downloads/details.aspx?familyid=5A58B56F-60B6-4412-95B9-54D056D6F9F4&displaylang=en

Security update replacement information

This security update replaces the following security update: None.

Update removal information

To uninstall this update, use the Add or Remove Programs item in Control Panel.

Command-line switches for this update

For more information about the various command-line switches that this update supports, use the /? option after the name of the update package on the command line.

File information

The English (United States) version of this security update has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

x86
Collapse this tableExpand this table
File nameFile versionFile sizeDateTime
9.0.30729.4148.catNot applicable6,53712-Jul-200912:11
9.0.30729.4148.policyNot applicable76411-Jul-200919:38
atl90.dll9.0.30729.4148159,03212-Jul-20090:02
atl90.dll9.0.30729.4148159,03212-Jul-20090:02
x86_Microsoft.VC90.ATL_1fc8b3b9a1e18e3b_9.0.30729.4148_x-ww_353599c2.catNot applicable6,50112-Jul-200912:11
x86_Microsoft.VC90.ATL_1fc8b3b9a1e18e3b_9.0.30729.4148_x-ww_353599c2.manifestNot applicable85612-Jul-20090:08
AMD64
Collapse this tableExpand this table
File nameFile versionFile sizeDateTime
9.0.30729.4148.catNot applicable6,55012-Jul-20097:35
9.0.30729.4148.policyNot applicable76811-Jul-200919:46
amd64_Microsoft.VC90.ATL_1fc8b3b9a1e18e3b_9.0.30729.4148_x-ww_673f7fa2.catNot applicable6,50112-Jul-20097:35
amd64_Microsoft.VC90.ATL_1fc8b3b9a1e18e3b_9.0.30729.4148_x-ww_673f7fa2.manifestNot applicable85811-Jul-200922:17
atl90.dll9.0.30729.4148176,45611-Jul-200922:11
atl90.dll9.0.30729.4148176,45611-Jul-200922:11
IA-64
Collapse this tableExpand this table
File nameFile versionFile sizeDateTime
9.0.30729.4148.catNot applicable6,53712-Jul-200911:58
9.0.30729.4148.policyNot applicable76611-Jul-200921:00
atl90.dll9.0.30729.4148416,05612-Jul-20091:27
atl90.dll9.0.30729.4148416,05612-Jul-20091:27
ia64_Microsoft.VC90.ATL_1fc8b3b9a1e18e3b_9.0.30729.4148_x-ww_64908062.catNot applicable6,48812-Jul-200911:58
ia64_Microsoft.VC90.ATL_1fc8b3b9a1e18e3b_9.0.30729.4148_x-ww_64908062.manifestNot applicable85712-Jul-20091:33

Properties

Article ID: 973924 - Last Review: May 8, 2012 - Revision: 5.0
APPLIES TO
  • Microsoft Visual Studio 2008 Service Pack 1
Keywords: 
kbsurveynew kbfix kbbug kbsecvulnerability kbsecbulletin kbsecurity kbqfe kbexpertiseinter KB973924

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com