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Symptoms

For local printers

You upgrade from Windows Vista to Windows 7 on a computer that has the HP Full Feature Software solution or the HP Basic Driver solution installed. Then, you notice that your HP Multifunction Printer (MFP) does not work as expected. In particular, physical buttons on the front panel of Multifunction Printer stop responding. The device is recognized correctly and is displayed as installed. However, the HP software does not start and does not report that it cannot connect to the device. Therefore, you cannot print, scan or copy.

Note If the HP Full Feature Software solution or HP Basic Driver solution is not installed before the computer upgrades to Windows 7, basic printing and scanning functionality should be present. To obtain enhanced functionality from their MFP, users can install the HP Full Feature Software solution or HP Basic Driver solution after the computer upgrades to Windows 7.



On 64-bit Windows 7-based computers, the HP Digital Imaging monitor cannot start and the icon does not appear in the notification area. Additionally, when you try to start HP Solution Center, you receive the following error message:

Solution Center cannot be launched

No device found


To fix these issues, apply the update that is described in this article.

For networked printers

Shared printers and network printers experience the issues that are described for local printers. The issues occur when you connect printers to a local computer that has HP Solution Center installed and then you upgrade the computer to Windows 7.

  • If the HP MFP is physically connected to and shared from a computer that is not running Windows 7 and other computers are connected to that printer, only Windows 7 computers that upgrade from Vista and that have the HP Full Feature Software solution or HP Basic Driver solution installed before upgrading to Windows 7 are affected.

  • If the HP MFP is physically connected to and shared from a Windows 7 computer that upgrades from Windows Vista and that have the HP Full Feature Software solution or HP Basic Driver solution installed before upgrading to Windows 7, all computers that are connected to that shared printer are affected.

Networked printers may experience the following additional symptoms:

  • Printing works from applications, but no HP Solution Center functionality (for example, checking the ink status) can communicate with the printer.

  • Scanning does not work at all because it uses the special HP services for scanning.

To fix these issues, apply the update that is described in this article. Additionally, download and install the appropriate HP device software for Windows 7 from http://www.HP.com.

Cause

This issue occurs because required libraries are not migrated from Windows Vista to Windows 7. Without the required libraries, software cannot communicate with the multifunction device. Attempts to uninstall or reinstall the HP software do not resolve the issue.

Resolution

Windows Update

An update is available from the Windows Update Web site. This update replaces some missing files and registries on the user's computer to fix a broken printer scenario for HP. To obtain the update, follow these steps:

  1. Click Start start btton , click Control Panel, and then click System and Security.

  2. Under Windows Update, click Check for updates.


Note During the installation, the update does not create an entry in the Installed Updates section. This is to avoid unintentional uninstalls.

Important This is a Windows Update-only release from Microsoft. The stand-alone is available from HP.

Update from HP

HP has also made this update available on the HP Support website at the following link:

http://h10025.www1.hp.com/ewfrf/wc/softwareDownloadIndex?softwareitem=mp-77751-1&cc=us&dlc=en&lc=enFollow the instructions on that site to download and install the update.

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information

Uninstall the update

To uninstall the update, you have to run an uninstall command at a command prompt. To uninstall the update, follow these steps:

Note Uninstalling this update or restoring your system to an earlier date reverts to the issue described in the "Symptoms" section. To resolve the issue, the update has to be re-installed.

  1. Start an elevated command prompt. To do this, follow these steps:

    1. Click Start start btton , type cmd in the Start Search box, right-click cmd.exe in the Programs list, and then click Run as Administrator.

      Note If you are prompted for an administrator password or for confirmation, type the password or provide confirmation.

  2. Type the command that is associated with your operating system, and then press ENTER.

    • For 32-bit Windows operating systems, type the following and press ENTER:

      msiexec /uninstall {859D40CF-8491-44AD-8FA8-7389CB418C64}


    • For 64-bit Windows operating systems, type the following and press ENTER:

      msiexec /uninstall {9301985B-D116-4A93-A93D-94580084FF86}

  3. Exit the command prompt when the uninstallation is completed.

Note To see whether your computer is running a 32-bit or 64-bit version of Windows, follow these steps:

  1. Click Start start btton , click Control Panel, and then click System and Security.

  2. Under System, you can view the system type.

STILL NEED HELP?

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The information and the solution in this document represents the current view of Microsoft Corporation on these issues as of the date of publication. This solution is available through Microsoft or through a third-party provider. Microsoft does not specifically recommend any third-party provider or third-party solution that this article might describe. There might also be other third-party providers or third-party solutions that this article does not describe. Because Microsoft must respond to changing market conditions, this information should not be interpreted to be a commitment by Microsoft. Microsoft cannot guarantee or endorse the accuracy of any information or of any solution that is presented by Microsoft or by any mentioned third-party provider.

Microsoft makes no warranties and excludes all representations, warranties, and conditions whether express, implied, or statutory. These include but are not limited to representations, warranties, or conditions of title, non-infringement, satisfactory condition, merchantability, and fitness for a particular purpose, with regard to any service, solution, product, or any other materials or information. In no event will Microsoft be liable for any third-party solution that this article mentions.

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