RemoteApp applications are displayed as black windows when you restart the applications in a Remote desktop connection in Windows Server 2008 R2

Article translations Article translations
Article ID: 981156 - View products that this article applies to.
Expand all | Collapse all

On This Page

SYMPTOMS

Consider the following scenario:
  • You install the "Remote Desktop Session Host" role service on a computer that is running Windows Server 2008 R2.
  • You publish some RemoteApp applications on the server. Then, you create .rdp files for these applications.
  • You use an .rdp file to start a RemoteApp application through Remote Desktop Connection 7.0 over a slow network, such as a wireless area network (WAN) on a client computer.
  • On the client computer, you close the RemoteApp application. Then, you double-cick the .rdp file to restart the application.
In this scenario, these applications are displayed as black windows intermittently.

CAUSE

This issue is caused by the display driver of the Remote Desktop Session host service on the server computer. During the connection stage, the monitor layout packets for the client computer are dropped because the outgoing buffers are full. These buffers usually become full when the client computer uses a slow network or a WAN.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, your computer must be running Windows Server 2008 R2 or Windows Server 2008 R2 Service Pack 1 (SP1). Additionally, your computer must have the "Remote Desktop Session Host" role service installed.

For more information about how to obtain a Windows 7 or a Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.
    Collapse this tableExpand this table
    VersionProductSR_LevelService branch
    6.1.760 0 . 20xxxWindows Server 2008 R2RTMLDR
    6.1.760 1 . 21xxxWindows Server 2008 R2SP1LDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows Server 2008 R2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Pci.sys6.1.7600.20671183,68818-Mar-201018:37x64
Termdd.sys6.1.7600.2067162,34418-Mar-201018:37x64
Volmgr.sys6.1.7600.2067172,07218-Mar-201018:37x64
Rdpwd.sys6.1.7600.20671205,82418-Mar-201007:08x64
Rdpdd.dll6.1.7600.20671194,56018-Mar-201007:09x64
Pci.sys6.1.7601.21772185,21616-Jul-201105:34x64
Termdd.sys6.1.7601.2177263,36016-Jul-201105:34x64
Volmgr.sys6.1.7601.2177270,52816-Jul-201105:34x64
Rdpwd.sys6.1.7601.21772210,94416-Jul-201103:45x64
For all supported IA-64-based versions of Windows Server 2008 R2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Pci.sys6.1.7600.20671454,53618-Mar-201018:14IA-64
Termdd.sys6.1.7600.20671160,14418-Mar-201018:14IA-64
Volmgr.sys6.1.7600.20671160,65618-Mar-201018:14IA-64
Rdpwd.sys6.1.7600.20671489,98418-Mar-201006:45IA-64
Rdpdd.dll6.1.7600.20671434,17618-Mar-201006:45IA-64
Pci.sys6.1.7601.21772458,11216-Jul-201104:21IA-64
Termdd.sys6.1.7601.21772162,68816-Jul-201104:21IA-64
Volmgr.sys6.1.7601.21772164,22416-Jul-201104:21IA-64
Rdpwd.sys6.1.7601.21772503,80816-Jul-201103:01IA-64

WORKAROUND

Workaround for Windows Server 2008 R2

To work around the issue, configure the following policy to force the Remote Desktop Session host service to stop disconnected RDC sessions after an specific amount of time.
Location: Computer Configuration\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Session Time Limits
Policies: Set time limit for disconnected sessions

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
969084 Description of the Remote Desktop Connection 7.0 client update for Remote Desktop Services (RDS)

Additional file information

Additional file information for Windows Server 2008 R2

Additional files for all supported x64-based versions of Windows Server 2008 R2
Collapse this tableExpand this table
File nameAmd64_0c8b59ec3818fc45efeb0c2254ba94c5_31bf3856ad364e35_6.1.7600.20671_none_433b841a2bf8a8f0.manifest
File versionNot applicable
File size1,097
Date (UTC)18-Mar-2010
Time (UTC)23:53
PlatformNot applicable
File nameAmd64_machine.inf_31bf3856ad364e35_6.1.7600.20671_none_16984e3df17af8ec.manifest
File versionNot applicable
File size7,894
Date (UTC)19-Mar-2010
Time (UTC)00:01
PlatformNot applicable
File nameAmd64_microsoft-windows-t..dp-winstationdriver_31bf3856ad364e35_6.1.7600.20671_none_a7fae94a07cca7cc.manifest
File versionNot applicable
File size3,435
Date (UTC)18-Mar-2010
Time (UTC)20:14
PlatformNot applicable
File nameAmd64_microsoft-windows-t..s-rdp-displaydriver_31bf3856ad364e35_6.1.7600.20671_none_411135f587c3101e.manifest
File versionNot applicable
File size2,816
Date (UTC)18-Mar-2010
Time (UTC)20:19
PlatformNot applicable
File nameUpdate.mum
File versionNot applicable
File size1,893
Date (UTC)18-Mar-2010
Time (UTC)23:53
PlatformNot applicable
File nameAmd64_b4144182f9eab3e4cef35185fcda3c15_31bf3856ad364e35_6.1.7601.21772_none_d9261853433f9f24.manifest
File versionNot Applicable
File size729
Date (UTC)16-Jul-2011
Time (UTC)09:54
PlatformNot Applicable
File nameAmd64_machine.inf_31bf3856ad364e35_6.1.7601.21772_none_187fb13feea075a4.manifest
File versionNot Applicable
File size7,894
Date (UTC)16-Jul-2011
Time (UTC)10:01
PlatformNot Applicable
File nameAmd64_microsoft-windows-t..dp-winstationdriver_31bf3856ad364e35_6.1.7601.21772_none_a9e24c4c04f22484.manifest
File versionNot Applicable
File size3,807
Date (UTC)16-Jul-2011
Time (UTC)06:12
PlatformNot Applicable
File nameUpdate.mum
File versionNot Applicable
File size2,525
Date (UTC)16-Jul-2011
Time (UTC)09:54
PlatformNot Applicable
Additional files for all supported IA-64-based versions of Windows Server 2008 R2
Collapse this tableExpand this table
File nameIa64_2ad189c66849adb9fec0190aef9aff93_31bf3856ad364e35_6.1.7600.20671_none_e38b5f5402ab4db4.manifest
File versionNot applicable
File size1,094
Date (UTC)18-Mar-2010
Time (UTC)23:53
PlatformNot applicable
File nameIa64_machine.inf_31bf3856ad364e35_6.1.7600.20671_none_ba7b56b0391b90b2.manifest
File versionNot applicable
File size6,844
Date (UTC)18-Mar-2010
Time (UTC)23:53
PlatformNot applicable
File nameIa64_microsoft-windows-t..dp-winstationdriver_31bf3856ad364e35_6.1.7600.20671_none_4bddf1bc4f6d3f92.manifest
File versionNot applicable
File size3,434
Date (UTC)18-Mar-2010
Time (UTC)20:14
PlatformNot applicable
File nameIa64_microsoft-windows-t..s-rdp-displaydriver_31bf3856ad364e35_6.1.7600.20671_none_e4f43e67cf63a7e4.manifest
File versionNot applicable
File size2,815
Date (UTC)18-Mar-2010
Time (UTC)20:18
PlatformNot applicable
File nameUpdate.mum
File versionNot applicable
File size1,887
Date (UTC)18-Mar-2010
Time (UTC)23:53
PlatformNot applicable
File nameIa64_0ec1e64bb56876f78222483f8bf5059f_31bf3856ad364e35_6.1.7601.21772_none_8dc1404f6c0f3c70.manifest
File versionNot Applicable
File size727
Date (UTC)16-Jul-2011
Time (UTC)09:54
PlatformNot Applicable
File nameIa64_machine.inf_31bf3856ad364e35_6.1.7601.21772_none_bc62b9b236410d6a.manifest
File versionNot Applicable
File size6,844
Date (UTC)16-Jul-2011
Time (UTC)09:54
PlatformNot Applicable
File nameIa64_microsoft-windows-t..dp-winstationdriver_31bf3856ad364e35_6.1.7601.21772_none_4dc554be4c92bc4a.manifest
File versionNot Applicable
File size3,805
Date (UTC)16-Jul-2011
Time (UTC)06:11
PlatformNot Applicable
File nameUpdate.mum
File versionNot Applicable
File size1,644
Date (UTC)16-Jul-2011
Time (UTC)09:54
PlatformNot Applicable

Properties

Article ID: 981156 - Last Review: August 10, 2011 - Revision: 3.0
APPLIES TO
  • Windows Server 2008 R2 Datacenter
  • Windows Server 2008 R2 Enterprise
  • Windows Server 2008 R2 for Itanium-Based Systems
  • Windows Server 2008 R2 Standard
Keywords: 
kbfix kbautohotfix kbhotfixserver kbsurveynew kbqfe kbexpertiseadvanced KB981156

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com