لوحة المعلومات هي تمثيل مرئي للمقاييس الأساسية التي تسمح لك بعرض بياناتك وتحليلها بسرعة في مكان واحد. لا توفر لوحات المعلومات طرق عرض بيانات مدمجة فحسب، بل توفر أيضا فرصة للذكاء المهني ذاتية الإعداد، حيث يستطيع المستخدمون تصفية البيانات لعرض ما هو مهم بالنسبة لهم فقط. في الماضي، غالبا ما كانت إعدادات Excel تتطلب منك إنشاء تقارير متعددة لأشخاص مختلفين أو أقسام مختلفة وفقا لاحتياجاتهم.
في هذا الموضوع، سنناقش كيفية استخدام جداول PivotTable ومخططات PivotChart وأدوات PivotTable متعددة لإنشاء لوحة معلومات ديناميكية. بعد ذلك، سنمنح المستخدمين القدرة على تصفية البيانات بالطريقة التي يريدونها بسرعة باستخدام مقسمات طرق العرض والمخطط الزمني، مما يسمح لجداول PivotTable والمخططات بالتوسع والتقليص لعرض المعلومات التي يريد المستخدمون رؤيتها فقط. بالإضافة إلى ذلك، يمكنك تحديث لوحة المعلومات بسرعة عند إضافة بيانات أو تحديثها. يسهل ذلك الأمر لأنك لن تحتاج إلا إلى إنشاء تقرير لوحة المعلومات مرة واحدة فقط.
في هذا المثال، سنقوم بإنشاء أربعة جداول PivotTable ومخططات من مصدر بيانات واحد.
بمجرد إنشاء لوحة المعلومات الخاصة بك، سنوضح لك كيفية مشاركتها مع الأشخاص عن طريق إنشاء مجموعة Microsoft. يتوفر لدينا أيضا مصنف Excel تفاعلي يمكنك تنزيله واتباع هذه الخطوات بنفسك.
قم بتنزيل مصنف البرنامج التعليمي حول لوحة معلومات Excel.
الحصول على بياناتك
يمكنك نسخ البيانات ولصقها مباشرة في Excel، أو يمكنك إعداد استعلام من مصدر بيانات. لهذا الموضوع، استخدمنا استعلام تحليل المبيعات من قالب Northwind Traders في Microsoft Access. إذا كنت تريد استخدامه، يمكنك فتح Access والانتقال إلى ملف>بحث جديد> وفي البحث، أدخل "Northwind" وقم بإنشاء قاعدة بيانات القالب. بمجرد الانتهاء من ذلك، ستتمكن من الوصول إلى أي من الاستعلامات المضمنة في القالب. لقد وضعنا هذه البيانات مسبقا في مصنف Excel من أجلك، لذلك لا داعي للقلق إذا لم يكن لديك Access.
تأكد من أن البيانات منظمة بشكل صحيح من دون فقدان صفوف أو أعمدة. يجب أن يمثل كل صف سجلا أو عنصرا فرديا. للحصول على المساعدة في إعداد استعلام أو إذا كانت البيانات تحتاج إلى معالجة، اطلع على Get & Transform in Excel.
إذا لم يكن الأمر كذلك بالفعل، فقم بتنسيق البيانات كجدول Excel. عند الاستيراد من Access، سيتم استيراد البيانات تلقائيا إلى أحد الجداول.
إنشاء جداول PivotTable
حدد أي خلية في نطاق البيانات، وانتقل إلى إدراج> ورقةعمل PivotTable>جديدة. راجع إنشاء PivotTable لتحليل بيانات ورقة العمل للحصول على مزيد من التفاصيل.
أضف حقول PivotTable التي تريدها، ثم نسق كما تريد. سيكون PivotTable هذا أساسا للجداول الأخرى، لذلك يجب أن تمضي بعض الوقت في إجراء أي تعديلات ضرورية على النمط وتخطيط التقرير والتنسيق العام الآن، حتى لا تضطر إلى القيام بذلك عدة مرات. لمزيد من التفاصيل، راجع: تصميم تخطيط PivotTable وتنسيقه.
في هذه الحالة، قمنا بإنشاء ملخص من المستوى الأعلى للمبيعات حسب فئة المنتج، وتم فرزها حسب حقل "المبيعات" بترتيب تنازلي.
راجع فرز البيانات في PivotTable أو PivotChart للحصول على مزيد من التفاصيل.
بعد إنشاء PivotTable الرئيسي، حدده، ثم انسخه والصقه عدة مرات حسب الحاجة للمناطق الفارغة في ورقة العمل. على سبيل المثال، بإمكان جداول PivotTable هذه تغيير الصفوف، وليس الأعمدة، لذا وضعناها في الصف نفسه مع وجود عمود فارغ بينها. ومع ذلك، قد يتبين لك أنك تحتاج إلى وضع جداول PivotTable أسفل بعضها البعض إذا كان بوسعها الأعمدة.
هام
لا يمكن أن تتراكب جداول PivotTables مع بعضها البعض، لذا تأكد من أن التصميم سيتيح مساحة كافية بينها للسماح لها بالتوسع والتقليص عند تصفية القيم أو إضافتها أو إزالتها.
في هذه المرحلة، قد ترغب في تسمية جداول PivotTable بأسماء ذات معنى، حتى تعرف ما تقوم به. وإلا، فسيقوم Excel بتسميتهم PivotTable1 وPivotTable2 وغير ذلك. يمكنك تحديد كل واحد، ثم الانتقال إلى تحليل PivotTable> ثم إدخال اسم جديد في المربع اسم PivotTable. سيكون هذا مهما عندما يحين وقت توصيل PivotTables بمقسمات طرق العرض وعناصر تحكم الخط الزمني.
إنشاء مخططات PivotChart
انقر فوق أي مكان في PivotTable الأول، وانتقل إلى PivotTable،أدوات>التحليل>،PivotChart، ثم حدد نوع مخطط. لقد اخترنا مخطط تحرير وسرد مع المبيعات كمخطط عمودي متفاوت المسافات ، و ٪ الإجمالي كمخطط خطي مرسوم على المحور الثانوي.
حدد المخطط، ثم حدد الحجم والتنسيق كما هو مطلوب من علامات التبويب "تحليل" و"تصميم" و"تنسيق" في PivotChart. لمزيد من التفاصيل، راجع السلسلة الخاصة بنا حول تنسيق المخططات.
كرر هذه العملية لكل من جداول PivotTable المتبقية.
الآن هو الوقت المناسب لإعادة تسمية مخططات PivotChart أيضا. انتقل إلى PivotChart، تحليل>، PivotChart ، ثم أدخل اسما جديدا في المربع "اسم المخطط ".
إضافة مقسمات طرق العرض والمخطط الزمني
تتيح لك مقسمات طرق العرض والمخططات الزمنية تصفية جداول PivotTable ومخططات PivotChart بسرعة حتى تتمكن من رؤية المعلومات المفيدة بالنسبة لك فقط.
حدد أي PivotTable وانتقل إلى "تحليل>عامل تصفية> PivotTable" إدراج مقسم طريقة عرض، ثم حدد كل عنصر تريد استخدامه لمقسم طريقة العرض. بالنسبة للوحة المعلومات هذه، نحدد الفئةواسم المنتجوالموظفواسم العميل. عند النقر فوق موافق، ستتم إضافة مقسمات طرق العرض إلى وسط الشاشة بحيث تكون مكدسة فوق بعضها البعض، وبذلك ستحتاج إلى ترتيبها وتغيير حجمها كما تقتضي الحاجة.
خيارات مقسم طريقة العرض: إذا نقرت فوق أي مقسم طريقة عرض، يمكنك الانتقال إلى علامة التبويب " مقسم طريقة العرض " وتحديد خيارات متنوعة، مثل النمط وعدد الأعمدة التي يتم عرضها. يمكنك محاذاة مقسمات طرق عرض متعددة عن طريق تحديدها باستخدام Ctrl+النقر بزر الماوس الأيسر، ثم استخدم أدوات "محاذاة " على علامة التبويب "أدوات مقسم طريقة العرض ".
اتصالات مقسم طريقة العرض: ستكون مقسمات طرق العرض متصلة فقط بجدول PivotTable الذي استخدمته لإنشائها، وبالتالي ستحتاج إلى تحديد كل مقسم طريقة عرض، ثم الانتقال إلى "اتصالاتتقريرمقسم>طريقة العرض>" والتحقق من جداول PivotTables التي تريد توصيلها بكل منها. بإمكان مقسمات طرق العرض والمخططات الزمنية التحكم في PivotTables بأي ورقة عمل، حتى لو كانت ورقة العمل مخفية.
إضافة مخطط زمني: حدد أي PivotTable وانتقل إلى "تحليل>عامل تصفية> PivotTable" وإدراج "مخطط زمني"، ثم حدد كل عنصر تريد استخدامه. بالنسبة للوحة المعلومات هذه، حددنا "تاريخ الطلب".
خيارات المخطط الزمني: انقر فوق المخطط الزمني وانتقل إلى علامة التبويب المخطط الزمني وحدد خيارات مثل النمطوالرأسوالتسمية التوضيحية. حدد الخيار Report Connections (اتصالات التقرير ) لربط المخطط الزمني بجداول PivotTables التي تختارها.
تعرف على المزيد حول مقسمات طرق العرض وعناصر التحكم في الخط الزمني .
الخطوات التالية
لقد اكتملت لوحة المعلومات الآن من الناحية الوظيفية، ولكنك قد لا تزال بحاجة إلى ترتيبها لتكون بالشكل الذي تريده وإجراء التعديلات النهائية. على سبيل المثال، قد ترغب في إضافة عنوان تقرير أو خلفية. أضفنا أشكالا حول PivotTables في لوحة المعلومات الخاصة بنا وأوقفنا تشغيل العناوينوخطوط الشبكة من علامة التبويب عرض .
تأكد من اختبار كل من مقسمات طرق العرض والمخططات الزمنية للتأكد من أن جداول PivotTable ومخططات PivotChart تعمل بالطريقة التي تريدها. قد تجد حالات حيث تتسبب تحديدات معينة في حدوث مشاكل إذا أراد PivotTable واحد الضبط والتداخل مع جدول آخر، الأمر الذي يتعذر عليه القيام به وسيعرض رسالة خطأ. يجب تصحيح هذه المشاكل قبل توزيع لوحة المعلومات الخاصة بك.
عند الانتهاء من إعداد لوحة المعلومات، يمكنك النقر فوق علامة التبويب "مشاركة" لوحة المعلومات في أعلى هذا الموضوع للتعرف على كيفية توزيعها.
اطلع أيضاً على
هل لديك أي أسئلة لم نجب عنها هنا؟
تفضل بزيارة مجتمع Microsoft Answers.