الملخص

Microsoft Project حساب فهرس أداء الجدولة (SPI) أو فهرس أداء التكلفة (CPI). تحتوي هذه المقالة على ماكرو عينة يحسب SPI و CPI لكل مهمة في مشروع.

ملاحظة: SPI هو نسبة العمل الذي يتم القيام به للعمل المجدول (BCWP/BCWS). CPI هي نسبة التكاليف في الموازنة إلى التكاليف الفعلية (BCWP/ACWP).

المزيد من المعلومات

ملاحظةتوفر Microsoft أمثلة برمجية للتوضيح فقط، بدون ضمان سواء تم التعبير عنه أو ضمنيا. يشمل ذلك، على سبيل المثال لا يقتصر على، الضمانات الضمنية ل قابلية الاستخدام أو اللياقة لغرض معين. تفترض هذه المقالة أنك على دراية بلغة البرمجة التي يتم إظهارها والأدوات المستخدمة لإنشاء إجراءات تصحيح الأخطاء وتصحيحها. يمكن لمهندسي دعم Microsoft المساعدة في شرح وظائف إجراء معين، ولكن لن يتم تعديل هذه الأمثلة لتوفير وظائف إضافية أو إجراءات إنشاء لتلبية متطلباتك المحددة. 


يحسب الماكرو التالي فهرس أداء الجدولة (SPI) وفهرس أداء التكلفة (CPI) لكل مهمة ويضع النتائج في الحقول رقمية. يساوي SPI لكل مهمة BCWP/BCWS. تكون CPI لكل مهمة مساوية ل BCWP/ACWP.

لإنشاء هذا الماكرو، اتبع الخطوات التالية:

  1. من القائمة أدوات، أشر إلى ماكرو، ثم انقر فوق وحدات ماكرو. بالنسبة Project 2010، انتقل إلى علامة التبويب عرض وانقر فوق الزر وحدات الماكرو.

  2. في الحقل اسم الماكرو، اكتب "CalcSPI_CPI"، ثم انقر فوق إنشاء لفتح Visual Basic المحرر.

  3. أنشئ الماكرو بكتابة ماكرو الفرعي التالي.


    Sub CalcSPI_CPI() Dim t As Task
    لكل t في ActiveProject.Tasks
      إذا لم يكن t لا شيء بعد ذلك
        إذا كانت t.BCWS <> 0 ثم
            t.Number10 = t.BCWP / t.BCWS 'هذا يحسب SPI
        End If
        إذا كانت t.ACWP <> 0 ثم
            t.Number11 = t.BCWP / t.ACWP 'يقوم هذا بحساب CPI
        End If
      End If
    t التالي
    End Sub

    NOTE: يستخدم هذا المثال الحقلين Number10 و Number11. يمكنك استخدام أي من الحقول الأخرى المتوفرة رقمية وأبجدية رقمية. قد تحتاج أيضا إلى استخدام Formatfunction لتنسيق النتائج.

  4. في Visual Basic المحرر، في القائمة ملف، انقر فوق إغلاق والعودة إلى Microsoft Project.

  5. في Microsoft Project، في القائمة أدوات، قم ب الإشارة إلى ماكرو، ثم انقر فوق وحدات الماكرو. بالنسبة Project 2010، انتقل إلى علامة التبويب عرض وانقر فوق الزر وحدات الماكرو.

  6. في قائمة وحدات الماكرو، انقرفوق CalcSPI_CPI . انقر فوق تشغيل.

لعرض نتائج الماكرو، أدرج الحقلين Number10 و Number11 في جدول مهمة. اتبع هذه الخطوات للقيام بذلك:

  1. في القائمة إدراج، انقر فوق عمود.

    بالنسبة Project 2010، انتقل إلى علامة التبويب تنسيق وانقر فوق الزر إدراج عمود.

  2. في القائمة اسم الحقل، انقر فوق رقم10.

  3. انقر فوق موافق.

  4. كرر الخطوات من 1 إلى 3 في الحقل Number11.

هل تحتاج إلى مزيد من المساعدة؟

توسيع المهارات
استكشاف التدريب
الحصول على الميزات الجديدة أولاً
الانضمام إلى Microsoft Insider

هل كانت المعلومات مفيدة؟

ما مدى رضاك عن جودة الترجمة؟
ما الذي أثّر في تجربتك؟

نشكرك على ملاحظاتك!

×