Datová makra v Accessu umožňují dodat logiku událostem, ke kterým dochází v tabulkách, třeba přidávání, aktualizaci nebo odstraňování dat. Podobají se "aktivačním událostem" v Microsoft SQL Server. Tento článek vysvětluje, jak vytvořit a ladit datová makra.
V tomto článku
- O datových makrech
- Vytvoření datového makra řízeného událostí
- Vytvoření pojmenovaného datového makra
- Správa datových maker
- Ladění datových maker
O datových makrech
Datová makra se spravují z karty Tabulka při prohlížení tabulky v zobrazení Datový list a nezobrazují se v části Makra v navigačním podokně. Datová makra můžete mimo jiné použít k ověření a zajištění přesnosti dat v tabulce. Existují dva hlavní typy datových maker – ta, která se aktivují událostmi tabulky (označují se také jako datová makra řízená událostmi), a ta, která se spouštějí v reakci na vyvolání jménem (taky známá jako "pojmenovaná" datová makra).
Vytvoření datového makra řízeného událostí
Události tabulky nastanou při každém přidání, aktualizaci nebo odstranění dat v tabulce. Datové makro můžete naprogramovat tak, aby se spustilo bezprostředně po kterékoli z těchto tří událostí nebo bezprostředně před událostí odstranění nebo změny. Pomocí následujícího postupu připojte datové makro k události tabulky:
V navigačním podokně poklikejte na tabulku, do které chcete přidat datové makro.
Na kartě Tabulka ve skupině Před událostmi nebo Po události klikněte na událost, ke které chcete přidat makro. Pokud třeba chcete vytvořit datové makro, které se spustí po odstranění záznamu z tabulky, klikněte na Po odstranění.
Poznámka
Pokud už událost obsahuje makro, zobrazí se její ikona zvýrazněná na pásu karet.
Access otevře Tvůrce maker. Pokud bylo pro tuto událost dříve vytvořeno makro, zobrazí aplikace Access existující makro.
Přidejte akce, které má makro provést.
Uložte a zavřete makro.
Další informace o vytváření maker najdete v článku Vytvoření makra uživatelského rozhraní.
Vytvoření pojmenovaného datového makra
Pojmenované nebo samostatné datové makro je přidružené ke konkrétní tabulce, ale ne ke konkrétní události. Pojmenovaná datová makra můžete volat z jakéhokoliv jiného datového makra nebo standardního makra.
- V navigačním podokně poklikejte na tabulku, do které chcete přidat datové makro.
- Na kartě Tabulka klikněte ve skupině Pojmenovaná makra na Pojmenované makro a potom klikněte na Vytvořit pojmenované makro.
Access otevře Tvůrce maker, kde můžete začít přidávat akce.
Další informace o vytváření maker najdete v článku Vytvoření makra uživatelského rozhraní.
O parametrech
Parametry umožňují předávat hodnoty do pojmenovaného datového makra, aby je bylo možné použít v podmíněných příkazech nebo jiných výpočtech. Umožňují také předávat odkazy na objekty ze standardních maker do datového makra.
Poznámka
Parametry nejsou k dispozici v datových makrech řízených událostmi.
Přidání parametru do datového makra:
- V horní části makra klikněte na Vytvořit parametr.
- Do pole Název zadejte jedinečný název parametru. Toto je název, který používáte k odkazování na parametr ve výrazech.
- Volitelně zadejte popis parametru do pole Popis . Doporučujeme zadat popis, protože později se při použití tohoto parametru popisný text, který zde zadáte, zobrazí jako popisek. To vám pomůže vzpomenout si na účel parametru.
Ke spuštění pojmenovaného datového makra z jiného makra použijte akci SpustitDataMakro . Akce vytvoří pole pro každý parametr, který jste vytvořili, takže můžete zadat potřebné hodnoty.
Správa datových maker
Datová makra se nezobrazují v navigačním podokně v části Makra. Pokud chcete vytvářet, upravovat, přejmenovávat a odstraňovat datová makra, musíte použít příkazy na pásu karet v zobrazení Datový list tabulky nebo v návrhovém zobrazení tabulky.
Úprava datového makra řízeného událostí
V navigačním podokně poklikejte na tabulku obsahující datové makro, které chcete upravit.
Na kartě Tabulka ve skupině Před událostmi nebo Po události klikněte na událost makra, které chcete upravit. Když třeba chcete upravit datové makro, které se spustí po odstranění záznamu z tabulky, klikněte na tlačítko Po odstranění.
Poznámka
Pokud k události není přidružené makro, její ikona se v nabídce nezvýrazní.
Access otevře Tvůrce maker a můžete začít makro upravovat.
Úprava pojmenovaného datového makra
- V navigačním podokně poklikejte na libovolnou tabulku, kterou chcete otevřít v zobrazení Datový list.
- Na kartě Tabulka ve skupině Pojmenovaná makra klikněte na Pojmenované makro a pak přejděte myší na Upravit pojmenované makro.
- V podnabídce klikněte na datové makro, které chcete upravit.
Access otevře Tvůrce maker a můžete začít makro upravovat.
Přejmenování pojmenovaného datového makra
- V navigačním podokně poklikejte na libovolnou tabulku, kterou chcete otevřít v zobrazení Datový list.
- Na kartě Tabulka klikněte ve skupině Pojmenovaná makra na Pojmenované makro a potom klikněte na Přejmenovat nebo odstranit makro.
- V dialogovém okně Správce datových maker klikněte na tlačítko Přejmenovat vedle datového makra, které chcete přejmenovat.
Access vybere aktuální název makra. - Zadejte nový název nebo upravte existující název a stiskněte klávesu ENTER.
Odstranění datového makra
Pokud chcete odstranit všechna pojmenovaná nebo událostmi řízená datová makra, postupujte takto:
- V navigačním podokně poklikejte na libovolnou tabulku, kterou chcete otevřít v zobrazení Datový list.
- Na kartě Tabulka klikněte ve skupině Pojmenovaná makra na Pojmenované makro a potom klikněte na Přejmenovat nebo odstranit makro.
- V dialogovém okně Správce datových maker klikněte na tlačítko Delete u datového makra, které chcete přejmenovat.
Poznámka
Makro řízené událostmi můžete také odstranit odstraněním všech jeho akcí.
Ladění datových maker
Pro datová makra nejsou dostupné některé běžné nástroje pro ladění maker, například příkaz Krokovat nebo akce makra Pole zprávy. Pokud ale máte s datovým makrem potíže, můžete použít tabulku Protokol aplikace v kombinaci s akcemi maker PřiChybě, VyvolatChybu a ProtokolUdálost, které vám pomůžou najít chyby datových maker.
Zobrazení tabulky aplikačního protokolu
Tabulka protokolu aplikací je systémová tabulka (pojmenovaná USysApplicationLog), která se ve výchozím nastavení v navigačním podokně nezobrazuje. Pokud se v datovém makru vyskytne chyba, můžete z informací v tabulce aplikačního protokolu zjistit, co se stalo.
Tabulku aplikačního protokolu zobrazíte následujícím postupem:
Kliknutím na Soubor otevřete zobrazení Microsoft Backstage.
Na kartě Informace klikněte na Zobrazit tabulku aplikačních protokolů.
Poznámka
Pokud tlačítko Zobrazit tabulku protokolu aplikací nevidíte, znamená to, že pro tuto databázi ještě nebyla vytvořena tabulka protokolu aplikace. Po zaprotokolování události se tlačítko zobrazí na kartě Informace .
Pomocí akce PřiChybě můžete vytvořit řádky v tabulce aplikačního protokolu pomocí akce LogEvent nebo akce RaiseError a pomocí akce PřiChybě můžete ovládat, jakým způsobem bude Access reagovat na chyby.