K načtení dat z externích zdrojů můžete použít Microsoft Query. Když použijete Microsoft Query k načtení dat z podnikových databází a souborů, nemusíte znovu zadít data, která chcete analyzovat v Excel. Sestavy a souhrny můžete Excel automaticky aktualizovat z původní zdrojové databáze při každé aktualizaci databáze novými informacemi.

V Microsoft Query se můžete připojit k externím zdrojům dat, vybrat data z těchto externích zdrojů, importovat tato data do listu a podle potřeby aktualizovat data, aby se data na listu synchronizovala s daty v externích zdrojích.

Typy databází, ke které máte přístup     Data můžete načíst z několika typů databází, včetně Microsoft Office Accessu, Microsoft SQL Server a Microsoft SQL Server OLAP Services. Můžete také načíst data z Excel sešitů a z textových souborů.

Microsoft Office poskytuje ovladače, které můžete použít k načtení dat z následujících zdrojů dat:

  • Microsoft SQL Server Analysis Services (Zprostředkovatel OLAP )

  • Microsoft Office Access

  • dBASE

  • Microsoft FoxPro

  • Microsoft Office Excel

  • Oracle

  • Paradox

  • Databáze textových souborů

Pomocí ovladačů ODBC nebo ovladačů zdrojů dat od jiných výrobců můžete načíst informace ze zdrojů dat, které tady nejsou uvedené, včetně jiných typů databází OLAP. Informace o instalaci ovladače ODBC nebo ovladače zdroje dat, který tady není uvedený, najdete v dokumentaci k databázi nebo se obraťte na dodavatele databáze.

Výběr dat z databáze     Data z databáze načítáte vytvořením dotazu, což je otázka, kterou se ptáte na data uložená v externí databázi. Pokud jsou například data uložená v databázi Accessu, možná budete chtít znát údaje o prodeji konkrétního produktu podle oblasti. Část dat můžete načíst tak, že vyberete jenom data pro produkt a oblast, které chcete analyzovat.

V Microsoft Query můžete vybrat sloupce dat, která chcete, a importovat jenom tato data do Excel.

Aktualizace listu v jedné operaci     Jakmile budete mít externí data v sešitu Excel, můžete při každé změně databáze Aktualizovat data aktualizovat , aniž byste museli znovu vytvářet souhrnné sestavy a grafy. Můžete například vytvořit měsíční souhrn prodeje a aktualizovat ho každý měsíc, až přijdou nové údaje o prodeji.

Jak Microsoft Query používá zdroje dat     Po nastavení zdroje dat pro určitou databázi ho můžete použít pokaždé, když chcete vytvořit dotaz k výběru a načtení dat z této databáze , aniž byste museli zadat všechny informace o připojení znovu. Microsoft Query používá zdroj dat k připojení k externí databázi a k zobrazení dostupných dat. Po vytvoření dotazu a vrácení dat do Excel poskytne Microsoft Query sešitu Excel informace o dotazu i zdroji dat, abyste se mohli k databázi znovu připojit, až budete chtít data aktualizovat.

Použití zdrojů dat v aplikaci Microsoft Query

Import dat pomocí Microsoft Query     pokud chcete importovat externí data Excel microsoft query, postupujte podle těchto základních kroků, z nichž každý je podrobněji popsaný v následujících částech.

Co je zdroj dat?     Zdroj dat je uložená sada informací, která Excel a Microsoft Query připojit k externí databázi. Když k nastavení zdroje dat použijete Microsoft Query, dáte zdroji dat název a potom zadejte název a umístění databáze nebo serveru, typ databáze a přihlašovací informace a informace o hesle. Tyto informace také obsahují název ovladače OBDC nebo ovladače zdroje dat, což je program, který umožňuje připojení k určitému typu databáze.

Nastavení zdroje dat pomocí Microsoft Query:

  1. Na kartě Data klikněte ve skupině Získat externí data na Z jiných zdrojůa potom klikněte na Z Microsoft Query.

  2. Udělejte jednu z těchto věcí:

    • Pokud chcete zadat zdroj dat pro databázi, textový soubor nebo Excel sešitu, klikněte na kartu Databáze.

    • Pokud chcete zadat zdroj dat datové krychle OLAP, klikněte na kartu Datové krychle OLAP. Tato karta je dostupná jenom v případě, že jste spustili Microsoft Query z Excel.

  3. Poklikejte na <nový zdroj dat>.

    – nebo –

    Klikněte <nový zdroj>a potom klikněte na OK.

    Zobrazí se dialogové okno Vytvořit nový zdroj dat.

  4. V kroku 1 zadejte název, který identifikuje zdroj dat.

  5. V kroku 2 klikněte na ovladač pro typ databáze, kterou používáte jako zdroj dat.

    Poznámky: 

    • Pokud externí databáze, ke které chcete získat přístup, nejsou podporované ovladači ODBC nainstalovanými s aplikací Microsoft Query, musíte získat a nainstalovat ovladač ODBC kompatibilní s Microsoft Office od jiného dodavatele, například od výrobce databáze. Pokyny k instalaci získáte od dodavatele databáze.

    • Databáze OLAP nevyžadují ovladače ODBC. Při instalaci Aplikace Microsoft Query jsou nainstalované ovladače pro databáze vytvořené pomocí Microsoft SQL Server Analysis Services. Pokud se chcete připojit k jiným databázím OLAP, musíte nainstalovat ovladač zdroje dat a klientský software.

  6. Klikněte Připojenía zadejte informace potřebné pro připojení ke zdroji dat. U databází, Excel sešitů a textových souborů závisí informace, které poskytnete, na typu zdroje dat, který jste vybrali. Může se zobrazit dotaz, jestli chcete zadat přihlašovací jméno, heslo, verzi databáze, kterou používáte, umístění databáze nebo jiné informace specifické pro typ databáze.

    Důležité informace: 

    • Používejte silná hesla kombinující malá a velká písmena, čísla a symboly. Slabá hesla obsahují jenom některé z těchto znaků. Příklad silného hesla: Y6dh!et5. Příklad slabého hesla: Domek27. Hesla by měla obsahovat minimálně 8 znaků. Ještě vhodnější jsou hesla obsahující 14 nebo víc znaků.

    • Je velice důležité, abyste si své heslo zapamatovali. Pokud je zapomenete, společnost Microsoft je nemůže odnikud načíst. Pokud si heslo zapíšete, uložte je na bezpečném místě odlišném od místa uložení informací, které heslo pomáhá chránit.

  7. Po zadání požadovaných informací se kliknutím na OK nebo Dokončit vraťte do dialogového okna Vytvořit nový zdroj dat.

  8. Pokud vaše databáze obsahuje tabulky a chcete, aby se konkrétní tabulka v Průvodci dotazem automaticky zobrazuje, klikněte na pole pro krok 4 a potom klikněte na tabulku, kterou chcete.

  9. Pokud nechcete při používání zdroje dat zadat svoje přihlašovací jméno a heslo, zaškrtněte políčko Uložit id uživatele a heslo do definice zdroje dat. Uložené heslo není zašifrované. Pokud zaškrtávací políčko není k dispozici, zjistěte u správce databáze, jestli je tato možnost dostupná.

    Poznámka zabezpečení: Při připojování ke zdrojům dat se nepoužívejte k ukládání přihlašovacích informací. Tyto informace mohou být uložené ve formátu prostého textu a uživatel se zlými úmysly by k informacím mohl přistupovat, aby mohl ohrozit zabezpečení zdroje dat.

Po dokončení těchto kroků se název zdroje dat zobrazí v dialogovém okně Zvolit zdroj dat.

Použití Průvodce dotazem pro většinu dotazů     Průvodce dotazem usnadňuje výběr a součtení dat z různých tabulek a polí v databázi. Pomocí Průvodce dotazem můžete vybrat tabulky a pole, která chcete zahrnout. Vnitřní spojení (operace dotazu, která určuje, že řádky ze dvou tabulek se kombinují na základě identických hodnot polí) se vytvoří automaticky, když průvodce rozpozná pole primárního klíče v jedné tabulce a pole se stejným názvem ve druhé tabulce.

Pomocí průvodce můžete seřadit sadu výsledků a provést jednoduché filtrování. V posledním kroku průvodce se můžete rozhodnout vrátit data do Excel nebo dotaz v Microsoft Query upřesnit. Po vytvoření dotazu ho můžete spustit v Excel nebo v Microsoft Query.

Průvodce dotazem spustíte takto:

  1. Na kartě Data klikněte ve skupině Získat externí data na Z jiných zdrojůa potom klikněte na Z Microsoft Query.

  2. V dialogovém okně Zvolit zdroj dat zkontrolujte, že je zaškrtnuté políčko Použít Průvodce dotazem k vytváření a úpravám dotazů.

  3. Poklikejte na zdroj dat, který chcete použít.

    – nebo –

    Klikněte na zdroj dat, který chcete použít, a potom klikněte na OK.

Práce přímo v Microsoft Query pro jiné typy dotazů     Pokud chcete vytvořit složitější dotaz, než umožňuje Průvodce dotazem, můžete pracovat přímo v Microsoft Query. Pomocí Microsoft Query můžete zobrazit a změnit dotazy, které začnete vytvářet v Průvodci dotazem, nebo můžete vytvářet nové dotazy bez použití průvodce. Pracujte přímo v Microsoft Query, když chcete vytvořit dotazy, které dělají toto:

  • Výběr konkrétních dat z pole     Ve velké databázi můžete chtít vybrat některá data v poli a vynechat data, která nepotřebujete. Pokud třeba potřebujete data pro dva produkty v poli, které obsahuje informace o mnoha produktech, můžete pomocí Kritéria vybrat data jenom pro dva produkty, které chcete.

  • Načtení dat na základě různých kritérií při každém spuštění dotazu     Pokud potřebujete vytvořit stejnou sestavu Excel nebo souhrn pro několik oblastí ve stejných externích datech , například samostatnou sestavu prodeje pro každou oblast, můžete vytvořit Parametrický dotaz. Když spustíte parametrní dotaz, zobrazí se výzva k zadání hodnoty, která se použije jako kritérium, když dotaz vybere záznamy. Parametrový dotaz může například vyzvat k zadání určité oblasti a tento dotaz můžete znovu použít k vytvoření každé místní sestavy prodeje.

  • Připojení k datům různými způsoby     Vnitřní spojení vytvořená Průvodcem dotazem jsou nejběžnějším typem spojení používaným při vytváření dotazů. Někdy ale chcete použít jiný typ spojení. Pokud máte třeba tabulku s informacemi o prodeji produktů a tabulku informací o zákaznících, zabrání vnitřní spojení (typu vytvořenému Průvodcem dotazem) načtením záznamů zákazníků pro zákazníky, kteří nekoupí. Pomocí Microsoft Query můžete tyto tabulky spojit tak, aby se načítaly všechny záznamy zákazníků, spolu s údaji o prodeji pro zákazníky, kteří provedli nákupy.

Pokud chcete spustit Microsoft Query, proveďte následující kroky.

  1. Na kartě Data klikněte ve skupině Získat externí data na Z jiných zdrojůa potom klikněte na Z Microsoft Query.

  2. V dialogovém okně Zvolit zdroj dat se ujistěte, že je políčko Pro vytváření a úpravy dotazů pomocí Průvodce dotazem zaškrtné.

  3. Poklikejte na zdroj dat, který chcete použít.

    – nebo –

    Klikněte na zdroj dat, který chcete použít, a potom klikněte na OK.

Opakované použití a sdílení dotazů     V Průvodci dotazem i v Microsoft Query můžete dotazy uložit jako soubor .dqy, který můžete upravit, znovu použít a sdílet. Excel soubory .dqy přímo, což vám nebo jiným uživatelům umožňuje vytvářet další oblasti externích dat ze stejného dotazu.

Otevření uloženého dotazu z Excel:

  1. Na kartě Data klikněte ve skupině Získat externí data na Z jiných zdrojůa potom klikněte na Z Microsoft Query. Zobrazí se dialogové okno Zvolit zdroj dat.

  2. V dialogovém okně Zvolit zdroj dat klikněte na kartu Dotazy.

  3. Poklikejte na uložený dotaz, který chcete otevřít. Dotaz se zobrazí v Microsoft Query.

Pokud chcete otevřít uložený dotaz a Microsoft Query už je otevřený, klikněte na nabídku Soubor Microsoft Query a potom klikněte na Otevřít.

Pokud poklikáte na soubor .dqy, Excel otevře, spustí dotaz a pak vloží výsledky do nového listu.

Pokud chcete sdílet souhrn nebo sestavu Excel založenou na externích datech, můžete ostatním uživatelům dát sešit, který obsahuje oblast externích dat, nebo můžete vytvořit Šablona. Šablona umožňuje uložit souhrn nebo sestavu bez uložení externích dat, aby byl soubor menší. Externí data se načítá, když uživatel otevře šablonu sestavy.

Po vytvoření dotazu v Průvodci dotazem nebo v Microsoft Query můžete data vrátit do Excel listu. Data se pak stanou Oblast externích dat nebo Kontingenční tabulka, které můžete formátovat a aktualizovat.

Formátování načtených dat     V Excel můžete pomocí nástrojů, jako jsou grafy nebo automatické mezisoučty, prezentovat a shrnout data načtená v Microsoft Query. Data můžete formátovat a formátování se zachová při aktualizaci externích dat. Místo názvů polí můžete použít vlastní popisky sloupců a automaticky přidávat čísla řádků.

Excel automaticky naformátovat nová data, která napíšete na konci oblasti tak, aby odpovídala předchozím řádkům. Excel také automaticky zkopírovat vzorce, které se opakovaly v předchozích řádcích, a rozšířit je na další řádky.

Poznámka: Aby se formáty a vzorce v oblasti rozšířily na nové řádky, musí se formáty a vzorce objevit aspoň ve třech z pěti předchozích řádků.

Tuto možnost (nebo ji znovu) můžete kdykoli zapnout:

  1. Klikněte na Soubor > Možnosti > Upřesnit.

    V Excel 2007: Klikněte na tlačítko Microsoft Office, Obrázek tlačítka Officena Excel Možnosti apotom klikněte na kategorii Upřesnit.

  2. V části Možnosti úprav zaškrtněte políčko Rozšířit formáty a vzorce oblasti dat. Pokud chcete automatické formátování oblasti dat zase vypnout, zrušte zaškrtnutí tohoto políčka.

Aktualizace externích dat:     Když aktualizujete externí data, spustíte dotaz a načtete nová nebo změněná data, která odpovídají vašim specifikacím. Dotaz můžete aktualizovat v Microsoft Query i v Excel. Excel nabízí několik možností pro aktualizaci dotazů, včetně aktualizace dat při každém otevření sešitu a automatické aktualizaci v časových intervalech. Během aktualizace dat Excel dál pracovat v práci a můžete také zkontrolovat stav při aktualizaci dat. Další informace najdete v tématu Aktualizace externího datového připojení v Excel.

Začátek stránky

Potřebujete další pomoc?

Rozšiřte své znalosti a dovednosti
Projít školení
Získejte nové funkce jako první
Připojit se k programu Microsoft Insider

Byly tyto informace užitečné?

Jak jste spokojeni s kvalitou překladu?
Co ovlivnilo váš názor?

Děkujeme za váš názor!

×