Použití počítaných sloupců v tabulce Excelu

Počítané sloupce Excel tabulek jsou skvělým nástrojem pro efektivní zadávání vzorců. Umožňují zadat do jedné buňky jeden vzorec a potom se tento vzorec automaticky rozšíří do zbytku sloupce. Příkazy Výplň nebo Kopírovat není potřeba používat. Může to být neuvěřitelně úspora času, hlavně pokud máte hodně řádků. A totéž se stane, když změníte vzorec. změna se také rozšíří na zbytek počítaného sloupce.

Poznámka: Snímky obrazovek v tomto článku byly pořízeny v Excelu 2016. Pokud máte jinou verzi, může se zobrazení poněkud lišit, ale pokud není uvedeno jinak, zůstávají funkce stejné.

Vytvoření počítaného sloupce

  1. Vytvoření tabulky Pokud nejste seznámeni s tabulkami Excel, další informace najdete v tématu Přehled Excel tabulek.

  2. Vložte do tabulky nový sloupec. Můžete to udělat tak, že napíšete do sloupce hned napravo od tabulky a Excel tabulku automaticky rozšíří. V tomto příkladu jsme vytvořili nový sloupec tak, že do buňky D1 napíšete "Celkový součet".

    Přidání nového sloupce tabulky zadáním do prázdného sloupce hned napravo od existující tabulky

    Tipy: 

    • Sloupec tabulky můžete přidat taky z karty Domů. Stačí kliknout na šipku pro vložení > vložit sloupce tabulky doleva.

    • Pokud chcete přidat sloupec tabulky z karty Domů, klikněte na šipku pro Vložení > Vložit sloupce tabulky doleva.

  3. Zadejte vzorec, který chcete použít, a stiskněte Enter.

    Přidání jednoho vzorce do buňky tabulky, která se automaticky dokončováním vytvoří počítaný sloupec

    V tomto případě jsme zadali =suma(a pak jsme vybrali sloupce ČT 1 a 2. ČT. Výsledkem je, Excel vzorec: =SUMA(Tabulka1[@[ČT 1]:[ČT 2]]). Tomu se říká strukturovaný referenční vzorec, který je jedinečný pro Excel tabulek. Strukturovaný formát odkazu umožňuje tabulce použít stejný vzorec pro každý řádek. Běžným Excel vzorec by byl =SUMA(B2:C2),který pak budete muset zkopírovat nebo vyplnit do zbývajících buněk ve sloupci.

    Další informace o strukturovaných odkazech najdete v tématu Použití strukturovaných odkazů Excel tabulkách.

  4. Když stisknete Enter, vzorec se automaticky vyplní do všech buněk sloupce – nad buňkou i pod buňkou, do které jste vzorec zadali. Vzorec je pro každý řádek stejný, ale protože se jedná o strukturovaný odkaz, Excel interně ví, který řádek je který.

    Příklad vzorce, který se automaticky vyplňuje, aby se v tabulce vytvořil počítaný sloupec

Poznámky: 

  • Počítaný sloupec můžete vytvořit taky zkopírováním nebo vyplněním vzorce do všech buněk prázdného sloupce tabulky.

  • Pokud do sloupce tabulky, který už obsahuje data, napíšete nebo přesunete vzorec, počítaný sloupec se automaticky nevytvá. Zobrazí se ale tlačítko Možnosti automatických oprav, které vám poskytne možnost přepsat data, aby bylo možné vytvořit počítaný sloupec.

    Možnost přepsání existujících vzorců v počítané sloupci, pokud se jeden vzorec liší od ostatních

  • Pokud do počítaného sloupce zadáte nový vzorec, který se liší od existujících vzorců, sloupec se automaticky aktualizuje novým vzorcem. Aktualizaci můžete vrátit zpět a zachovat jenom jeden nový vzorec z tlačítka Možnosti automatických oprav. Obecně se to ale nedoporučuje, protože může zabránit automatické aktualizaci sloupce v budoucnu, protože nebude vědět, který vzorec se má rozšířit při přidání nových řádků.

    Možnost vrácení počítaného sloupce zpět po zadání vzorce

  • Pokud jste do buňky prázdného sloupce napište nebo zkopírovali vzorec a nechcete nový počítaný sloupec zachovat, klikněte na Undo button vrátit zpět. Můžete také dvakrát stisknout kombinaci kláves Ctrl+Z.

Počítaný sloupec může obsahovat buňku, která má jiný vzorec než ostatní. Tím se vytvoří výjimka, která bude v tabulce zřetelně označená. Neúmyslné nekosistence tak můžete snadno zjistit a vyřešit.

Nekonzistentní oznámení o chybě vzorce v Excel tabulce

Poznámka: Výjimky počítaného sloupce se vytvoří v případě, že uděláte některou z těchto věcí:

  • Zadáte do buňky počítaného sloupce jiná data než vzorec.

  • Zadejte vzorec do buňky počítaného sloupce a potom na panelu nástrojů Rychlý přístup klikněte Undo button tlačítko Zpět.

  • Zadáte do počítaného sloupce, který již obsahuje nejméně jednu výjimku, nový vzorec.

  • Zkopírujete do počítaného sloupce data neodpovídající vzorci daného počítaného sloupce.

    Poznámka: Pokud zkopírovaná data obsahují vzorec, tento vzorec přepíše data v počítané sloupci.

  • Odstraníte vzorec z jedné nebo víc buněk počítaného sloupce.

    Poznámka: Tato výjimka není označena.

  • Přesunete nebo odstraníte v jiné oblasti listu buňku, na kterou odkazuje jeden či více řádků počítaného sloupce.

Oznámení o chybě se zobrazí jenom v případě, že máte povolenou možnost kontroly chyb na pozadí. Pokud chybu nevidíte, přejděte na Možnosti souboru > > Vzorce > zkontrolujte, jestli je zaškrtnuté políčko Povolit chybu na pozadí.

  • Pokud používáte aplikaci Excel 2007, klikněte na tlačítko Office Tlačítko Office 2007a potom Excel Možnosti > Vzorce.

  • Pokud používáte Mac, přejděte na Excel řádku nabídek a potom klikněte na Předvolby > Vzorce & Seznamy > Kontrola chyb.

Možnost automatického vyplňování vzorců pro vytvoření počítaných sloupců v Excel je ve výchozím nastavení povolená. Pokud nechcete, aby Excel počítané sloupce při zadávání vzorců do sloupců tabulky, můžete tuto možnost vypnout. Pokud tuto možnost nechcete vypnout, ale nechcete vždy vytvářet počítané sloupce při práci v tabulce, můžete počítané sloupce zastavit v automatickém vytváření.

  • Zapnutí nebo vypnutí počítaných sloupců

    1. Na kartě Soubor klikněte na položku Možnosti.

      Pokud používáte aplikaci Excel 2007, klikněte na tlačítko Office Tlačítko Office 2007a potom Excel Možnosti.

    2. Klikněte na možnost Kontrola pravopisu a mluvnice.

    3. V části Možnosti automatických opravklikněte na Možnosti automatických oprav.

    4. Klikněte na kartu Automatické úpravy formátu při psaní.

    5. V části Automaticky při práci zaškrtněte nebo zrušte zaškrtnutí políčka Vyplnit vzorce v tabulkách pro vytvoření počítaných sloupců, abyste tuto možnost zapnuli nebo vypnuli.

      Vypněte sloupce počítané tabulky ze seznamu Možnosti > > Nástroje kontroly pravopisu > Možnosti automatických oprav > Zrušte zaškrtnutí políčka Vyplnit vzorce v tabulkách a vytvářet počítané sloupce.

      Tip: Můžete taky kliknout na tlačítko Možnosti automatických oprav, které se po zadání vzorce zobrazí ve sloupci tabulky. Klikněte na Ovládací prvek Možnosti automatických oprav a zrušte zaškrtnutí políčka Vyplnit vzorce v tabulkách pro vytvoření počítaných sloupců, abyste tuto možnost vypnuli.

    Pokud používáte Mac, v hlavní nabídce Excel goto > Předvolby > Vzorce a seznamy > Tabulky & Filtry > Automatické vyplňování vzorců.

  • Automatické ukončení vytváření počítaných sloupců

    Po zadání prvního vzorce ve sloupci tabulky klikněte na tlačítko Možnosti automatických oprav, které se zobrazí, a potom klikněte na Zastavit automatické vytváření počítaných sloupců.

Můžete také vytvořit vlastní počítaná pole s kontingenčními tabulkami, kde vytvoříte jeden vzorec a Excel pak je použije na celý sloupec. Další informace o výpočtu hodnot v kontingenční tabulce

Potřebujete další pomoc?

Kdykoliv se můžete zeptat některého odborníka v technické komunitě Excelu nebo získat podporu v komunitě pro odpovědi.

Viz také

Základní informace o tabulkách Excelu

Formátování excelové tabulky

Změna velikosti tabulky přidáním nebo odebráním řádků a sloupců

Součty dat v tabulce aplikace Excel

Potřebujete další pomoc?

Rozšiřte své znalosti a dovednosti
Projít školení
Získejte nové funkce jako první
Připojit se k programu Microsoft Insider

Byly tyto informace užitečné?

Jak jste spokojeni s kvalitou překladu?
Co ovlivnilo váš názor?

Děkujeme za váš názor!

×