Na obsah buněk v jiném sešitu můžete odkazovat vytvořením vzorce externího odkazu. Externí odkaz (nazývaný taky odkaz) je odkaz na buňku nebo oblast na listu v jiném Excel sešitu nebo odkaz na definovaný název v jiném sešitu.

  1. Otevřete sešit obsahující externí odkaz (cílový sešit) a sešit obsahující data, na která chcete vytvořit odkaz (zdrojový sešit).

  2. Vyberte buňku nebo buňky, ve kterých chcete vytvořit externí odkaz.

  3. Typ = (znaménko rovná se).

    Pokud chcete použít funkci, například SUMA, zadejte název funkce, za kterou následuje počáteční závorka. Například =SUMA(.

  4. Přepněte do zdrojového sešitu a klikněte na list obsahující buňky, které chcete propojit.

  5. Vyberte buňku nebo buňky, na které chcete vytvořit odkaz, a stiskněte Enter.

    Poznámka: Pokud vyberete více buněk, například =[SourceWorkbook.xlsx]List1!$A$1:$A$10 a máte aktuální verzi Microsoft 365, můžete vzorec potvrdit jako dynamický maticový vzorec jednoduše stisknutím klávesy ENTER. V opačném případě musí být vzorec zadán jako starší maticový vzorec stisknutím kombinace kláves CTRL+SHIFT+ENTER. Další informace o maticových vzorcích najdete v tématu s pokyny k používání a příklady maticových vzorců.

  6. Excel se vrátíte do cílového sešitu a zobrazíte hodnoty ze zdrojového sešitu.

  7. Všimněte si Excel vrátí odkaz s absolutními odkazy ,takže pokud chcete vzorec zkopírovat do jiných buněk, budete muset odebrat znaky dolaru ($):

    =[SourceWorkbook.xlsx]List1! $ A$1

    Pokud zdrojový sešit zavřete, Excel ke vzorci automaticky připojí cestu k souboru:

    ='C:\Reports\[SourceWorkbook.xlsx]List1'!$A$1

  1. Otevřete sešit obsahující externí odkaz (cílový sešit) a sešit obsahující data, na která chcete vytvořit odkaz (zdrojový sešit).

  2. Vyberte buňku nebo buňky, ve kterých chcete vytvořit externí odkaz.

  3. Typ = (znaménko rovná se).

  4. Přepněte do zdrojového sešitu a klikněte na list obsahující buňky, které chcete propojit.

  5. Stiskněte klávesu F3,vyberte název, na který chcete vytvořit odkaz, a stiskněte Enter.

    Poznámka: Pokud pojmenovaná oblast odkazuje na více buněk a máte aktuální verzi Microsoft 365 ,můžete jednoduše stisknout enter a vzorec potvrdit jako dynamický maticový vzorec. V opačném případě musí být vzorec zadán jako starší maticový vzorec stisknutím kombinace kláves CTRL+SHIFT+ENTER. Další informace o maticových vzorcích najdete v tématu s pokyny k používání a příklady maticových vzorců.

  6. Excel vás vrátí do cílového sešitu a zobrazí hodnoty z pojmenované oblasti ve zdrojovém sešitu.

  1. Otevřete cílový sešit a zdrojový sešit.

  2. V cílovém sešitu přejděte na Vzorce > definované názvy > Definovat název.

    Skupina Definované názvy na pásu karet

  3. V dialogovém okně Nový název zadejte do pole Název název oblasti.

  4. V poli Odkazuje na odstraňte obsah a potom umístěte kurzor do pole.

    Pokud chcete, aby název funkce fungoval, zadejte název funkce a umístěte kurzor na místo, kde chcete externí odkaz použít. Zadejte třeba =SUMA()a umístěte kurzor mezi závorky.

  5. Přepněte do zdrojového sešitu a klikněte na list obsahující buňky, které chcete propojit.

  6. Vyberte buňku nebo oblast buněk, které chcete propojit, a klikněte na OK.

    Přidání definovaného názvu do externího sešitu ze vzorců > definovaných názvů > Definovat název > Nový název.

Externí odkazy jsou užitečné hlavně v případě, že není praktické udržovat velké modely listů pohromadě ve stejném sešitu.

  • Sloučení dat z několika sešitů    Můžete propojit sešity několika uživatelů nebo oddělení a potom integrovat relevantní data do souhrnného sešitu. Když se tak změní zdrojové sešity, nebudete muset souhrnný sešit ručně měnit.

  • Vytváření různých zobrazení dat    Můžete zadat všechna data do jednoho nebo více zdrojových sešitů a pak vytvořit sešit sestavy, který obsahuje externí odkazy jenom na relevantní data.

  • Zefektivnění velkých a složitých modelů    Rozdělením složitého modelu na řadu vzájemně závislých sešitů můžete na modelu pracovat bez otevření všech souvisejících listů. Menší sešity se snadněji mění, nevyžadují tolik paměti a rychlejší je otevírat, ukládat a počítat.

Vzorce s externími odkazy na jiné sešity se zobrazují dvěma způsoby v závislosti na tom, jestli je zdrojový sešit – ten, který dodává data do vzorce – otevřený nebo zavřený.

Když je zdroj otevřený, externí odkaz obsahuje název sešitu v hranatých závorkách ([ ]), následovaný názvem listu, vykřičníkem (!) a buňkami, na kterých vzorec závisí. Například následující vzorec přidá buňky C10:C25 ze sešitu s názvem Budget.xls.

Externí odkaz

=SUMA([Budget.xlsx]Roční! C10:C25)

Pokud zdroj není otevřený, externí odkaz obsahuje celou cestu.

Externí odkaz

=SUMA('C:\Reports\[Budget.xlsx]Roční'! C10:C25)

Poznámka: Pokud název jiného listu nebo sešitu obsahuje mezery nebo jiné než abecední znaky, musíte název (nebo cestu) uzavřít do jednoduchých uvozovek, jak je uvedeno výše v příkladu. Excel je automaticky přidá, když vyberete zdrojovou oblast.

Vzorce, které odkazují na definovaný název v jiném sešitu, používají název sešitu a vykřičník (!) a název. Například následující vzorec přidá buňky v oblasti s názvem Prodej ze sešitu s názvem Budget.xlsx.

Externí odkaz

=SUMA(Budget.xlsx! Prodej)

  1. Vyberte buňku nebo buňky, ve kterých chcete vytvořit externí odkaz.

  2. Typ = (znaménko rovná se).

    Pokud chcete použít funkci, například SUMA, zadejte název funkce, za kterou následuje počáteční závorka. Například =SUMA(.

  3. Přepněte na list obsahující buňky, na které chcete vytvořit propojení.

  4. Vyberte buňku nebo buňky, na které chcete vytvořit odkaz, a stiskněte Enter.

    Poznámka: Pokud vyberete více buněk (=List1! A1:A10) a mají aktuální verzi Microsoft 365a pak můžete jednoduše stisknout enter a vzorec potvrdit jako dynamický maticový vzorec. V opačném případě musí být vzorec zadán jako starší maticový vzorec stisknutím kombinace kláves CTRL+SHIFT+ENTER. Další informace o maticových vzorcích najdete v tématu s pokyny k používání a příklady maticových vzorců.

  5. Excel se vrátí do původního listu a zobrazí hodnoty ze zdrojového listu.

Vytvoření externího odkazu mezi buňkami v různých sešitech

  1. Otevřete sešit, který bude obsahovat externí odkaz (cílový sešit, nazývaný také sešit vzorců) a sešit obsahující data, na která chcete vytvořit propojení (zdrojový sešit, nazývaný také datový sešit).

  2. Ve zdrojovém sešitu vyberte buňku nebo buňky, které chcete propojit.

  3. Stiskněte Ctrl+C nebo přejděte na Domů> Schránka> Kopírovat.

  4. Přepněte do cílového sešitu a klikněte na list, kam chcete propojená data umístit.

  5. Vyberte buňku, kam chcete umístit propojená data, a pak přejděte na Domů > Schránka > Vložit > Vložit odkaz.

  6. Excel vrátí data zkopírovaná ze zdrojového sešitu. Pokud ho změníte, změní se při aktualizaci okna prohlížeče automaticky v cílovém sešitu.

  7. Pokud chcete použít odkaz ve vzorci, zadejte před odkaz = , zvolte funkci, za odkaz zadejte (a potom zadejte ).

Vytvoření odkazu na list ve stejném sešitu

  1. Vyberte buňku nebo buňky, ve kterých chcete vytvořit externí odkaz.

  2. Typ = (znaménko rovná se).

    Pokud chcete použít funkci, například SUMA, zadejte název funkce, za kterou následuje počáteční závorka. Například =SUMA(.

  3. Přepněte na list obsahující buňky, na které chcete vytvořit propojení.

  4. Vyberte buňku nebo buňky, na které chcete vytvořit odkaz, a stiskněte Enter.

  5. Excel se vrátí do původního listu a zobrazí hodnoty ze zdrojového listu.

Potřebujete další pomoc?

Kdykoliv se můžete zeptat některého odborníka v technické komunitě Excelu nebo získat podporu v komunitě pro odpovědi.

Viz také

Definice a použití názvů ve vzorcích

Vyhledání odkazů (externích odkazů) v sešitu

Potřebujete další pomoc?

Rozšiřte své znalosti a dovednosti
Projít školení
Získejte nové funkce jako první
Připojit se systém Microsoft Office insiderům

Byly tyto informace užitečné?

Jak jste spokojeni s kvalitou překladu?
Co ovlivnilo váš názor?

Děkujeme za váš názor!

×