Vytvoření nebo spuštění makra

Ve Wordu můžete často používané úkoly automatizovat vytvořením a spuštěním maker. Makro je řada příkazů a pokynů, které seskupíte jako jeden příkaz k automatickému provedení úkolu.

Pokud chcete ušetřit čas na úkolech, které děláte často, svažte jednotlivé kroky do makra. Nejdřív makro zaznamenejte. Pak ho můžete spustit kliknutím na tlačítko na panelu nástrojů Rychlý přístup nebo stiskem kombinace kláves. Záleží na tom, jak si ho nastavíte.

  1. Klikněte na Zobrazení > Makra > Zaznamenat makro.

    Příkaz Zaznamenat makro

  2. Zadejte název makra.

    Pole Název makra

  3. Abyste tohle makro mohli použít u všech nových dokumentů, které vytvoříte, nezapomeňte v poli Uložit makro v vybrat možnost Všechny dokumenty (Normal.dotm).

    Pole pro výběr místa uložení makra

  4. Pokud chcete makro spouštět kliknutím na tlačítko, klikněte na Tlačítko.

    Kliknutím přiřadíte makro k tlačítku

  5. Klikněte na nové makro (jeho název vypadá podobně jako Normal.NewMacros.<váš název makra>) a klikněte na Přidat.

    Makro a tlačítko Přidat

  6. Klikněte na Změnit.

    Tlačítko Změnit v okně Přizpůsobení panelu nástrojů Rychlý přístup

  7. Zvolte obrázek tlačítka, zadejte požadovaný název a dvakrát klikněte na OK.

    Možnosti tlačítka v okně Tlačítko Změnit

  8. Teď je čas pro záznam kroků. Pro každý krok úkolu klikněte na příkaz nebo stiskněte tlačítko. Word zaznamená vaše kliknutí a stisknutí kláves.

    Poznámka: Při záznamu makra vybírejte text pomocí klávesnice. Výběr provedený pomocí myši makro nezaznamená.

  9. Pro ukončení záznamu klikněte na Zobrazení > Makra > Zastavit záznam.

    Příkaz Zastavit záznam

Tlačítko vašeho makra se zobrazí na panelu nástrojů Rychlý přístup.

Tlačítko makra na panelu nástrojů Rychlý přístup

Kliknutím na tlačítko makro spustíte.

  1. Klikněte na Zobrazení > Makra > Zaznamenat makro.

    Příkaz Zaznamenat makro

  2. Zadejte název makra.

    Pole Název makra

  3. Abyste tohle makro mohli použít u všech nových dokumentů, které vytvoříte, nezapomeňte v poli Uložit makro v vybrat možnost Všechny dokumenty (Normal.dotm).

    Pole pro výběr místa uložení makra

  4. Pokud chcete makro spouštět stiskem klávesové zkratky, klikněte na Klávesnici.

    Kliknutím přiřadíte makro ke klávesové zkratce

  5. Do pole Stiskněte klávesovou zkratku zadejte kombinaci kláves.

  6. Zkontrolujte, jestli tato kombinace už není přiřazená k něčemu jinému. Pokud ano, zkuste jinou kombinaci.

  7. Abyste toto makro mohli použít u všech nových dokumentů, které vytvoříte, nezapomeňte v poli Změny uložit do vybrat možnost Normal.dotm.

  8. Klikněte na Přiřadit.

  9. Teď je čas pro záznam kroků. Pro každý krok úkolu klikněte na příkaz nebo stiskněte tlačítko. Word zaznamená vaše kliknutí a stisknutí kláves.

    Poznámka: Při záznamu makra vybírejte text pomocí klávesnice. Výběr provedený pomocí myši makro nezaznamená.

  10. Pro ukončení záznamu klikněte na Zobrazení > Makra > Zastavit záznam.

    Příkaz Zastavit záznam

Makro spustíte stiskem klávesové zkratky.

Když chcete spustit makro, klikněte na tlačítko na panelu nástrojů Rychlý přístup a stiskněte klávesovou zkratku. Nebo můžete makro spustit ze seznamu Makra.

  1. Klikněte na Zobrazení > Makra > Zobrazit makra.

    Příkaz Zobrazit makra

  2. V seznamu Název makra klikněte na makro, které chcete spustit.

  3. Klikněte na Spustit.

Aby mohlo být makro z jednoho dokumentu dostupné ve všech nových dokumentech, přidejte ho do šablony Normal.dotm.

  1. Otevřete dokument obsahující makro.

  2. Klikněte na Zobrazení > Makra > Zobrazit makra.

    Příkaz Zobrazit makra

  3. Klikněte na Organizátor.

    Tlačítko Organizátor v okně Zobrazit makra

  4. Klikněte na makro, které chcete přidat do šablony Normal.dotm a pak na Kopírovat.

  1. Klikněte na Soubor > Možnosti > Přizpůsobit pás karet.

  2. V rozevíracím seznamu Zvolit příkazy z klikněte na položku Makra.

  3. Klikněte na požadované makro.

  4. V části Přizpůsobit pás karet klikněte na kartu a vlastní skupinu, do které chcete makro přidat.

Pokud nemáte vlastní skupinu, klikněte na tlačítko Nová skupina. Potom klikněte na Přejmenovat a zadejte název vlastní skupiny.

  1. Klikněte na Přidat.

  2. Kliknutím na Přejmenovat zvolíte pro makro symbol a zadáte požadovaný název.

  3. Dvakrát klikněte na OK.

  1. Na kartě Vývojář klikněte ve skupině Kód na tlačítko Makra.

  2. Do pole Název makra napište název makra.

    Poznámka: Pokud novému makru dáte stejný název jako předdefinovaný makro ve Wordu, nahradí se předdefinovaný makro novými akcemi maker. Pokud chcete zobrazit seznam předdefinových maker, klikněte v seznamu Makra v seznamu Příkazy wordu.

  3. V seznamu Makra v klikněte na šablonu nebo dokument, do kterého chcete makro uložit.

    Pokud chcete, aby makro bylo dostupné ve všech dokumentech, nezapomeňte kliknout na Normal.dotm.

  4. Kliknutím na Vytvořit otevřete Visual Basic Editor.

Po otevření Editoru jazyka Visual Basic můžete chtít další informace o práci s jazykem Visual Basic for Applications. Další informace získáte tak, že v nabídce Nápověda kliknete na Nápověda pro Microsoft Visual Basic nebo stisknete klávesu F1.

Můžete zaznamenat posloupnost akcí nebo můžete napsat makro od začátku zadáním kódu jazyka Visual Basic for Applications do Visual Basic Editor.

Poznámka: Pokud chcete pracovat s Office Word 2007, musíte zobrazit kartu Vývojář.

  1. Klikněte na tlačítko Microsoft Office Obrázek tlačítka Office a potom klikněte na Možnosti aplikace Word.

  2. Klikněte na Oblíbené.

  3. V části Nejlepší možnosti pro práci s Wordemzaškrtněte políčko Zobrazit kartu Vývojář na pásu karet.

    Poznámka: Pás karet je součástí Uživatelské rozhraní Microsoft Office Fluent.

  1. Na kartě Vývojář klikněte ve skupině Kód na Zaznamenat makro.

    Skupina Kód na kartě Vývojář
  2. Do pole Název makra napište název makra.

    Poznámka: Pokud nové makro dáte stejný název jako předdefinovaný makro v Office Word 2007, nahradí se předdefinovaný makro novými akcemi maker. Pokud chcete zobrazit seznam předdefinových maker, klikněte na kartě Vývojář ve skupině Kód na Makra. V seznamu Makra v klikněte na Příkazy aplikace Word.

  3. V poli Uložit makro do klikněte na Šablona nebo dokument, do kterého chcete makro uložit.

    Důležité informace: Pokud chcete, aby makro bylo dostupné ve všech dokumentech, nezapomeňte kliknout na Normal.dotm.

  4. Do pole Popis napište krátký popis makra.

  5. Proveďte jednu z následujících akcí:

    • Zahájení nahrávání    Pokud chcete makro začít nahrávat bez přiřazení k tlačítku na panelu nástrojů Rychlý přístup nebo ke klávesové zkratce, klikněte na OK.

    • Vytvoření tlačítka    Pokud chcete makro přiřadit k tlačítku na panelu nástrojů Rychlý přístup, proveďte toto:

      1. Klikněte na tlačítko.

      2. V části Customize Quick Access Toolbar(Přizpůsobit panel nástrojů Rychlý přístup) vyberte dokument (nebo všechny dokumenty), ke kterému chcete makro přidat na panel nástrojů Rychlý přístup.

        Důležité informace: Pokud chcete, aby makro bylo dostupné ve všech dokumentech, nezapomeňte kliknout na Normal.dotm.

      3. V dialogovém okně Zvolit příkazy z klikněte na makro, které nahráváte, a potom klikněte na Přidat.

      4. Pokud chcete tlačítko přizpůsobit, klikněte na Změnit.

      5. V části Symbolklikněte na symbol, který chcete použít pro tlačítko.

      6. Do pole Zobrazovaný název zadejte název makra, který chcete zobrazit.

      7. Pokud chcete makro začít nahrávat, klikněte dvakrát na OK.

        Symbol, který vyberete, se zobrazí na panelu nástrojů Rychlý přístup. Název, který napíšete, se zobrazí, když na symbol nasátáte.

    • Přiřazení klávesové zkratky    Pokud chcete přiřadit makro k klávesové zkratce, proveďte toto:

      1. Klikněte na Klávesnice.

      2. V poli Příkazy klikněte na makro, které nahráváte.

      3. Do pole Stiskněte novou klávesovou zkratku zadejte posloupnost kláves, kterou chcete použít, a potom klikněte na Přiřadit.

      4. Klikněte na Zavřít a začněte nahrávat makro.

  6. Proveďte akce, které chcete zahrnout do makra.

    Poznámka: Když nahrajete makro, můžete pomocí myši kliknout na příkazy a možnosti, ale ne vybrat text. K výběru textu je nutné použít klávesnici. Další informace o výběru textu pomocí klávesnice najdete v tématu Výběr textu.

  7. Pokud chcete nahrávání akcí ukončit, klikněte ve skupině Kód na Zastavit záznam.

Změna klávesové zkratky makra

  1. Klikněte na tlačítko Microsoft Office Obrázek tlačítka Office a potom klikněte na Možnosti aplikace Word.

  2. Klikněte na Přizpůsobit.

  3. Vedle položky Klávesové zkratkyklikněte na Přizpůsobit.

  4. V seznamu Kategorie klikněte na Makra.

  5. V seznamu Makra klikněte na makro, které chcete změnit.

  6. Do pole Stiskněte novou klávesovou zkratku zadejte kombinaci kláves, kterou chcete zvolit.

  7. Zaškrtněte políčko Aktuální klávesy, abyste měli jistotu, že přiřazovat kombinaci kláves, kterou už používáte k provedení jiného úkolu.

  8. V seznamu Uložit změny v klikněte na možnost, která odpovídá tomu, kde chcete makro spustit.

    Důležité informace: Pokud chcete, aby makro bylo dostupné ve všech dokumentech, nezapomeňte kliknout na Normal.dotm.

  9. Klikněte na tlačítko Zavřít.

  1. Na kartě Vývojář klikněte ve skupině Kód na tlačítko Makra.

    Skupina Kód na kartě Vývojář

  2. V seznamu pod položkou Název makraklikněte na makro, které chcete spustit.

  3. Klikněte na Spustit.

  1. Na kartě Vývojář klikněte ve skupině Kód na tlačítko Makra.

    Skupina Kód na kartě Vývojář

  2. Do pole Název makra napište název makra.

    Poznámka: Pokud nové makro dáte stejný název jako předdefinovaný makro v Office Word 2007, nahradí se předdefinovaný makro novými akcemi maker. Pokud chcete zobrazit seznam předdefinových maker, klikněte v seznamu Makra v seznamu Příkazy wordu.

  3. V seznamu Makra v klikněte na Šablona nebo dokument, do kterého chcete makro uložit.

    Pokud chcete, aby makro bylo dostupné ve všech dokumentech, nezapomeňte kliknout na Normal.dotm.

  4. Kliknutím na Vytvořit otevřete Visual Basic Editor.

Po otevření Editoru jazyka Visual Basic můžete chtít další informace o práci s jazykem Visual Basic for Applications. Další informace získáte tak, že v nabídce Nápověda kliknete na Nápověda pro Microsoft Visual Basic nebo stisknete klávesu F1.

Pokud chcete rychle pracovat na úkolech, které často pracujete, můžete v desktopové verzi Wordu sbalit kroky do maker, která běží jediným kliknutím. V Word pro web musíte tyto úkoly procházet ručně.

Pokud máte Word, otevřete dokument ve Wordu tak, že nejdřív kliknete na Otevřít ve Wordu.

Obrázek příkazu Otevřít v desktopové aplikaci

Pak postupujte podle pokynů pro desktopovou verzi Wordu.

Když makro spustíte ve Wordu a dokument uložíte, zobrazí se výsledky makra při opětovném otevření dokumentu v Word pro web.

Potřebujete další pomoc?

Rozšiřte své dovednosti s Office
Projít školení
Získejte nové funkce jako první
Připojte se k účastníkům programu Office Insiders

Byly tyto informace užitečné?

Děkujeme vám za zpětnou vazbu.

Děkujeme vám za váš názor! Pravděpodobně bude užitečné, když vás spojíme s některým z našich agentů podpory Office.

×