Přihlásit se pomocí účtu Microsoft
Přihlaste se nebo si vytvořte účet.
Dobrý den,
Vyberte jiný účet.
Máte více účtů.
Zvolte účet, pomocí kterého se chcete přihlásit.

Příznaky

V Microsoft Commerce Server 2009 R2 spuštění postupy čištění po přenesení. Při spuštění nástroj CatalogCleanup.vbs nebo ctlg_DropPersistentTablesInScratchDB uložené procedury, zobrazí se chybová zpráva podobná následující:

Msg 245, úroveň 16, stavu 1, řádek 25

Převod se nezdařil při převodu hodnotu nvarchar "Výsledků" na datový typ int. Převod se nezdařil při převodu hodnotu nvarchar "Výsledků" na datový typ int.


Příčina

K tomuto problému dochází z důvodu problému v ctlg_DropPersistentTablesInScratchDB uložené procedury.

Řešení

Chcete-li vyřešit tento problém, použití této opravy hotfix.

K dokončení instalace této opravy hotfix, naleznete v části "instalace pokyny".

Informace o opravě hotfix

Společnost Microsoft má k dispozici podporovanou opravu hotfix. Tato oprava hotfix je však určena opravit pouze problému popsaného v tomto článku. Tuto opravu hotfix instalujte pouze do systémů, ve kterých dochází k potížím popsaným v tomto článku. Tato oprava hotfix může být dále testována. Proto pokud nejste vážně ohrožen tímto problémem, doporučujeme počkat na další aktualizaci softwaru, která obsahuje tuto opravu hotfix.

Pokud je oprava hotfix k dispozici ke stažení, je v horní části tohoto článku znalostní báze Knowledge Base oddíl "Oprava Hotfix je dostupná ke stažení" . Pokud tato sekce není uvedena, obraťte se na Zákaznický servis a podporu společnosti Microsoft k získaní opravy hotfix.

Poznámka: Pokud nastanou další problémy nebo bude nutné další řešení potíží, bude možná třeba vytvořit další samostatný požadavek na služby. Běžná cena za technickou podporu se vztahuje k dodatečným otázkám podpory a k problémům, které se netýkají této konkrétní opravy hotfix. Úplný seznam telefonních čísel Zákaznického servisu a podpory společnosti Microsoft naleznete na následujícím webu podpory společnosti Microsoft, kde také můžete vytvořit samostatný požadavek na služby:

http://support.microsoft.com/contactus/?ws=supportPoznámka: Ve formuláři „Oprava hotfix je dostupná ke stažení“ se zobrazují jazyky, pro které je oprava hotfix k dispozici. Pokud váš jazyk není zobrazen, to je protože oprava hotfix není k dispozici pro daný jazyk.

Předpoklady

Chcete-li nainstalovat tuto opravu hotfix, musí mít Service Pack 1 pro Commerce Server 2009 R2 nainstalován.


Pokyny k instalaci

Chcete-li vyřešit tento problém pro nové databáze katalogu, spusťte soubor Cs2009r2sp1-kb2908786-x86.exe aktualizace souboru Catalogcreate.sql pro Commerce Server 2009 R2.

Navíc je nutné spustit soubor Kb2908786.sql proti existující databáze katalogu aktualizovat jejich uložené procedury.

Informace o restartování počítače

Po instalaci této opravy hotfix nemusíte restartovat počítač.

Informace o odinstalaci

Je-li odinstalovat tuto opravu hotfix, Průvodce konfigurací serveru Commerce a lze jej spustit Průvodce inovací. Můžete bezpečně klepněte na tlačítko Storno pro zrušení opětovného spuštění těchto průvodců.

Informace o nahrazení

Tato oprava hotfix nenahrazuje dříve vydanou opravu hotfix.

Informace o souborech

Anglická verze této opravy hotfix má atributy (nebo pozdější atributy souborů) uvedené v následující tabulce. Kalendářní data a časy jednotlivých souborů jsou uvedeny v koordinovaném světovém čase (UTC). Při zobrazení informací o souboru je převeden na místní čas. Rozdíl mezi místním časem a časem UTC naleznete na kartě Časové pásmo v položce Datum a čas v okně Ovládací panely.

Pro Commerce Server 2009 R2

Název souboru

Verze souboru

Velikost souboru

Datum

Čas

Platforma

Cs2009r2sp1-kb2908786-x86.exe

9.0.60313.7

508,096

22-Nov-2013

08:55

x86

Kb2908786.sql

Není k dispozici

5,669

22-Nov-2013

13:30

Není k dispozici

Catalogcreate.sql

Není k dispozici

1,166,059

22-Nov-2013

00:40

Není k dispozici

Poznámka: Vzhledem k závislostem souborů může nejnovější oprava, která obsahuje tyto soubory také obsahovat další soubory.


Stav

Společnost Microsoft potvrdila, že se jedná o problém v produktech společnosti Microsoft, které jsou uvedeny v části "Platí pro".

Odkazy

Naleznete terminologie společnost Microsoft používá k popisu aktualizací softwaru.

Potřebujete další pomoc?

Chcete další možnosti?

Prozkoumejte výhody předplatného, projděte si školicí kurzy, zjistěte, jak zabezpečit své zařízení a mnohem více.

Komunity vám pomohou klást otázky a odpovídat na ně, poskytovat zpětnou vazbu a vyslechnout odborníky s bohatými znalostmi.

Byly tyto informace užitečné?

Jak jste spokojeni s kvalitou jazyka?
Co ovlivnilo váš názor?
Po stisknutí tlačítka pro odeslání se vaše zpětná vazba použije k vylepšování produktů a služeb Microsoftu. Váš správce IT bude moci tato data shromažďovat. Prohlášení o zásadách ochrany osobních údajů.

Děkujeme vám za zpětnou vazbu.

×