Přihlásit se pomocí účtu Microsoft
Přihlaste se nebo si vytvořte účet.
Dobrý den,
Vyberte jiný účet.
Máte více účtů.
Zvolte účet, pomocí kterého se chcete přihlásit.

Příznaky

Zvažte následující scénář:

  • Nasadili jste různé kumulativní aktualizace pro servery Microsoft Exchange v prostředí Exchange Server 2013.

  • Konfigurujete službu Vyrovnávání zatížení , která nepoužívá spřažení relací pro protokol HTTP a obor názvů pro PowerShell.

  • Pomocí následujících prostředí Exchange Management Shell vytvoříte vzdálené relace PowerShellu napříč vyrovnaným zavaděčem: $Session = New-PSSession-ConfigurationName Microsoft. Exchange-ConnectionUri http://shell.contoso.com-AllowRedirectionImport-PSSession $Session

V tomto scénáři připojení neproběhne úspěšně. Kromě toho se zobrazí chyba WSMan-InvalidShellID, která se podobá následující:

New-PSSession: [shell.contoso.com] zpracovávání dat ze vzdáleného serveru shell.contoso.com se nezdařilo s následující chybovou zprávou: [ClientAccessServer = Server1, BackEndServer = Server. contoso. com, RequestId =IDNumber, časové razítko =Datum a čas] [FailureCategory = WSMan-InvalidShellID] požadavek na vzdálené prostředí systému Windows s ShellId ShellIDNumner se nezdařil, protože prostředí nebylo nalezeno. Možné příčiny jsou: zadaná ShellId je nesprávná nebo prostředí už na serveru neexistuje. Zadejte správnou ShellId nebo vytvořte nové prostředí a zkuste operaci zopakovat. Další informace najdete v tématu nápovědy bout_Remote_Troubleshooting. [....]

Příčina

K tomuto problému dochází, protože vzdálené relace PowerShellu nejsou nepřetržitě směrovány na stejný server poštovní schránky.

Alternativní řešení

Jako alternativní řešení použijte jednu z následujících metod:

  • Nakonfigurujte službu Vyrovnávání zatížení tak, aby používala spřažení relací nebo trvalost.

  • Používat servery Exchange stejné kumulativní aktualizace ve vyrovnávání zatížení

Řešení

Tento problém vyřešíte instalací kumulativní aktualizace 11 nebo novější kumulativní aktualizace pro Exchange Server 2013.

Stav

Společnost Microsoft potvrzuje, že se jedná o problém v produktech této společnosti, které jsou uvedeny v části Informace v tomto článku jsou určeny pro produkt.

Potřebujete další pomoc?

Chcete další možnosti?

Prozkoumejte výhody předplatného, projděte si školicí kurzy, zjistěte, jak zabezpečit své zařízení a mnohem více.

Komunity vám pomohou klást otázky a odpovídat na ně, poskytovat zpětnou vazbu a vyslechnout odborníky s bohatými znalostmi.

Byly tyto informace užitečné?

Jak jste spokojeni s kvalitou jazyka?
Co ovlivnilo váš názor?
Po stisknutí tlačítka pro odeslání se vaše zpětná vazba použije k vylepšování produktů a služeb Microsoftu. Váš správce IT bude moci tato data shromažďovat. Prohlášení o zásadách ochrany osobních údajů.

Děkujeme vám za zpětnou vazbu.

×