Přihlásit se pomocí účtu Microsoft
Přihlaste se nebo si vytvořte účet.
Dobrý den,
Vyberte jiný účet.
Máte více účtů.
Zvolte účet, pomocí kterého se chcete přihlásit.

Příznaky

Na portálu Business Portal pro Microsoft Dynamics GP se zobrazí následující chybová zpráva:

Chyba serveru v aplikaci '/'.

Nelze serializovat stav relace. V režimu StateServer a SQLServer ASP.NET serializovat objekty stavu relace a v důsledku toho nejsou povoleny neserializovatelné objekty nebo objekty MarshalByRef. Stejné omezení platí v případě, že podobnou serializaci provádí vlastní úložiště stavu relace v režimu Vlastní.

K tomuto problému dochází, pokud platí jedna z následujících podmínek:

  • Kliknutím zaškrtněte políčko Vyžadovat čas zahájení nebo zastavení v samoobslužné suite pro správu lidských zdrojů v portálu Business Portal.

  • Časový rozvrh uložíte v Project časového & pro Microsoft Dynamics GP.

  • V aplikaci Správa požadavků pro Microsoft Dynamics GP vytvoříte novou žádanku.

Příčina

K tomuto problému dochází, protože jiná aplikace změní <sessionState> prvek v Web.config souboru.

Řešení

Chcete-li tento problém vyřešit, změňte <sessionState a> použít parametry, které business portal potřebuje. Postupujte takto:

  1. Vyhledejte soubor Web.config pro obchodní portál. Tento soubor se nachází ve virtuálním adresáři ve složce Inetpub na serveru, na kterém je nainstalovaný portál Business Portal. Tento soubor může být například v následujícím umístění:

    C:\Inetpub\wwwroot\wss\VirtualDirectories\81

  2. Vytvořte kopii Web.config souboru.

  3. V Poznámkový blok nebo v jiném textovém editoru otevřete Web.config soubor.

  4. V nabídce Úpravy klikněte na Najít.

  5. Do pole Najít zadejte režim sessionState a klikněte na Najít další.

  6. Ověřte, že <sessionState,> se zobrazí následujícím způsobem.

    <sessionState mode="InProc" />
  7. Pokud <sessionState> prvek atributu "InProc", upravte režim <sessionState> hodnotu atributu "InProc".

  8. Uložte Web.config soubor.

  9. Pokud chcete povolit změny v Web.config souboru, spusťte příkaz iisreset. Postupujte takto:

    1. Na serveru, na kterém je nainstalovaný portál Business Portal, klikněte na Starta potom klikněte na Spustit.

    2. Do pole Otevřít zadejte následující příkaz a stiskněte enter:

      iisreset

Potřebujete další pomoc?

Chcete další možnosti?

Prozkoumejte výhody předplatného, projděte si školicí kurzy, zjistěte, jak zabezpečit své zařízení a mnohem více.

Komunity vám pomohou klást otázky a odpovídat na ně, poskytovat zpětnou vazbu a vyslechnout odborníky s bohatými znalostmi.

Byly tyto informace užitečné?

Jak jste spokojeni s kvalitou jazyka?
Co ovlivnilo váš názor?
Po stisknutí tlačítka pro odeslání se vaše zpětná vazba použije k vylepšování produktů a služeb Microsoftu. Váš správce IT bude moci tato data shromažďovat. Prohlášení o zásadách ochrany osobních údajů.

Děkujeme vám za zpětnou vazbu.

×