Přihlásit se pomocí účtu Microsoft
Přihlaste se nebo si vytvořte účet.
Dobrý den,
Vyberte jiný účet.
Máte více účtů.
Zvolte účet, pomocí kterého se chcete přihlásit.

Příznaky

Jde o takovouto situaci:

  • Máte řadiče domény se systémem Windows Server 2008 R2 v prostředí domény se systémem Windows Server 2008 R2.

  • Můžete nastavit na konkrétní statický port má být použit NT Directory Service (NTDS) a služba Netlogon na řadiči domény. Chcete-li to provést, postupujte podle metody, která je popsána v následujícím článku znalostní báze Microsoft Knowledge Base (KB):

    224196 replikací omezení služby Active Directory a přenosu služby RPC klienta na určitý port

  • Můžete nakonfigurovat obvodové síti (označované také jako DMZ, demilitarizovaná zóna a sledovaná podsíť) Chcete-li povolit síťový provoz na konkrétní statický port.

  • Pokusíte se přihlásit k řadiči domény.

V tomto scénáři trvá déle, než bylo očekáváno přihlašovací proceduru pro řadič domény. Kromě toho může být narušeno některé služby závislé na službu Netlogon.

Také můžete vidět následující RPC rozšířené informace o chybě v souboru netlogon.log:[CRITICAL] [22508] NlPrintRpcDebug: Dumping extended error for I_NetServerReqChallenge with 0xc0020017[CRITICAL] [22508] [0] ProcessID is 948
[CRITICAL] [22508] [0] System Time is: 10/7/2014 17:9:8:786
[CRITICAL] [22508] [0] Generating component is 18
[CRITICAL] [22508] [0] Status is 1722
[CRITICAL] [22508] [0] Detection location is 1442
[CRITICAL] [22508] [0] Flags is 0
[CRITICAL] [22508] [0] NumberOfParameters is 1
[CRITICAL] [22508] Unicode string: dc1.contoso.com
[CRITICAL] [22508] [1] ProcessID is 948
[CRITICAL] [22508] [1] System Time is: 10/7/2014 17:9:8:786
[CRITICAL] [22508] [1] Generating component is 18
[CRITICAL] [22508] [1] Status is 1722
[CRITICAL] [22508] [1] Detection location is 323
[CRITICAL] [22508] [1] Flags is 0
[CRITICAL] [22508] [1] NumberOfParameters is 0
[CRITICAL] [22508] [2] ProcessID is 948
[CRITICAL] [22508] [2] System Time is: 10/7/2014 17:9:8:786
[CRITICAL] [22508] [2] Generating component is 18
[CRITICAL] [22508] [2] Status is 1237
[CRITICAL] [22508] [2] Detection location is 313
[CRITICAL] [22508] [2] Flags is 0
[CRITICAL] [22508] [2] NumberOfParameters is 0
[CRITICAL] [22508] [3] ProcessID is 948
[CRITICAL] [22508] [3] System Time is: 10/7/2014 17:9:8:786
[CRITICAL] [22508] [3] Generating component is 18
[CRITICAL] [22508] [3] Status is 10060
Chyba RPC je 1722 (RPC_S_SERVER_UNAVAILABLE) a Sockets chyba 10060 (WSAETIMEDOUT). Tyto chyby označují, že server není dostupný a neodpověděl včas.

V níže uvedené trasování v síti zjistíte, že port se klient spolu s požadavky TCP SYN neobdrží odpověď. Proto server nereaguje na tomto portu.10.1.1.70 57565 (0xE0DD) 10.1.1.140 135 (0x87) EPM EPM:Request: ept_map: NDR, Netlogon(NRPC) {12345678-1234-ABCD-EF00-01234567CFFB} v1.010.1.1.140 135 (0x87) 10.1.1.70 57565 (0xE0DD) EPM EPM:Response: ept_map: NDR, Netlogon(NRPC) {12345678-1234-ABCD-EF00-01234567CFFB} v1.0
Tower: NDR, Netlogon(NRPC) {12345678-1234-ABCD-EF00-01234567CFFB} v1.0, RPC v5, 10.1.1.140:2645 (0xA55) [2645]
Tower: NDR, Netlogon(NRPC) {12345678-1234-ABCD-EF00-01234567CFFB} v1.0, RPC v510.92.24.141, 10.1.1.140:49150 (0xBFFE) [49150]
Tower: NDR, Netlogon(NRPC) {12345678-1234-ABCD-EF00-01234567CFFB} v1.0, RPC v510.92.24.141, 10.1.1.140:1028 (0x404) [1028]
Poznámka: Klient použije první port (v tomto případě je 2645) a že port není otevřen v bráně firewall.

Pokud máte nainstalován v systému Windows Server 2008 R2 aktualizace 2654097 nebo používáte systém Windows Server 2012 nebo novější, členové domény a řadiče domény, které mluví na řadič domény, který je ovlivněn tento problém protokolu události 5816 a 5817, pokud k ní dojde.

Příčina

K tomuto problému dochází, protože neexistuje žádná synchronizace mezi registrace koncového bodu v řadiči domény. Registrace koncového bodu jsou prováděny různé služby nebo podprocesů, které jsou hostovány v procesu Lsass.exe.

Například následující služby jsou hostovány v procesu Lsass.exe:

  • Lsarpc

  • SAMR

  • Drsuapi

  • Služba Netlogon


Řešení

Informace o opravě hotfix

Společnost Microsoft má k dispozici podporovanou opravu hotfix. Tato oprava hotfix je však určena pouze problému popsanému v tomto článku. Tuto opravu hotfix instalujte pouze do systémů, ve kterých dochází k potížím popsaným v tomto článku. Tato oprava hotfix může být dále testována. Proto pokud nejste vážně ohrožen tímto problémem, doporučujeme počkat na další aktualizaci softwaru, která obsahuje tuto opravu hotfix.

Pokud je oprava hotfix k dispozici ke stažení, je v horní části tohoto článku znalostní báze Knowledge Base oddíl "Oprava Hotfix je dostupná ke stažení" . Pokud tato sekce není uvedena, obraťte se na Zákaznický servis a podporu společnosti Microsoft k získaní opravy hotfix.

Poznámka: Pokud nastanou další problémy nebo bude nutné další řešení potíží, bude možná třeba vytvořit další samostatný požadavek na služby. Běžná cena za technickou podporu se vztahuje k dodatečným otázkám podpory a k problémům, které se netýkají této konkrétní opravy hotfix. Pro úplný seznam telefonních čísel společnosti Microsoft Zákaznikého servisu a podpory nebo chcete-li vytvořit zvláštní požadavek na službu navštivte následující web společnosti Microsoft:

http://support.microsoft.com/contactus/?ws=supportPoznámka: Ve formuláři „Oprava hotfix je dostupná ke stažení“ se zobrazují jazyky, pro které je oprava hotfix k dispozici. Pokud váš jazyk není zobrazen, to je protože oprava hotfix není k dispozici pro daný jazyk.

Předpoklady

Chcete-li nainstalovat tuto opravu hotfix, musíte používat systém Windows Server 2008 R2 Service Pack 1 (SP1).

Další informace o získání aktualizace service pack systému Windows 7 nebo Windows Server 2008 R2 získáte klepnutím na následující číslo článku databáze Microsoft Knowledge Base:

976932 Informace o aktualizaci Service Pack 1 pro systém Windows 7 a Windows Server 2008 R2

Informace o registrech

Chcete-li nainstalovat tuto opravu hotfix, není nutné provádět žádné změny registru.

Požadavek na restartování

Po instalaci této opravy hotfix musíte restartovat počítač.

Informace o nahrazení opravy hotfix

Tato oprava hotfix nenahrazuje dříve vydanou opravu hotfix.

Globální verze této opravy hotfix nainstaluje soubory, jejichž atributy jsou uvedeny v následujících tabulkách. Kalendářní data a časy jednotlivých souborů jsou uvedeny v koordinovaném světovém čase (UTC). Kalendářní data a časy těchto souborů v místním počítači jsou zobrazeny dle vašeho místního času a také podle aktuálního letního času (DST). Navíc data a časy se mohou změnit při provádění některých operací se soubory.

Poznámky k informacím o souboru systému Windows Server 2008 R2Důležité: Opravy hotfix pro systém Windows 7 a Windows Server 2008 R2 opravy hotfix jsou součástí stejných balíčků. Opravy hotfix na stránce žádost o opravu Hotfix jsou však uvedeny pod oběma operačními systémy. Chcete-li požádat o balíček oprav hotfix, který se vztahuje k jednomu nebo oboum operačním systémům, vyberte opravu hotfix, která je uvedena na stránce v části "Windows 7/Windows Server 2008 R2". Vždy se v článcích podívejte v části "Platí pro" na to, pro který operační systém je oprava hotfix určená.

  • Soubory týkající se konkrétního produktu, SR_Level (RTM, SPn) a služby (LDR, GDR) lze identifikovat porovnáním čísel verzí souborů podle následující tabulky:

    Verze

    Výrobek

    Milník

    Složka služby

    6.1.760
    1.22 xxx

    Windows Server 2008 R2

    SP1

    LDR

  • Soubory MANIFEST (.manifest) a soubory MUM (.mum) instalované pro každé prostředí jsou uvedeny samostatně v části "Další informace o souborech pro systém Windows Server 2008 R2". MUM a MANIFEST soubory a soubory katalogu (CAT) přidružené zabezpečení, jsou velice důležité k uchování stavu aktualizované součásti. Soubory katalogu zabezpečení, pro něž nejsou uvedeny atributy, jsou podepsané digitálním podpisem společnosti Microsoft.

Pro všechny podporované verze systému Windows Server 2008 R2 x64

Název souboru

Verze souboru

Velikost souboru

Datum

Čas

Platforma

Netlogon.dll

6.1.7601.22289

699,904

01-Apr-2013

07:33

x64

Pro všechny podporované verze IA-64 systému Windows Server 2008 R2

Název souboru

Verze souboru

Velikost souboru

Datum

Čas

Platforma

Netlogon.dll

6.1.7601.22289

1,158,144

01-Apr-2013

04:23

IA-64


Stav

Společnost Microsoft potvrdila, že se jedná o problém v produktech společnosti Microsoft, které jsou uvedeny v části "Platí pro".

Další informace

Pro další informace o terminologii používané v aktualizacích softwaru, klepněte na následující číslo článku k zobrazení článku v databázi Microsoft Knowledge Base:

824684 Popis standardní terminologie používané k popisu aktualizací softwaru společnosti Microsoft

Další informace o souborech pro systém Windows Server 2008 R2

Další soubory pro všechny podporované verze systému Windows Server 2008 R2 x64

Název souboru

Amd64_microsoft-windows-security-netlogon_31bf3856ad364e35_6.1.7601.22289_none_5c208d1b67eb79b1.manifest

Verze souboru

Není k dispozici

Velikost souboru

35,995

Datum (čas UTC)

01-Apr-2013

Čas (UTC)

08:04

Platforma

Není k dispozici

Název souboru

Wow64_microsoft-windows-security-netlogon_31bf3856ad364e35_6.1.7601.22289_none_6675376d9c4c3bac.manifest

Verze souboru

Není k dispozici

Velikost souboru

16,596

Datum (čas UTC)

01-Apr-2013

Čas (UTC)

04:44

Platforma

Není k dispozici

Další soubory pro všechny podporované verze IA-64 systému Windows Server 2008 R2

Název souboru

Ia64_microsoft-windows-security-netlogon_31bf3856ad364e35_6.1.7601.22289_none_0003958daf8c1177.manifest

Verze souboru

Není k dispozici

Velikost souboru

35,992

Datum (čas UTC)

01-Apr-2013

Čas (UTC)

04:52

Platforma

Není k dispozici

Název souboru

Wow64_microsoft-windows-security-netlogon_31bf3856ad364e35_6.1.7601.22289_none_6675376d9c4c3bac.manifest

Verze souboru

Není k dispozici

Velikost souboru

16,596

Datum (čas UTC)

01-Apr-2013

Čas (UTC)

04:44

Platforma

Není k dispozici


Potřebujete další pomoc?

Chcete další možnosti?

Prozkoumejte výhody předplatného, projděte si školicí kurzy, zjistěte, jak zabezpečit své zařízení a mnohem více.

Komunity vám pomohou klást otázky a odpovídat na ně, poskytovat zpětnou vazbu a vyslechnout odborníky s bohatými znalostmi.

Byly tyto informace užitečné?

Jak jste spokojeni s kvalitou jazyka?
Co ovlivnilo váš názor?
Po stisknutí tlačítka pro odeslání se vaše zpětná vazba použije k vylepšování produktů a služeb Microsoftu. Váš správce IT bude moci tato data shromažďovat. Prohlášení o zásadách ochrany osobních údajů.

Děkujeme vám za zpětnou vazbu.

×