Přihlásit se pomocí účtu Microsoft
Přihlaste se nebo si vytvořte účet.
Dobrý den,
Vyberte jiný účet.
Máte více účtů.
Zvolte účet, pomocí kterého se chcete přihlásit.

Kb 978268

Příznaky

Při pokusu o přiřazení nově vytvořeného plánu platby v skupině HRMSSS (Human Resource Self Service Suite) pro obchodní portál (BP) v Microsoft Dynamics GP nebo změně existujícího plánu platby se zobrazí jedna z následujících chybových zpráv:

 

Mzdový plán obsahuje data, která se překrývají s aktivním plánem mzdy z minulého roku. Nelze uložit dva aktivní plány placení, které sdílejí kalendářní data.

nebo

Platební období přiřazená k tomuto výplatnímu plánu neodpovídají frekvenci platby. Přepočet mzdových období v plánu mzdy

Příčina

K problému s první zprávou nahoře dochází, protože počáteční datum období 1 v novém výplatní kalendáři se překrývají s datem v posledním období předchozího plánu platby. Modul HRMSSS ale vyžaduje, aby byl plán platby dlouhý 365 dní a neumožňují přeskakování nebo překrývání dat mezi dvěma plány.


Problém s druhou zprávou nahoře spočívá v tom, že výplatní plán je dlouhý 364 dní a systém vyžaduje, aby byl 365 dní dlouhý, než budou povoleny jakékoli změny, nebo se může vytvořit nový plán platby vedle něj.
 

Řešení


Příklad:

Řekněme, že váš plán placení 2021 běží od 23. prosince 2021 do 22. prosince 2022. V tomto příkladu byste chtěli vytvořit nový plán placení s názvem "2022", který začíná 22. prosince 2022, ale nemůžete to udělat, protože ho už používal předchozí výplatní plán. 

Plán platby: Počáteční datum – koncové datum

2021: je aktuálně nastavená pro data 23. 12. 2021 – 22. 12. 2022

2022: chcete data 22. 12. 2022 – 21. 12. 2023; Tento nový plán chcete spustit 22. 12. 2022, ale nemůžete ho použít, protože toto datum už platový plán předchozího roku používal. 

Poznámka: Systém vyžaduje, aby se "název" období shoduje s razítkem "rok" v "počátečním datu" v tomto výplatní kalendáři.

Tento problém můžete vyřešit jedním z následujících způsobů:

  • Pokud používáte BP 4.0 s Microsoft Dynamics GP 10.0, použijte metodu 1 nebo metodu 2 níže.

  • Pokud používáte BP 5.0 nebo BP 5.1 s Microsoft Dynamics GP 2010 nebo BP 6.0/6.1 s Microsoft Dynamics GP 2013 a máte 27 období (dvoutýdenní) nebo 53 období (týdně), použijte níže metodu 1 nebo metodu 2.

  • Pokud používáte BP 5.0 nebo BP 5.1 s Microsoft Dynamics GP 2010 nebo BP 6.0/6.1 s Microsoft Dynamics GP 2013 a máte 26 období (dvoutýdenní) nebo 52 období (týdně), protože jste kliknuli na možnost Použít pouze úplná období platby, použijte níže metodu 1 nebo metodu 3. Plán placení 2021 (s použitím jenom celých období) vypadá, že končí 21. 12. 2022, ale nedovolí vám vytvořit nový plán pro rok 2022, který začíná 22. 12. 2022, i když toto datum nebylo v předchozím plánu výplaty použito.

Metoda 1: Zrušení přiřazení minulého plánu platby, aby se na něj systém ne podíval.


Pokud jste skončili s používáním minulého plánu placení a všechny tyto časové karty jsou schváleny až do dokončení, můžete jednoduše zrušit přiřazení tohoto plánu mzdy od všech zaměstnanců a systém ho už nebude považovat. Pak budete moct vytvořit nový plán placení počínaje datem, které si budete přát. Toto je nejrychlejší a nejjednodušší způsob, jak tento problém vyřešit, pokud můžete počkat, až se už nebude používat předchozí plán, a všechny časové karty, které používají tento plán platby, byly schváleny nebo dokončeny.

1. Přihlaste se k bp jako správce.

2. Klikněte na kartu Správa.

3. Klikněte na Nastavení karty Timecard.

4. Vyberte správný plán platby a klikněte na tlačítko Přiřadit.

5. V rozevíracím seznamu Omezit podle vyberte Oddělení a klikněte na Zrušit označení všech. Potom omezte podle zaměstnance a vyberte Zrušit označení všech. (Zkontrolujte také podle umístění a umístění, i když se méně často používají.) Uložit.

6. Teď můžete kliknout na Přidat a vytvořit nový plán placení počínaje datem, které si budete přát.



Poznámka: Neodstraňovat předchozí plán platby z portálu Business Portal. Plán mzdy musí existovat, aby bylo možné zobrazit historická data. Pokud se ale z okna Plán mzdy odstraní minulé výplatní plány, můžete ho jednoduše vytvořit znovu, ale nepořazovat ho žádným zaměstnancům. Jenom musí existovat, aby se historie časových karet v minulosti zobrazuje.

Metoda 2: Změna kalendářních dat v plánu platby, pokud máte 27 nebo 53 období pomocí skriptů Microsoft SQL.

Poznámka: Než budete postupovat podle pokynů v tomto článku, ujistěte se, že máte úplnou záložní kopii databáze, kterou můžete obnovit, pokud dojde k problému.


Další poznámky:

  • Doporučujeme vytvořit zálohu. Všimněte si počátečních a koncových dat pro všechny výplatní plány, abyste mohli SQL skripty.

  • Doporučujeme, abyste schvalili všechny časové karty v výplatní kalendáři, který se má změnit. Proto postupujte podle těchto pokynů až do konce platebního plánu.


Cílem následujících kroků je přejmenovat poslední období (období 27 nebo období 53) na období 0, takže systém přesune toto období na začátek plánu. Potom změníme razítko roku v tomto období, takže den navíc se přidá na začátek plánu v předchozím roce a odebere se z konce plánu, aby se toto datum ulehčí. Takže v podstatě se tím plán posune o jeden den dřív (nebo 22. 12. 2020– 21. 12. 2021). Musíme to udělat, protože systém pořád vyžaduje, aby plán byl dlouhý 365 dní. 

Krok 1
Spuštěním příslušného skriptu změňte hodnotu ID období z hodnoty dvoutýdenní nebo týdenní na 0 následujícím způsobem. Tím se poslední období přesune na začátek výplatního plánu:

BIWEEKLY:
update HRM_PayPeriod set PayPeriodID ='0' where PayPeriodID ='27' and yearid='2021' and frequencyid ='2'
WEEKLY:
update HRM_PayPeriod set PayPeriodID ='0' where PayPeriodID ='53' and yearid='2021' and frequencyid ='1'



Poznámka: Ve výše uvedeném skriptu aktualizujte YEARID tak, aby byl název starého plánu placení. Tyto příkladové skripty pokrývají jenom týdenní a dvoutýdenní, ale úpravy vhodných způsobem používejte i v případě, že váš plán má jinou frekvenci, například měsíční nebo půlměsíční. Otevřete prosím případ podpory, abyste tyto hodnoty vložili do skriptu.
 

Krok 2

Spuštěním příslušného skriptu níže změňte hodnotu Název období tak, aby odpovídala:

BIWEEKLY:
update HRM_PayPeriod set Name = 'Period 0' where Name = 'Period 27' and Yearid = '2021' and frequencyid = '2'

WEEKLY:
update HRM_PayPeriod set Name = 'Period 0' where Name = 'Period 53' and Yearid = '2021' and frequencyid = '1'





Krok 3
Teď budete muset změnit počáteční a koncové datum v období 0 na předchozí rok, takže se přičte den navíc na začátek plánu platby. Spuštěním obou skriptů nejdříve změňte počáteční datum pro období 0 a koncové datum pro období 0:

BIWEEKLY:
update HRM_PayPeriod set BeginDate ='2021-12-22' where payperiodid ='0' and yearid='2021' and frequencyid ='2'

update HRM_PayPeriod set EndDate ='2021-12-22' where payperiodid ='0' and yearid='2021' and frequencyid ='2'


WEEKLY:
update HRM_PayPeriod set BeginDate ='2021-12-22' where payperiodid ='0' and yearid='2021' and frequencyid ='1'

update HRM_PayPeriod set EndDate ='2021-12-22' where payperiodid ='0' and yearid='2021' and frequencyid ='1'

Poznámka: Datum v posledním období bylo 22. 12. 12. 2022 a vy jste ho teď změnili na 22. 12. 2021–22. 12. 2021, což přidá další den na začátek plánu změnou pouze razítka roku. Období 26 nebo 52 končí 21. 12. 2022.



Krok 4
Spuštěním následujícího skriptu aktualizujte tabulku HRM_PaySchedule tak, aby odpovídala novému počátečnímu datu období 0 v HRM_PayPeriod tabulce:

BIWEEKLY:
update HRM_payschedule set BeginDate='2021-12-22' where yearid='2021' and frequencyid ='2'

WEEKLY:

update HRM_payschedule set BeginDate='2021-12-22' where yearid='2021' and frequencyid ='1'

Poznámka: Pokud chcete ověřit, že hodnota BeginDate v tabulce HRM_PaySchedule odpovídá hodnotě BeginDate tečky 0 v tabulce HRM_PayPeriod, spusťte následující skript:

BIWEEKLY:
Select BeginDate, * from HRM_PayPeriod where yearid ='2021' and frequencyid = 2 and PayPeriodID = 0
Select BeginDate, * from HRM_PaySchedule where yearid ='2021' and frequencyid = 2

WEEKLY:
Select BeginDate, * from HRM_PayPeriod where yearid ='2021' and frequencyid = 1 and PayPeriodID = 0
Select BeginDate, * from HRM_PaySchedule where yearid ='2021' and frequencyid = 1
 


Krok 5
Teď můžete vytvořit nový plán placení pro rok 2022 s počátečním datem "22. 12. 2022". V aplikaci BP klikněte na kartu Správa a klikněte na Nastavení karty Timecard. Klikněte na tlačítko Přidat v části Výplatní plány. Zadejte četnost a počáteční datum ze dne 22. 12. 2022 a klikněte na Vypočítat platební období. Uložit.


Poznámka: Nový výplatní plán také vytvoří další období 27 nebo období 53 pro den navíc (protože 365 není dělitelné 7). V tuto chvíli ale nedoporučujeme měnit období navíc. V opačném případě se výplatní plán znovu překrývá s předchozím aktuálním plánem mzdy, takže byste měli počkat na konec roku, abyste ho upravoval.


Krok 6
Vyberte plán mzdy a kliknutím na tlačítko Přiřadit přiřaďte nový plán oddělením, místům, konkrétním zaměstnancům nebo pozicím.



 

Metoda 3: Změna kalendářních dat v plánu mzdy, pokud máte 26 nebo 52 období pomocí skriptů Microsoft SQL.



Poznámka: Než budete postupovat podle pokynů v tomto článku, ujistěte se, že máte úplnou záložní kopii databáze, kterou můžete obnovit, pokud dojde k problému.


Další poznámky:

  • Doporučujeme vytvořit zálohu. Všimněte si počátečních a koncových dat pro všechny výplatní plány, abyste mohli SQL skripty.

  • Doporučujeme, abyste schvalili všechny časové karty v výplatní kalendáři, který se má změnit. Proto postupujte podle těchto pokynů až do konce platebního plánu.



V tomto příkladu se stávající plán placení 2021 používá od 23. 12. 2021 do 21. 12. 2022 (a má 26 nebo 52 výplatní období). Chcete změnit stávající mzdový plán nebo vytvořit nový plán, který začíná 22. 12. 2022, ale stále se zobrazí chybová zpráva, i když toto datum stávající mzdový plán nevyužírá. Systém vám nedovolí vytvořit nový plán placení, protože předchozí plán není dlouhý 365 dní.  


Cílem níže uvedených kroků je přidat do stávajícího plánu další den, aby byl dlouhý 365 dní, takže pak budete moct vytvořit nový plán placení. 

Krok 1
Zkontrolujte aktuální data v období 1 a posledním období (období 26 nebo období 52) ve stávajícím plánu mzdy:

BIWEEKLY: Select * from HRM_PayPeriod where yearid='2021' and frequencyid ='2'
WEEKLY: Select * from HRM_PayPeriod where yearid='2021' and frequencyid ='1'



Poznámka: Ve výše uvedeném skriptu aktualizujte YEARID tak, aby byl název existujícího plánu placení. Tyto příkladové skripty pokrývají jenom týdenní a dvoutýdenní, ale úpravy vhodných způsobem používejte i v případě, že váš plán má jinou frekvenci, například měsíční nebo půlměsíční. Otevřete prosím případ podpory, abyste tyto hodnoty vložili do skriptu.

Krok 2

Zálohujte počáteční datum v období 1 o jeden den a přidejte den navíc na začátek plánu placení, aby byl dlouhý 365 dní.

BIWEEKLY:
update HRM_PayPeriod set BeginDate ='2021-12-22' where payperiodid ='1' and yearid='2021' and frequencyid ='2'


WEEKLY:
update HRM_PayPeriod set BeginDate ='2021-12-22' where payperiodid ='1' and yearid='2021' and frequencyid ='1'

Poznámka: Pokud se přidání počátečního data překrývají s plánem mzdy předchozího roku, možná budete muset nejdřív zrušit přiřazení starého plánu od všech zaměstnanců, aby se o něj systém nestará a neviděl další překrývající se problém.



Poznámka: Díky tomu bude výplatní plán od 22. 12. 2021 do 21. 12. 2022, který přidá den navíc na začátek plánu, aby byl dlouhý 365 dní. 


Krok 3
Spuštěním následujícího skriptu aktualizujte tabulku HRM_PaySchedule tak, aby odpovídala novému počátečnímu datu období 1 v HRM_PayPeriod tabulky:

BIWEEKLY:
update HRM_payschedule set BeginDate='2021-12-22' where yearid='2021' and frequencyid ='2'

WEEKLY:
update HRM_payschedule set BeginDate='2021-12-22' where yearid='2021' and frequencyid ='1'

Poznámka: Pokud chcete ověřit, že hodnota BeginDate v tabulce HRM_PaySchedule odpovídá hodnotě BeginDate tečky 0 v tabulce HRM_PayPeriod, spusťte následující skript:

BIWEEKLY:
Select BeginDate, * from HRM_PayPeriod where yearid ='2021' and frequencyid = 2 and PayPeriodID = 0
Select BeginDate, * from HRM_PaySchedule where yearid ='2021' and frequencyid = 2

WEEKLY:
Select BeginDate, * from HRM_PayPeriod where yearid ='2021' and frequencyid = 1 and PayPeriodID = 0
Select BeginDate, * from HRM_PaySchedule where yearid ='2021' and frequencyid = 1


Krok 4
Teď můžete vytvořit nový plán placení pro rok 2022 s počátečním datem "22. 12. 2022". V aplikaci BP klikněte na kartu Správa a klikněte na Nastavení karty Timecard. Klikněte na tlačítko Přidat v části Výplatní plány. Zadejte četnost a počáteční datum ze dne 22. 12. 2022 a klikněte na Vypočítat platební období. Uložit.


Poznámka: Nový výplatní plán také vytvoří další období 27 nebo období 53 pro den navíc (protože 365 není dělitelné do 7) nebo pokud použijete možnost Použít pouze úplná období placení, vytvoří se 26 nebo 52 platných období znovu. V tuto chvíli ale nedoporučujeme měnit období navíc. V opačném případě se výplatní plán znovu překrývá s předchozím aktuálním plánem mzdy, takže byste měli počkat na konec roku, abyste ho upravoval.


Krok 5
Vyberte plán mzdy a kliknutím na tlačítko Přiřadit přiřaďte nový plán oddělením, místům, konkrétním zaměstnancům nebo pozicím.

 

Potřebujete další pomoc?

Chcete další možnosti?

Prozkoumejte výhody předplatného, projděte si školicí kurzy, zjistěte, jak zabezpečit své zařízení a mnohem více.

Komunity vám pomohou klást otázky a odpovídat na ně, poskytovat zpětnou vazbu a vyslechnout odborníky s bohatými znalostmi.

Byly tyto informace užitečné?

Jak jste spokojeni s kvalitou jazyka?
Co ovlivnilo váš názor?
Po stisknutí tlačítka pro odeslání se vaše zpětná vazba použije k vylepšování produktů a služeb Microsoftu. Váš správce IT bude moci tato data shromažďovat. Prohlášení o zásadách ochrany osobních údajů.

Děkujeme vám za zpětnou vazbu.

×