Platí proSQL Server 2016 Developer - duplicate (do not use) SQL Server 2016 Enterprise - duplicate (do not use) SQL Server 2016 Enterprise Core - duplicate (do not use) SQL Server 2016 Standard - duplicate (do not use)

Příznaky

Předpokládejme, že používáte SQL Server 2016 nebo 2017. Při dotazování na data v zóně šifrování pomocí Hadoop úspěšně funguje vše. Po uplynutí 10 hodin však dotaz selže a vygeneruje následující chybovou zprávu v Dms_polybase. log. Ačkoliproblém může být vyřešen, když restartujete základnu je možné, že dotazpo 10 hod.

org. Apache. Hadoop. Security. Authentication. Client. AuthenticationException: GSSException: nejsou zadané žádné platné přihlašovací údaje (úroveň mechanismu: nenašel se žádný lístek služby Kerberos).

Příčina

K tomuto problému dochází, protože není automaticky obnovit lístek TGT (Kerberos ticket granting ticket). Platnost lístku vyprší 10 hodin po vytvoření.

Stav

Společnost Microsoft potvrzuje, že se jedná o problém v produktech této společnosti, které jsou uvedeny v části Informace v tomto článku jsou určeny pro produkt.

Řešení

Tento problém je opravený v následujících kumulativních aktualizacích systému SQL Server:

O kumulativních aktualizacích pro SQL Server:

Každá nová kumulativní aktualizace pro SQL Server obsahuje všechny opravy hotfix a všechny opravy zabezpečení, které byly součástí předchozí kumulativní aktualizace. Podívejte se na nejnovější kumulativní aktualizace SQL serveru:

Odkazy

Informace o terminologii používané společností Microsoft k popisu aktualizací softwaru.

Potřebujete další pomoc?

Chcete další možnosti?

Prozkoumejte výhody předplatného, projděte si školicí kurzy, zjistěte, jak zabezpečit své zařízení a mnohem více.