Příznaky
V Commerce Server 2009 R2 Service Pack 1 (SP1) můžete konfigurovat katalogu Export výraz pracovní v katalogu pracovní možnosti. Nicméně pokud je vybrána možnost Všechny úrovně , klauzule filtru potomky nepracuje podle očekávání.
Příčina
K tomuto problému dochází při uložená procedura (ctlg_StoreFilteredCatalogItemsToExport). Tento proces prochází struktura katalogu, vyhledat a Přidat následovníky pro export. Při posledním kole při postupu pokusí přidat zpět chybějící skupiny výrobků klauzuli filtru se nepoužívá.
Řešení
Chcete-li vyřešit tento problém, nainstalujte následující opravu hotfix.Pokyny k instalaci .
K dokončení instalace této opravy hotfix, naleznete v částiInformace o opravě hotfix
Společnost Microsoft má k dispozici podporovanou opravu hotfix. Tato oprava hotfix je však určena opravit pouze problému popsaného v tomto článku. Tuto opravu hotfix instalujte pouze do systémů, ve kterých dochází k potížím popsaným v tomto článku. Tato oprava hotfix může být dále testována. Proto pokud nejste vážně ohrožen tímto problémem, doporučujeme počkat na další aktualizaci softwaru, která obsahuje tuto opravu hotfix.
Pokud je oprava hotfix k dispozici ke stažení, je v horní části tohoto článku znalostní báze Knowledge Base oddíl "Oprava Hotfix je dostupná ke stažení" . Pokud tato sekce není uvedena, obraťte se na Zákaznický servis a podporu společnosti Microsoft k získaní opravy hotfix. Poznámka: Pokud nastanou další problémy nebo bude nutné další řešení potíží, bude možná třeba vytvořit další samostatný požadavek na služby. Běžná cena za technickou podporu se vztahuje k dodatečným otázkám podpory a k problémům, které se netýkají této konkrétní opravy hotfix. Pro úplný seznam telefonních čísel společnosti Microsoft Zákaznikého servisu a podpory nebo chcete-li vytvořit zvláštní požadavek na službu navštivte následující web společnosti Microsoft:http://support.microsoft.com/contactus/?ws=supportPoznámka: Ve formuláři „Oprava hotfix je dostupná ke stažení“ se zobrazují jazyky, pro které je oprava hotfix k dispozici. Pokud váš jazyk není zobrazen, to je protože oprava hotfix není k dispozici pro daný jazyk.
Předpoklady
Chcete-li nainstalovat tuto opravu hotfix, musí mít Service Pack 1 pro Commerce Server 2009 R2 nainstalován.
Pokyny k instalaci
K dokončení instalace této opravy hotfix, spusťte soubor Kb2931431.sql proti všechny existující databáze katalogu.
Informace o restartování počítače
Po instalaci této opravy hotfix nemusíte restartovat počítač.
Informace o nahrazení
Tato oprava hotfix nenahrazuje dříve vydanou opravu hotfix.
Informace o souborech
Anglická verze této opravy hotfix má atributy (nebo pozdější atributy souborů) uvedené v následující tabulce. Kalendářní data a časy jednotlivých souborů jsou uvedeny v koordinovaném světovém čase (UTC). Při zobrazení informací o souboru je převeden na místní čas. Rozdíl mezi místním časem a časem UTC naleznete na kartě Časové pásmo v položce Datum a čas v okně Ovládací panely.
Název souboru |
Verze souboru |
Velikost souboru |
Datum |
Čas |
Platforma |
---|---|---|---|---|---|
Catalogcreate.sql |
Není k dispozici |
1,166,263 |
25-Feb-2014 |
12:33 |
Není k dispozici |
Kb2931431.sql |
Není k dispozici |
8,680 |
04-Feb-2014 |
13:20 |
Není k dispozici |
Poznámka: Vzhledem k závislostem souborů může nejnovější oprava, která obsahuje tyto soubory také obsahovat další soubory.
Stav
Společnost Microsoft potvrdila, že se jedná o problém v produktech společnosti Microsoft, které jsou uvedeny v části "Platí pro".
Odkazy
Další informace o terminologii , kterou společnost Microsoft používá k popisu aktualizací softwaru.